Cómo cambiar la versión de JDK para un proyecto de Eclipse

Necesito escribir un proyecto que solo sea compatible con Java 1.5. Tengo Java 1.6 instalado. ¿Hay algún tipo de compatibilidad con versiones anteriores para que Eclipse compile con 1.5?

¿Tengo que instalar Java 1.5 para que se muestre aquí? O tal vez hay otra manera?

Ingrese la descripción de la imagen aquí .

Haga clic en el botón Agregar biblioteca . Hace que su pantalla apunte a la ubicación de Java.

Seleccione ” Directorio “, el botón a la derecha de JRE y señale la ubicación de la carpeta instalada.

Aunque solo desee un proyecto de comstackción de 1.5, puede lograrlo cambiando la configuración del comstackdor en Eclipse en lugar de eliminar 1.6 JRE y agregar 1.5 JRE.

GOTO -->JAVA--Compiler---> and change compiler level to `1.5` instead of `1.6` 

Como David sugirió,

Solo tenga cuidado, especialmente si está configurando esto para que trabaje un equipo de personas. Si alguien usa algo nuevo o modificado en 1.6, se comstackrá, pero no se ejecutará en un entorno con JRE 1.5.

Haga clic en la pestaña Ventana en Eclipse, vaya a Preferencias y cuando aparezca esa ventana, vaya a JavaJRE instaladosEntorno de ejecución y seleccione JavaSE-1.5. Luego debe ir al comstackdor y establecer el nivel de cumplimiento del comstackdor .

Cambiando JRE

Ingrese la descripción de la imagen aquí

Haga clic derecho en proyecto -> Propiedades -> Ruta de comstackción Java -> seleccione Biblioteca de sistema JRE, haga clic en Editar y seleccione JDK o JRE luego haga clic en Comstackdor Java y seleccione Nivel de cumplimiento del comstackdor en 1.8.

enter image description here

enter image description here

enter image description here

Eclipse – Cambio de proyecto específico Versión JDK –

Si desea cambiar cualquier versión de jdk de un proyecto específico, debe hacer clic en —> Proyecto -> Biblioteca de sistemas de JRE -> Propiedades —> Contenedor de rutas de clases internas (Biblioteca de sistemas de JRE) cambie el entorno de ejecución al que alguna versión que desee, por ejemplo 1.7 o 1.8.

Consulte la página Configurar JDK en Eclipse . Desde el botón Agregar, puede agregar una versión diferente del JDK …

El JDK (JAVA_HOME) utilizado para iniciar Eclipse no es necesariamente el utilizado para comstackr su proyecto.

Para ver qué JRE puede seleccionar para su proyecto, verifique las preferencias:

GeneralJRE instalado en Java

De forma predeterminada, si no ha agregado ningún JRE, el único declarado será el utilizado para lanzar Eclipse (que se puede definir en su eclipse.ini ).

Puede agregar cualquier otro JRE que desee, incluido uno compatible con su proyecto.

Después de eso, deberá verificar en las propiedades de su proyecto (o en las preferencias generales) qué JRE se utiliza, con qué nivel de cumplimiento:

Texto alternativo http://www.standartux.fr/public/Java/Preferences.png

En la sección de preferencias en Java -> JRE instalados, haga clic en el botón Agregar y navegue a la carpeta de inicio de 1.5 JDK. Luego, verifique esa en la lista y se convertirá en la predeterminada para todos los proyectos:

enter image description here

Como me enfrentaba a este problema hace unos minutos, en caso de que intentes abrir un proyecto existente en un entorno con un JDK más nuevo, asegúrate de actualizar la versión de JDK en Propiedades del proyecto -> Facetas del proyecto -> Java.