ADT 22.2 Asistente de nueva aplicación: dependencia de plantilla no compatible: actualice su complemento de Android Eclipse

Encontré algunas respuestas a ese problema pero ninguna me funcionó. Al obtener la última pantalla en una nueva creación de proyecto, recibo el siguiente mensaje:

Dependencia de plantilla no compatible: actualice su complemento de Android Eclipse

La versión requerida está vacía (en algunos casos aparece como 8). La versión instalada es 18.

Ya probé muchas de las soluciones que encontré aquí, como:

  • Ejecute el administrador de SDK como administrador
  • Ejecute Eclipse como administrador
  • Vuelva a instalar los componentes de soporte de la carpeta adicional SDK y luego reinicie Eclipse,

Ninguno de estos no funcionó para mí.

¿Hay alguna otra solución?

Actualización 2: Ahora (2013-09-19T17: 00: 00Z) hay un ADT 22.2.1 y las actualizaciones de Herramientas 22.2.1 disponibles que solucionan este problema:

  • Use Eclipse> Ayuda> Buscar actualizaciones para obtener ADT 22.2.1
  • Use SDK Manager para obtener las Herramientas 22.2.1

Necesita ambas partes para solucionar el problema. El paquete ADT y el paquete instalador en http://developer.android.com/sdk/index.html también se han actualizado.

(De aquí )


Actualización : el informe de errores ahora tiene una respuesta con archivos de plantillas fijas adjuntas y los siguientes comentarios:

Este es mi mal. Estaba en el medio de cambiar el sistema de dependencia utilizado por las plantillas y un estado transitorio se recogió en esta construcción de herramientas. Las plantillas se han establecido en la twig principal de AOSP.

He adjuntado una instantánea de las plantillas de Actividades actuales. Reemplazar su carpeta sdk / tools / templates / activities con el contenido de este zip debería resolver este problema.

Pido disculpas por las molestias.

Mi anterior solución alternativa a continuación.


Solución al error :

Para actividad en blanco :

  1. Editar /tools/templates/activities/BlankActivity/template.xml

  2. Comenta la dependencia:

      

Para el flujo maestro / detalles :

  1. Edite /tools/templates/activities/MasterDetailFlow/template.xml

  2. Comenta las dependencias:

      

Finalmente:

  • Reiniciar Eclipse

Si es necesario, copie android-support-v4.jar desde /extras/support/v4 en sus libs .

@ Šantić A. Miroslav – No estoy seguro de por qué, pero eliminar las herramientas SDK no se degrada a la versión anterior. La carpeta /tools simplemente desapareció y se produjo un error de ruta de acceso no encontrado .


Intenté descargar desde http://dl-ssl.google.com/android/repository/tools_r22-windows.zip , descomprimirlo y reemplazarlo con la carpeta /tools para degradar las herramientas SDK, y funcionó para yo.

Tengo el mismo problema. Sucede cuando actualicé las herramientas de Android SDK a Rev. 22.2. La degradación a una versión anterior eliminará el problema.

Me estaba enfrentando el mismo problema en las últimas horas, y lo resolví … descargué el SDK (para mi Mac) desde el siguiente enlace.

[Para Mac] http://dl-ssl.google.com/android/repository/tools_r22-macosx.zip

[Para Windows] http://dl-ssl.google.com/android/repository/tools_r22-windows.zip

[Para Linux] http://dl-ssl.google.com/android/repository/tools_r22-linux.zip

Fui a directorio instalado Android -> herramienta y reemplacé todo el contenido con los archivos descargados.

Reinicié Eclipse, ejecuté New Project , ¡y está funcionando bien!

Por favor prueba mi solución:

  1. Crea un nuevo proyecto usando la línea de comando
    • Notas: NO lo cree en el espacio de trabajo de Eclipse, créelo en otro lugar, por ejemplo, ~/tmp/
    • eg android create project --target 1 --name MyAndroidApp --path ./MyAndroidAppProject --activity MyAndroidAppActivity --package com.example.myandroid
  2. Luego, en Eclipse, ” Importar ” el proyecto que acaba de crear

Solución de trabajo

Descargué el adt-bundle-windows-x86_64-20130729 de http://burnbit.com/torrent/251451/adt_bundle_windows_x86_64_20130729_zip . Después de actualizar, también recibí el mismo error que obtuviste. Sin actualizar, creé el proyecto, por lo que ahora se está ejecutando. Entonces haz este paso. Este error viene por una discrepancia de versión. Entonces haz este paso.

Espero que esto solucione tu problema.

Hay un error en la última versión de SDK. Por favor descárguelo a r_22. Esto funciona para mi.

Necesita actualizar su complemento ADT para ello. La última versión de una herramienta Android SDK es 22.2.1 y para eso necesita el paquete ADT 22.2.1. El enlace de descarga es http://www.softpedia.com/get/Programming/Components-Libraries/Android-Development-Tools.shtml