la página se carga dos veces en Google Chrome

¿Alguien tiene algún problema con la ejecución de Page_Load dos veces en Google Chrome? Es una pregunta corta, no sé qué más explicar …

Tengo una página simple de asp.net y en Firefox e IE todo está funcionando bien. Pero en Chrome, Page_Load se dispara dos veces …

Alguien tiene alguna idea de por qué?

EDITACIÓN posterior: – lo que es extraño es que tengo 4 repetidores … enlazados con valores aleatorios. Los métodos aleatorios se activan dos veces (debido a que la página se carga dos veces) pero los repetidores toman los valores INICIALMENTE … por lo tanto, la segunda publicación posterior se genera de alguna manera después del paso de representación.

Tercera edición: ¡SÓLO sucede en la actualización!

Solución (en mi caso): había un img src vacío, y esa fue la causa

Noto este mismo problema en IE si la página contiene tags img que no tienen un atributo src (o el src está vacío, etc.). No estoy seguro si Chrome hace lo mismo, pero vale la pena verificarlo, ¿verdad?

Para mí, el problema fue debido a la extensión Firebug Lite para Google Chrome . Una vez desactivada, la página solo se carga una vez.

Tuve un problema muy similar: Chrome y Firefox cargaban la página dos veces, Internet Explorer la cargaba una vez.

El problema fue debido a mi .htaccess :

 RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule ^(.*)$ index.php [QSA,L] 

Cuando los navegadores solicitaban un favicon.ico, se llamaba a mi página index.php, creando así un doble acceso al servidor. Mi solución fue crear un favicon.ico, aunque también podría tener index.php manejar ese caso especial, o incluso .htaccess, pero necesitaba un favicon.ico de todos modos 🙂

Tuve el mismo problema estúpido. La página se carga dos veces y las actualizaciones se quedaron en blanco.

Gracias a esta publicación revisé mi hoja de CSS.

Eliminé esta línea:

cuerpo {background-image: url (); }

Ese era el problema

Hace poco tuve este problema con el procesamiento de Chrome dos veces también, la causa de este problema es

  

una vez que lo configuré

  

o elimine completamente iframe, entonces la doble representación ya no aparece.

Además de la respuesta de Chris Shaffer, que me puso en el camino correcto, me gustaría añadir que en mi caso también había una etiqueta con un src vacío que causaba el problema.

Tal vez se aplica a todos los elementos con un src vacío.

Hasta ahora he usado Chrome para probar páginas ASP.NET muchas veces y nunca he encontrado esto. ¿Qué estás haciendo del lado del cliente que podría causar esto? ¿Estás haciendo algo de AJAX?

Noté que esto comenzó a sucederme cuando cambié a Chrome v.4, el canal del desarrollador, para poder comenzar a usar extensiones. No parecía ser un problema con v.3, la versión estable.

En su Page_Load, verifique el valor de Page.IsPostBack y Page.IsCallback para ver si difieren entre las dos llamadas. Si son diferentes, podría ser un reinicio de Javascript o Chrome siguiendo un redireccionamiento dos veces o algo así.

Encontré un problema similar con PHP y Firefox.

El problema provenía de una definición de estilo defectuosa que Firefox interpretó para volver a cargar la página. No recuerdo exactamente qué era, pero la idea puede ser algo así como

 .my_class { background: url(#); } 

Aconsejaría intentar aislar primero su CSS y luego sus secciones de HTML para verificar si el problema podría provenir de él.

Si configuras la etiqueta de imagen src en # o la vacías provocará dos llamadas de carga de página, me enfrenté a esto en Chrome y antes en Firefox.

puede poner cualquier valor de cadena o carácter en lugar de vacío o # para resolver este problema.

Tampoco les gusta los href vacíos

Tenía una etiqueta de enlace de favicon vacía e hizo lo mismo. Quien haya dicho sobre el disco vacío me puso sobre eso, simplemente quitó todo hasta que comenzó a funcionar

Los navegadores basados ​​en Gecko aparentemente hacen esto cuando el marcado es incorrecto. Eso significa XHTML Y CSS.

Aquí hay una gran publicación sobre el tema: http://www.110mb.com/forum/how-to-stop-firefox-dual-pageloads-t27704.0.html

Es por eso que algunos de ustedes están teniendo el problema cuando tienen un atributo src en blanco o un atributo href en blanco. Sintaxis incorrecta, el navegador lo lee como un “error”. Supongo que es un tipo de error más discreto que ni siquiera notarías, pero debido a la naturaleza de la página en la que estás trabajando se ha vuelto aparente y se ha presentado como un problema más bien molesto.

Lo que ciertos navegadores consideran como un “error” y lo que es “aceptable” probablemente también sea ligeramente diferente, eso explicaría por qué algunos de ustedes tienen el problema en FF y no en Chrome y viceversa.

Solo agradece que no estés en mi lugar. Tengo una página que está enviando un correo electrónico dos veces debido a este problema y no hay forma de que pueda corregir el marcado incorrecto porque simplemente hay demasiado para arreglar que se genera en demasiados lugares, muchos de los CSS y Los problemas de HTML también se controlan dinámicamente.

Sin embargo, todavía no entiendo el razonamiento que hay detrás de tomar la página dos veces cuando encuentra problemas no conformes de esta naturaleza.

También estoy teniendo este problema.

Es curioso, agregué “visible = false” a toda la etiqueta de “formulario” haciendo que la página esté totalmente vacía, todavía se carga dos veces. También pellizqué el DOCTYPE, revisé las tags img para ver las fonts vacías, etc. etc., etc.

Todavía carga dos veces.

PERO noté que esto sucede solo en “localhost” . Los sitios web remotos funcionan bien.

Pensé que puede ser tiene algo que ver con DNS, pero “127.0.0.1” también se carga dos veces. Esto me vuelve loco …

Se encontró con el mismo problema. Estaba usando DOM Snitch.

Lo deshabilité e inmediatamente dejó de publicar dos veces.

Después de mirarlo, parece contener 2 tags sin un atributo href. Debido a que es una extensión de Chrome, se inyecta en el DOM en el cliente y supongo que esto hace que una página Webforms publique dos veces.

En caso de que alguien vea esto, asegúrese de verificar las extensiones y / o complementos que esté usando.

Tuve el mismo problema. Sin embargo, mi “error” se encontraba en mi archivo css.

Estaba usando .htaccess para volver a escribir todo en mi carpeta raíz pero utilicé

 background-image: url('../img/login_facebook.png') 

en mi archivo css. Eliminé el .. y el problema fue resuelto.

Esto puede ser un problema con una de las extensiones / complementos. Pruebe el modo incógnito : esto me ayudó una vez.

Aquí hay otro excelente artículo sobre por qué ocurre esto: https://www.nczonline.net/blog/2009/11/30/empty-image-src-can-destroy-your-site/

Obtuve el mismo error al usar Chrome en un sitio ASP.NET. Estaba volviendo a activar el ciclo de vida de la página con IsPostBack establecido en False.

Esto causó todo tipo de problemas para mí.

Creo que es solo la forma en que funciona Google Chrome. Puse un código en mi página de índice para escribir en un archivo con el nombre de archivo que se cargó, y cada vez que cargo la página (usando actualización o una nueva ventana) pone 2 resultados en el archivo.

EDITAR: Cambié el nombre de mi archivo de índice a test.php y lo volví a ejecutar. Esta vez solo tuvo un resultado. Este problema me está molestando.

EDITAR: Cambié el nombre de mi archivo a index.php y lo ejecuté. El mismo problema. Luego renombré mi .htaccess (para mod_rewrite) a htaccess para que no se analizara y el problema desaparezca. Después de descubrir esto, deshabilité la reescritura de url en el archivo .htaccess y el problema aún desapareció (finalmente). Hice una prueba más (si la gente sigue leyendo esta mierda) y descubrí que google carga la página dos veces cuando redirige desde el archivo .htaccess. Encontré una pequeña solución que parece solucionar el problema.

No estoy seguro si esto aplica a asp.net. Solo conozco la encoding php y los servidores apache.