WAMP muestra el error ‘MSVCR100.dll’ que falta al instalar

Cuando intenté instalar WAMP , apareció la siguiente alerta, MSVCR100.dll falta

Hice clic en Aceptar , continuó la instalación de WAMP. Cuando comienzo, el logotipo de WAMP siempre es ‘amarillo’. No se está volviendo “verde”, lo que significa que hay algo mal. ¿Qué es exactamente el archivo MSVCR100.dll ? ¿Cómo lo obtengo y corrijo este error?

El archivo MSVCR100.dll es parte de Microsoft Visual C++ , redistribuibles. Puede instalarlos y ver si esto resuelve su problema. Después de instalar la verificación anterior, si su instalación de wamp está configurada correctamente. Busque las publicaciones “mi icono de wamp se queda naranja”.

Este artículo en los foros de WampServer muestra todas las bibliotecas de tiempo de ejecución de Microsoft Visual C ++ que necesita tener instaladas en su sistema para cada versión de WampServer. Citar:

Para Windows 32: asegúrese de haber instalado el paquete redistribuible de Visual C ++ 2010 SP1 x86: VC10 SP1 vcredist_x86.exe

http://www.microsoft.com/download/en/details.aspx?id=8328

Para Windows 64: asegúrese de haber instalado el paquete redistribuible de Visual C ++ 2010 SP1 x64: VC10 SP1 vcredist_x64.exe

http://www.microsoft.com/download/en/details.aspx?id=13523

Apache no se ejecutará sin este componente

De hecho, si está ejecutando Windows de 64 bits, es una buena idea instalar todas las bibliotecas de 32 bits, así como las de 64 bits. Después de que todas las ventanas de 64 bits ejecutan código de 64 y 32 bits. Probablemente encontrará que necesita al menos uno de los tiempos de ejecución de 32 bits para alguna aplicación / utilidad que instalará en algún momento.

ACTUALIZAR

Si está ejecutando WAMPServer 2.5, también necesita el redireccionamiento VC11. Visual C ++ redistribuible para Visual Studio 2012

29.08.2014 con WAMP 2.5 Acepto que VC11 es necesario y no es una mala idea tener distribuciones previas instaladas. Será necesario por otra aplicación. No estoy seguro si necesitas la versión bit 32

http://www.microsoft.com/en-us/download/confirmation.aspx?id=30679

ACTUALIZACIÓN 3 de agosto de 2016

Como me informó Fred -ii- (muchas gracias por cierto) el enlace para la publicación en los foros de wamp ya no funciona. Como no pude encontrar el enlace original, puedes probar http://forum.wampserver.com/read.php?2,138295 . Tiene mucha información y puede ayudarte.

Para mí, ninguna de las respuestas anteriores funcionó, así que estoy agregando lo que funcionó para mí. Primero instalé los archivos mencionados en la respuesta aceptada y cuando eso no funcionó, descargué archivos de este enlace y comenzó a funcionar.

Entonces creo que la distribución de 2012 también es necesaria (estoy usando window7 home basic 64 FYI).

Resolví este problema instalando este: http://www.microsoft.com/en-sg/download/details.aspx?id=30679

Asegúrese de eliminar wampserver y vuelva a instalarlo

Nota: estoy usando Windows 7 32 bits

He intentado todas las respuestas anteriores, pero aún así el mismo error fue vomitar. ¡Más tarde encontré esto en WAMP Forum y finalmente mi WAMP funciona!

Si está utilizando WampServer 2.5 en una Windows de 64 bits, necesitará las versiones de 32 bits y 64 bits de este tiempo de ejecución.

Microsoft Visual C ++ 2012 (www.microsoft.com)

Presione el botón Descargar y en la siguiente pantalla seleccione VSU_4 \ vcredist_x86.exe Presione el botón Descargar y en la siguiente pantalla seleccione VSU_4 \ vcredist_x64.exe

Fuente: http://forum.wampserver.com/read.php?2,123608

¡La mayoría de las veces tendrá que instalar tanto x86 como x64!

Enlaces aquí: x86 y x64

Son el paquete redistribuible de Visual C ++ 2010 SP1

(me pasó cuando instalé MySQL Workbench)

Acabo de correr en este tema. El problema estaba en el mismo sistema operativo (Win7 HB x64) que en esta respuesta . Usé el consejo de gaurav y comencé con éxito el WAMP.

Quería agregar que no necesita versiones de Visual C ++ 2010 cuando usa la versión 2012 (al menos en este caso).

He instalado el nuevo WAMP 2.5, tengo Windows 8 x64 bit. He probado todas las soluciones anteriores, pero no funcionó conmigo y el icono de WAMP se queda en naranja . lo que funciona conmigo es:

  1. Desinstale el actual WAMP x64 bit
  2. instalar esto http://www.microsoft.com/en-us/download/details.aspx?id=30679
  3. Descargue e instale el servidor WAMP para x32 bit.
  4. Eligió a Firfox como el navegador.

Espero que ayude a alguien a buscar esta respuesta

Editar: dado que volví a encontrar el mismo problema, me di cuenta de que mi solución anterior no funcionaba; así como cualquier otra solución publicada aquí. Estoy usando Windows 7 Professional (64 bits).

Esta vez, he colocado el archivo ‘MSVCR100.dll’ (descargado como un ZIP, luego extraído en el escritorio y luego copiado) en una carpeta C: \ Windows http://www.dll-files.com/dllindex/dll- files.shtml? msvcr110

y luego instalador WAMP Server, 64BIT. http://sourceforge.net/projects/wampserver/

Luego, he descargado e instalado: http://www.microsoft.com/en-us/download/confirmation.aspx?id=30679

nombre de archivo: vcredist_x64.exe

Solo lo he probado con PHP desde un símbolo del sistema , ya que hago todo lo demás en un servidor y no en un host local.

Aunque funciona para lo que necesito para usarlo

Corriendo:

php da Falló la carga de php_xdebug-2.2.5-5.5-vc11.dll

php -v -WORKS!

Por favor, avíseme si esto funcionó para usted o no, o si hay algo más que deba hacer para mejorar la solución.

Hoy instalé el servidor Wamp 3.0.6 (x64) en una máquina con Windows 10 con VS2017 instalado. Tenía muchos paquetes redistribuibles de Visual C ++ instalados, pero no el de 2012. Luego lo instalé y ahora puedo ejecutar el servidor Wamp. Puede encontrar un enlace de descarga aquí .

Si no entiende nada, descargue vcredist_x86.exe desde http://www.microsoft.com/en-us/download/details.aspx?id=8328 . Solucionará tu problema.

Volver a instalar .NET Framework no funcionó para mí. Algunos softwares menos profesionales, como las utilidades de puesta a punto, manipulan o mantienen constantemente en uso los archivos .NET framework. como ese .dll. Lo aprendí mientras intentaba desinstalar las actualizaciones de .NET antes de la reinstalación.

  • No te olvides de desinstalar wamp del panel de control antes de volver a instalarlo.
  • Desinstalando las actualizaciones .NET de Windows. (controlPanel-> desinstalar un
  • progtwig-> ver actualizaciones) Desinstalar soft ware que previene
  • desinstalando .NETs. Terminó desinstalando satisfactoriamente .NET
  • actualizaciones de framework. Verifique las actualizaciones de Windows. Instalar las actualizaciones que aparecen DESPUÉS de la verificación (.NET framework update. 3update para mí bajo win7x64)
  • instalar wamp (terminado impecablemente para mí)

Paso 1. Desinstalar WAMP

Paso 2. Instale la última actualización redistribuible de Microsoft Visual C ++ 2015 3

Paso 3. Reiniciar el sistema

Paso 4. Reinstalar WAMP

Asegúrate de que Skype no haya iniciado sesión. No quieres saber más detalles si eres un novato 🙂

Para mí, el problema no se resolvió incluso después de instalar las redistribuciones de VC ++. Tuve que descargar manualmente el archivo MSVCR110.dll de https://www.dll-files.com/msvcr110.dll.html y lo coloqué en c: /> windows> system32 y funcionó correctamente.

Esta herramienta comprobará si faltan paquetes y también le dará un enlace de descarga para los paquetes. .
Si está en Windows 64 bit, entonces necesita instalar paquetes x86 y x64
enlace para descargar la herramienta:

DESCARGAR

Para resolver este problema, debe instalar todos los paquetes de redistribución de Microsoft 2010,2012 (x86 y x64) que desinstalar wampserver del panel de control y reinstalar la nueva copia del servidor de wamp. Este error será reparado.

La instalación de vcredist_x64.exe de Visual C++ Redistributable for Visual Studio 2012 solucionó el problema.

https://www.microsoft.com/en-us/download/details.aspx?id=30679

Estoy usando Windows 7 Home Basic 64 bit e instalé WampServer 2.5

Encontré este problema cuando mi sistema operativo estaba en francés, y estaba instalando Wampserver en inglés.

Estoy bastante seguro de que los paquetes Redistribuibles de Microsoft se instalaron porque ya estaba trabajando con Visual Studio. Creo que el problema puede deberse a cambios en los nombres de ruta con diferentes idiomas. Sin embargo, cuando instalé wampserver en francés, todo funcionó perfectamente.

Después de descargar todas las bibliotecas dichas por ezaoutis, el mensaje de error en mi Windows 10 persistió, leyendo los requisitos de instalación de wampserver3.1.3 , había una herramienta de verificación llamada check_vcredist.exe , la ejecuté y me mostró todas las bibliotecas faltantes y se descargó enlaces, por lo que finalmente pude instalarlo con éxito.

Debajo de la imagen con la herramienta de verificación marcada

Tuve el mismo problema, pero ninguna de las respuestas anteriores funcionó. Esto es lo que hizo el trabajo para mí:

  1. descargue msvcr110.dll , msvcr120.dll , msvcp120.dll y vcruntime140.dll desde dll-files.com
  2. Cópialos en System32
  3. Desinstalar wamp
  4. Reinstalar wamp

Algunas veces tienes que instalar todas las versiones o un montón de ellas.

Cualquier persona que no haya encontrado las respuestas anteriores es útil, eche un vistazo aquí

    Intereting Posts