La importación android.support no se puede resolver

Estoy tratando de ejecutar el código provisto AQUÍ
Descargué el código de su Github e importé a Android SDK, pero muestra un error en las líneas

import android.support.v4.app.FragmentActivity; import android.support.v4.app.NavUtils; 

en múltiples archivos. Sin embargo, si reviso el Administrador de Android SDK, se instalarán tanto la Android Support Library como el Android Support Repository en la carpeta Extras. También puedo ver la carpeta de soporte y su contenido en el SDK_INSTALL\sdk\extras\android\support . También tiene la carpeta v4 que también contiene el android-support-v4.jar y la carpeta src . ¿Por qué sigue mostrando el error, cómo lo resuelvo y cómo puedo ejecutar ese código de muestra? El código de muestra es para una aplicación de lector RSS, si es relevante.

Por favor, siga estos pasos:

Para Eclipse:

  • Ve a las Properties tu proyecto
  • Navega hacia la Java Build Path
  • Luego ve a la pestaña Libraries . Haga clic en el botón Add External JARs en el panel derecho.
  • Seleccione el archivo android-support-v4.jar , generalmente la ruta para el archivo Jar es:
    YOUR_DRIVE \ android-sdks \ extras \ android \ support \ v4 \ android-support-v4.jar
  • Después de agregar la biblioteca android-support-v4.jar , vaya a la pestaña Order and Export y marque el archivo de la biblioteca android-support-v4 .
  • Después de hacer lo anterior, limpie el proyecto y contrólelo .
  • Problema resuelto.

Para Android Studio:

Version corta:

  • Agregue comstackción ‘com.android.support:support-v4:YOUR_TARGET_VERSION’ en su archivo build.gradle.

Versión larga:

  • Ir a Archivo -> Estructura del proyecto

  • Vaya a la pestaña “Dependencias” -> Haga clic en el signo Más -> Vaya a “Dependencia de la biblioteca”

  • Seleccione la biblioteca de soporte “support-v4 (com.android.support:support-v4:YOUR_TARGET_VERSION)”

  • Navegue a su “build.gradle” dentro de su Directorio de aplicaciones y verifique si su Biblioteca de soporte de Android deseada ha sido agregada a sus dependencias.

  • Reconstruye tu proyecto y ahora todo debería funcionar.

Lectura adicional con respecto a esta pregunta:

  1. Biblioteca de soporte – Android Dev
  2. Revisiones recientes de la biblioteca de soporte
  3. Paquetes de soporte de la biblioteca
  4. ¿Qué es una biblioteca de soporte de Android?
  5. ¿Cómo funciona la Biblioteca de soporte de Android?

Espero que esto ayude.

andorid-support-v4.jar es un archivo jar externo que debe importar a su proyecto.

Así es como lo haces en Android Studio:

Ir a Archivo -> Estructura del proyecto enter image description here

Vaya a la pestaña “Dependencias” -> Haga clic en el signo Más -> Vaya a “Dependencia de la biblioteca” enter image description here

Seleccione la biblioteca de soporte “support-v4 (com.android.support:support-v4:23.0.1)” enter image description here

Ahora, vaya a su archivo “build.gradle” en su aplicación y asegúrese de que la biblioteca de soporte de Android se haya agregado a sus dependencias. Alternativamente, también podría haber escrito compile 'com.android.support:support-v4:23.0.1' directamente en sus dependencies{} lugar de hacerlo a través de la GUI.

enter image description here

Reconstruye tu proyecto y ahora todo debería funcionar. enter image description here

Otra forma de resolver el problema.

Si está utilizando una biblioteca de soporte, debe agregar la compat lib al proyecto. Este enlace muestra cómo agregar la lib de soporte a su proyecto

Suponiendo que ha agregado la biblioteca de soporte anteriormente, pero está recibiendo el problema mencionado, puede seguir los pasos a continuación para solucionarlo.

1- Haga clic con el botón derecho en el proyecto y navegue a Build Path-> Configure Build Path

2- En el lado izquierdo de la ventana emergente, selecciona Android . Verás una imagen como esta:

enter image description here

3- Puedes notar que no se hace referencia a libaray en el momonet. Ahora haga clic en el botón Agregar que se muestra en la parte inferior derecha. Verá una ventana emergente como se muestra a continuación.

enter image description here

4- Seleccione la aplicacióncompatible lib y presione ok. (nota: la lib se mostrará si los ha agregado como se mencionó anteriormente). Ahora verá la siguiente ventana.

enter image description here

5- Presione ok. Eso es. La lib se agrega a su proyecto (observe la marca roja) y los errores relacionados con la inclusión de la lib de soporte deben ir ahora.

Seguí las instrucciones anteriores de Gene en Android Studio 1.5.1 pero agregué esto a mi archivo build.gradle:

 compile 'platforms:android:android-support-v4:23.1.1' 

así que lo cambié a:

 compile 'com.android.support:support-v4:23.1.1' 

Y comenzó a funcionar.

Este problema también puede ocurrir si tiene varias versiones de la misma biblioteca de soporte android-support-v4.jar . Si su proyecto está utilizando otros proyectos de biblioteca que contienen versiones diferentes-2 de la biblioteca de soporte. Para resolver el problema, mantenga la misma versión de la biblioteca de soporte en cada lugar.

Este es un paso muy fácil para importar cualquier lib o archivo jar de terceros en su proyecto

  1. Copie el archivo android-support-v4.jar de your_drive \ android-sdks \ extras \ android \ support \ v4 \ android-support-v4.jar
    o copia de la carpeta bin de tu proyecto existente.
    o cualquier archivo .jar de terceros
  2. pegar el archivo jar copiado en la carpeta lib

  3. haga clic derecho en este archivo jar y luego haga clic en construir ruta-> Agregar a comstackción de ruta enter image description here

  4. aún así está obteniendo un error en su proyecto, luego limpie el proyecto y contrólelo.

Para mí, estaban apareciendo cuando transferí el código manualmente a otra computadora portátil. Solo haz

Archivo> Invalidar caché / reiniciar

haga clic en ‘Invalidar caché y reiniciar’ y listo.

Lo resolví al eliminar android-support-v4.jar de mi proyecto. Porque appcompat_v7 ya tiene una copia.

Si ya ha importado appcompat_v7, el problema no se resuelve. luego pruébalo

Android Studio 2.2.3 Linux Mint 18.1

Dentro de su ‘vista de proyecto’ abra Gradle Scripts -> build.gradle (Module: app) y coloque el puntero del mouse dentro de las dependencias de la palabra.

Haga clic en la bombilla y haga clic en “agregar dependencia de la biblioteca” y para mí todas las bibliotecas que quería se enumeran allí.

bibliotecas de ejemplo que surgieron para mí: comstackr ‘com.android.support:gridlayout-v7:25.1.0’ comstackr ‘com.android.support:support-v13:25.1.0’

Ahora estoy buscando agregar compatibilidad con Android de forma predeterminada en la configuración predeterminada de Gradles.