CFBundleVersion en el error de carga de Info.plist

“El archivo binario que cargó no era válido. La clave CFBundleVersion en el archivo Info.plist debe contener una versión superior a la de la versión cargada anteriormente”.

Recibo este error cuando vengo a cargar mi aplicación.

Configuré la versión actualizada a 1.2 en iTunes Connect y también actualicé el archivo .plist a 1.2.

No entiendo por qué estoy recibiendo este error. Cualquier ayuda sería apreciada. Gracias.

Hay al menos 1 error conocido en el servidor de carga de Apple que no han reparado durante más de 12 meses. Cosas a tener en cuenta:

  1. Apple elimina los ceros a la izquierda dentro del número de versión; es decir, la “cadena completa” NO se trata como un número, sino que los bits entre puntos se tratan como números SEPARADOS. por ejemplo, “1.02” es tratado por Apple como “1.2”. Entonces, para Apple, 1.02 es MAYOR QUE 1.1
  2. A veces, Apple se “confunde” y parece comparar su aplicación cargada con la versión de una aplicación DIFERENTE que ha subido anteriormente. Le ha sucedido a mucha gente, y yo mismo lo he visto algunas veces
  3. Se supone que Apple está comparando la “CFBundleVersion” (es decir, “Bundle version”, no la “Bundle versions string, short”); no te confundas
  4. Con frecuencia, la única solución viable es boost el número de frente (por ejemplo, el “2” en “2.4” – boostlo a “3”)
  5. El número de versión que carga no está relacionado con el número de versión que aparece en iTunes: puede poner lo que quiera allí, y eso es lo que verán los usuarios.
  6. … excepto que, si también informa el número de versión “real” dentro de su aplicación, el usuario verá la versión de CFBundleVersion (generalmente, depende de cómo la codifique), en lugar de la versión de iTunes (que, creo, no se puede acceder desde dentro de tu aplicación)

Actualiza el número de comstackción. El número de versión es importante, pero el número de comstackción marca la diferencia. Por ejemplo, tenía mi versión inicial de una aplicación como:

 version #: 1.0 build #: 1.0 

Sin embargo, cuando intenté cargar la próxima versión, es decir,

 version #: 1.1 build #: 1.0 

No aceptaría la carga. Simplemente incrementando la construcción # a 1.1 la carga fue aceptada.

Xcode 4 pensará que desea volver a cargar la misma versión si no vuelve a archivar la aplicación. Incluso si cambia la versión del paquete y la vuelve a generar, la carga fallará. ¡Recuerde hacer un ” Archivo ” en el menú Producto!

Muchas de las respuestas aquí finalmente me ayudaron, pero no fue hasta que vi el número exacto de “versión” que Apple estaba comparando.

  1. Vaya a iTunes Connect -> Administre sus aplicaciones
  2. Elija la aplicación para la que desea verificar la versión anterior
  3. Haga clic en el botón azul etiquetado Ver detalles
  4. Haga clic en el enlace etiquetado Detalles binarios
  5. Encuentre el valor dado para la Versión del paquete

Aunque pensé que había enviado la versión número 1.0.1, el número real que Apple almacenó fue 101. Algunos de los comentarios anteriores me hicieron creer que necesitaba cambiar mi versión a 2.0 (20) o 1.5 (15) o 1.2 (12) ) -Todos son todos menos de 101 como puedes ver. La actualización de mi versión número 102 (sin los puntos) solucionó el problema.

Este artículo señala que el número de versión que se ve en la tienda de aplicaciones no es necesariamente el mismo que el número de versión del paquete. Cuando ve los detalles de su aplicación en iTunes, hay un enlace llamado ‘Detalles binarios’. Esa página muestra la versión del paquete. Una de las aplicaciones en las que estaba trabajando era en la versión 1.0, pero la versión del paquete era 2.0. La carga de un paquete con la versión 1.1 falló, pero 2.1 funcionó.

Entonces, hay una versión de aplicación y una versión de paquete. Este problema tiene que ver con la versión del paquete.

Parece que la confusión es causada por el formato de número. La versión del paquete no es un decimal. Es una versión (o comstackción tal vez) así que 1.11 es realmente “un punto once”. Por lo tanto, 1.11 es mayor que 1.2. Tuve éxito usando 1.20 en este caso.

Por lo general, esto puede deberse a la ausencia del número de versión. Por lo tanto, agregue el número de versión en Identidad y también verifique el número de comstackción.

enter image description here

Mantener la encoding ……… 🙂

Para mí (Xcode 4.5) cambiar el número de comstackción resolvió el problema. establecer las versiones a 1.0.2 … 2.0.2 etc. luego boost la construcción # (Adam 3 puntos dame una idia dónde mirar).

Debería poder iniciar sesión en iTunes Connect y ver la versión actual de la aplicación (incluida la que haya enviado pero no en vivo). Verifique para asegurarse de que no haya enviado una versión anterior con un número de versión más alto (o el mismo).

Pasé unas horas tratando de resolver este problema. Comprobé con todas mis fuerzas para asegurar que CFBundleVersion fuera de hecho más alto que la versión anterior, al abrir el info.plist en un editor de texto, obtener información del objective y leer la versión de las propiedades, le pedí a mi esposa que lea la versión en iTunes para confirmar que no me afectó un Alzheimer inesperado.

Al final, esto de alguna manera hizo el truco. Mi versión anterior era 1.0.4. Intenté 1.3.5, 1.4.5 etc .; ninguno funcionó. Pero, sorprendentemente, cuando ingresé a 2.0.0, a Application Loader le gusta lo que vio y lo subió. ¿Esto se debe a un error en el cargador de aplicaciones?

En el resumen de objectives al lado del número de versión en xcode4 hay una comstackción, comencé esto en 1, incrementé cada vez que hago una carga binaria, esto resolvió el problema para mí

Si el error informado es CFBundleVersion, la corrección suele ser bastante fácil. Comprueba / prueba esto:

  1. Vaya al elemento de proyecto de nivel superior en Project Navigator y haga clic en él.
  2. En el panel justo a la derecha, haga clic en el objective de la aplicación.
  3. Haga clic en la pestaña de resumen.

En la pestaña de resumen, verá que hay dos “versiones” diferentes que se pueden ajustar. El primero es el campo “Versión”, que se utiliza en la pantalla predeterminada “Acerca de” para las aplicaciones de Mac. El de la derecha es la “Versión de comstackción”. ¡Este es el que realmente importa para los envíos de la App Store!

Sé que esta es una vieja pregunta, pero me encontré con este problema. Lo resolví borrando el proyecto del archivo y luego volviendo a archivarlo. Aparentemente, la versión anterior de la aplicación estaba ahí y causaba confusión.

Presta atención al mensaje de error.

El mensaje de error contiene el número de paquete anterior entre corchetes (por ejemplo, [9]).

Por lo tanto, necesita incrementar ese número de paquete (ej. 9.1), aunque su nuevo número de versión es 1.2

Entonces, cuando actualice la versión de 1.1 a 1.2 en iTunes Connect, debe establecer estos valores en su proyecto.

 Version number = 1.2 Bundle number = [previous bundle number]++ 

Tengo un iPhone y una versión para iPad en mi proyecto, la infoplist para el ipad no estaba asociada con el producto ipad por alguna razón, la membresía de Checking Target y su asociación con el producto correcto resolvió este problema para mí.

Encontré la solución para este error en esta publicación CFBundleVersion debe ser más alta que la versión anterior

¡espero que esto ayude!

Cometí un error al intercambiar la ‘Versión’ y el ‘Build’ no.

En lugar de poner el 2.3 en el campo Versión, lo puse en el Nº de comstackción.

Aquí es cómo resolví el problema (y supongo que este es el problema con mucha gente):

1) Haga clic en la pestaña general de la configuración de sus proyectos (a la que puede acceder haciendo clic en el nombre de su proyecto, que se encuentra en la parte superior de todos los archivos de códigos).

2) Asegúrate de que el campo de comstackción coincida con lo que colocaste en tu plist para la clave “Versión del paquete”.

Este fue el problema para mí, por alguna razón no estaban sincronizados. Creo que cuando cambias la clave de la Versión de Bundler se supone que se sincroniza (y viceversa). Pero no sucedió por alguna razón, podría ser un error.

Tuve el mismo problema y sucedió porque no he archivado y estaba usando el primer archivo que utilicé para el 1.0 pero con el 1.0.1. Así que seleccioné el dispositivo iOS, archivé y luego validé. Ta-daaa, funcionó!

Yo tuve el mismo problema. Básicamente mi versión anterior era 1.12. Quería cambiarla a 1.2 pero tuve el error mencionado. Probé 1.20 y funcionó perfecto

Ningún conjunto de números en constante aumento funcionó siempre que utilizara el “Cargador de aplicaciones” de Apple para cargar mi archivo ipa, pero si usaba el “Organizador” de XCode (que se encuentra debajo del menú desplegable “Ventana” en la versión 3.2.5) , hizo clic en el botón “Validar …”, esperó a que me aprobara, luego hizo clic en el botón “Enviar …”, todo salió como se esperaba con un número de versión sana (uno que es un incremento individual por encima del que está actualmente) disponible en la App Store).

en xcode 4.2 parece que no se registra la versión del paquete si se modifica desde el archivo info.plist. Configuré mi nueva versión de paquete directamente en el panel xcode “información” y ahora funciona.

Encontré otra solución.

Si selecciona su target >> info >> update Bundle ID.

Yo tuve el mismo problema. La primera versión enviada fue 1.5.20 y quería actualizarse a 1.7.30.

Después de probar infructuosamente las versiones 1.8, 2.0 y 3.0, actualicé mi CFBundleVersion a 10.0 y de repente funcionó.

No estoy seguro de cuál es la lógica detrás de este comportamiento, pero me causó perder cerca de 2 días de trabajo.

Comprueba la versión de tu paquete de la versión cargada anteriormente, debes comparar la versión de paquete más alta con la versión de paquete de la versión ya cargada. La versión ya cargada se puede ver por itunesconnect / application / view details / binary details.

Pasé dos noches en un problema similar. Mi versión anterior era 1.02, y traté de validar con 1.2, 1.20, 1.1 y siempre recibí el mensaje binario no válido.

Lo resolví ingresando 2.0 como número de versión, y funcionó . Sospecho que este es un error también. No recibí este mensaje cuando recientemente actualicé mi juego de 1.0 a 1.1, pero eso fue con xcode 3. ¡Gracias por el consejo!

Tuve un problema similar y después de pasar media hora noté que estaba aumentando el número equivocado. En vez de boost la Bundle version , estaba incrementando Bundleversions, string, short en Info.plist. Busque “CFBundleVersion” en su proyecto usando CMD + Shift + F. Verá que necesita boost el número CFBundleVersion.

Pruebe change version = “1.1.1.0” a version = “1.1.1”

A finales de octubre, Apple requiere que los números de versión sean menores a 4 dígitos (1.2.3 o 1.23 en comparación con 1.2.3.4 o 1.234). ¡Esto también se aplica a las bibliotecas!

Un grep rápido para el número de versión ofensivo en su directorio de proyecto debe aparecer la biblioteca ofensiva:

grep -r "1.2.3.4" .

Tenía una beta activa de TestFlight activa. Build 2020 , versión 407

Envié una aplicación para la revisión oficial de la App Store. Build 2020 , versión 435, y fue aprobado. Simplemente está sentado allí, esperando que lo presione en vivo en la App Store.

Sin añadir una historia secundaria complicada, lo que quería hacer es darles a mis usuarios de TestFlight beta una versión actualizada para obtener una vista previa de la versión oficial de la App Store por unos días, antes de hacer la versión de la App Store en vivo. ¿Porque preguntas? Debido a que estaban obteniendo funciones gratuitas, se estaba a punto de costar dinero una vez que la aplicación se activara.

Entonces, envié Build 2020 , versión 436, a TestFlight, y fue rechazado.

Fue rechazado porque tengo un candidato oficial aprobado de la App-Store con el mismo número de comstackción

Solución: cambie el número de comstackción de su versión de TestFlight. Envié Build 20200 (agregué un cero adicional) versión 436 a TestFlight, y fue aprobado. No se preocupe, aún puede enviar esta comstackción al mismo grupo beta de TestFlight, siempre y cuando siga usando el mismo BundleID.