Error al resolver com.android.support:appcompat-v7:22 y com.android.support:recyclerview-v7:21.1.2

Instalé ALL Extra y SDK API 21-22, incluyendo cambios en compileSdkVersion 22 to 21 buildToolsVersion ’22 .0.1 ‘a 21.1.2 pero error.

Y los problemas de representación para API 22 y yo cambiamos a <= 21 todavía.

    Esta es la versión correcta que puede agregar en su build.gradle de acuerdo con las necesidades de la API.

    API 24:

     implementation 'com.android.support:appcompat-v7:24.2.1' implementation 'com.android.support:recyclerview-v7:24.2.1' 

    API 25:

     implementation 'com.android.support:appcompat-v7:25.4.0' implementation 'com.android.support:recyclerview-v7:25.4.0' 

    API 26:

     implementation 'com.android.support:appcompat-v7:26.1.0' implementation 'com.android.support:recyclerview-v7:26.1.0' 

    API 27:

     implementation 'com.android.support:appcompat-v7:27.1.1' implementation 'com.android.support:recyclerview-v7:27.1.1' 

    Para hacer que funcione tuve que configurar:

     compile ("com.android.support:support-v4:22.2.0") compile ("com.android.support:appcompat-v7:22.2.0") compile ("com.android.support:support-annotations:22.2.0") compile ("com.android.support:recyclerview-v7:22.2.0") compile ("com.android.support:design:22.2.0") 

    comstackr (“com.android.support: design : 22. 2 .0″)

    La documentación indica algo diferente ( documentos ):

    com.android.support: support -design: 22. 0 .0

    Ruta real para las bibliotecas de repository de soporte:

    enter image description here

    1. Debe descargar las Bibliotecas de repository de soporte.

    Si el problema aún existe:

    1. Vaya a la ruta real de sus bibliotecas de repository de soporte y verifique que exista la siguiente carpeta:

       "ANDROID_SDK_DIRECTORY\extras\android\m2repository\com\android\support" 

      En esa carpeta hay bibliotecas de soporte que no se pueden encontrar. por ejemplo:

       "ANDROID_SDK_DIRECTORY\extras\android\m2repository\com\android\support\appcompat-v7" 
    2. Abra la carpeta appcompat-v7 y verá carpetas con todas las versiones disponibles. Debería usar solo una de estas versiones en las dependencias del archivo build.gradle o usar +, por ej. 18.0. +

       dependencies { compile fileTree(dir: 'libs', include: ['*.jar']) compile 'com.android.support:appcompat-v7:18.0.+' compile 'com.android.support:gridlayout-v7:23.1.1' compile 'com.android.support:support-v4:23.1.1' } 

    Esa es la ruta tomada desde el archivo de dependencias de grade.build:

     com.android.support:appcompat-v7:18.0.0 

    Consulte la ruta real en su HDD ->

     ANDROID_SDK_DIRECTORY\extras\android\m2repository\com\android\support\appcompat-v7\18.0.0 

    Si no hay tal carpeta, recibirá el error:

     "failed to resolve com.android.support:appcompat-v7:18.0.0" 

    ps Si tiene Windows x64, cuando instale sdk y jdk, asegúrese de que la ruta de instalación no tenga Program Files(86) . Los corchetes que agregan Windows pueden causar problemas adicionales al resolver rutas para su proyecto. Use rutas simples para su carpeta de instalación.

    Por ejemplo:

     c:\androidSDK\ 

    Error al encontrar: com.android.support:appcompat-v7:22.0.0

    La respuesta “Literalmente probé todo lo demás”:

    Este problema también ocurrirá si no tiene una biblioteca de soporte de Android actualizada y un repository de soporte de Android. Simplemente instale usando el administrador de SDK.

    en bibliotecas de soporte, siempre debe agregar tres números como número de versión

    Supongamos que para 22 -> necesita escribirlo como 22.0.0, no solo 22

    para 22.1 -> 22.1.0

    Entonces tus dependencias deberían verse así

     compile 'com.android.support:appcompat-v7:22.0.0' compile 'com.android.support:support-v4:22.0.0' compile 'com.android.support:cardview-v7:22.0.0' compile 'com.android.support:recyclerview-v7:22.0.0' 

    I Idioma de los progtwigdores que necesita para rellenar ceros adicionales.

    Espero que esto resuelva tu problema

    Lo resuelvo

    cambiar 22.0.0 a 21.0.3

     dependencies { compile fileTree(dir: 'libs', include: ['*.jar']) //compile 'com.android.support:appcompat-v7:22.0.0' compile 'com.android.support:appcompat-v7:21.0.3' } 

    tal vez tengo descargar el com.android.support:appcompat-v7:21.0.3 pero no tengo la compile 'com.android.support:appcompat-v7:22.0.0'

    cuando uso SDK Manager actualice mi support library support repository y el support repository , el problema se descarta.

    Junto con otras soluciones proporcionadas, asegúrese de tener lo siguiente dentro de project / build.gradle

     allprojects { repositories { jcenter() maven { url "https://maven.google.com" } } } 

    NOTA 1 : todas las bibliotecas de com.android.support deben usar la misma especificación de versión (las versiones de mezcla pueden provocar lockings en el tiempo de ejecución).

    NOTA 2 : la biblioteca de soporte no debe usar una versión diferente a compileSdkVersion

    Para API 28 puede usar:

     implementation 'com.android.support:appcompat-v7:28.0.0-alpha1' implementation 'com.android.support:recyclerview-v7:28.0.0-alpha1' 

    https://mvnrepository.com/artifact/com.android.support/appcompat-v7/28.0.0-alpha1 https://mvnrepository.com/artifact/com.android.support/recyclerview-v7/28.0.0-alpha1

    Todas las bibliotecas de soporte: https://mvnrepository.com/artifact/com.android.support

    Es más fácil usar el signo ” + ” en el número de versión. Por ejemplo

     compile 'com.android.support:support-v4:22.0.+' compile "com.android.support:appcompat-v7:22.0.+" 

    En este caso, no tendrá que cambiar versiones para el mismo número de API

    Vaya a Messages Gradle Sync, y haga clic en Install Repository y sincronice el proyecto. Esto instalará el archivo necesario en Android SDK y después de la sincronización podrá crear gradle o ejecutar su proyecto.

    ¿Los importas? Me gusta esto:

     compile 'com.android.support:appcompat-v7:21.0.3' compile 'com.android.support:recyclerview-v7:21.0.3' 
     compile ("com.android.support:support-v4:22.2.0") compile ("com.android.support:appcompat-v7:22.2.0") compile ("com.android.support:support-annotations:22.2.0") compile ("com.android.support:recyclerview-v7:22.2.0") compile ("com.android.support:design:22.2.0") 

    pegue el código anterior en su app gradle.

    y al configurar el proyecto, seleccione actividad vacía en lugar de actividad en blanco.

    Solucionado mi problema cambiando estos

     compile 'com.android.support:cardview-v7:21.0.+' compile 'com.android.support:recyclerview-v7:21.0.+' 

    a

     compile 'com.android.support:cardview-v7:23.0.+' compile 'com.android.support:recyclerview-v7:23.0.+' 

    eso significa que su versión del SDK objective debe ser la misma que la versión de cardView y recyclerView y otras bibliotecas de Google.

     targetSdkVersion 23 

    Herramientas> Android> SDK Manager

    Seleccione todos los paquetes que no estén actualizados y actualícelos.

    Tenía tanta dependencia en build.gradle –

     compile 'com.android.support:recyclerview-v7:+' 

    Pero causa comstackciones inestables. Asegúrate de que funcione bien para ti, y busca en tu administrador de SDK de Android la versión actual de soporte lib disponible, y reemplaza esta dependencia con

     def final RECYCLER_VIEW_VER = '23.1.1' compile "com.android.support:recyclerview-v7:${RECYCLER_VIEW_VER}" 

    Resolví el problema de actualizar todos los paquetes de Android SDK Manager y, además, tuve que instalar Extras -> Android Support Repository .

     allprojects { repositories { google() jcenter() maven { url "https://maven.google.com" } } }