ADT requiere ‘org.eclipse.wst.sse.core 0.0.0’ pero no se pudo encontrar

Estoy instalando el SDK de Android en una nueva instalación de Fedora 14 (Linux). Instalé eclipse y ejecuté las herramientas / sdk de Android para instalar todos los componentes de Eclipse para el SDK. Logré instalar DDMS cuando lo seleccioné solo.

Y para el último componente, las herramientas para desarrolladores de Android, recibo el feo mensaje de error pegado a continuación.

Ahora estoy atascado en el infierno de la dependencia de Eclipse.

He buscado a través de los paquetes disponibles en Fedora y no puedo encontrar el que tiene los archivos necesarios para satisfacer esta dependencia de Eclipse. ¿Alguien puede traducir qué es lo que está pidiendo Eclipse y en qué paquete de Fedora vive?

El feo error:

Cannot complete the install because one or more required items could not be found. Software being installed: Android Development Tools 0.9.9.v201009221407-60953 (com.android.ide.eclipse.adt.feature.group 0.9.9.v201009221407-60953) Missing requirement: Android Development Tools 0.9.9.v201009221407-60953 (com.android.ide.eclipse.adt.feature.group 0.9.9.v201009221407-60953) requires 'org.eclipse.wst.sse.core 0.0.0' but it could not be found 

Acabo de encontrar exactamente el mismo problema en Eclipse 3.6 (Helios). Después de buscar en Google, encontré este enlace:

http://code.google.com/intl/es/eclipse/docs/faq.html#wstinstallerror

Durante la instalación, hay un error al solicitar org.eclipse.wst.sse.ui. ¿Cómo arreglo eso?

El complemento de Google para Eclipse depende de otros componentes específicos de Eclipse, como WST. Es posible que su instalación de Eclipse aún no los incluya a todos, pero se pueden instalar fácilmente siguiendo estas instrucciones. Eclipse 3.6 (Helios)

  1. Seleccione Ayuda> Instalar nuevo software …
  2. Haga clic en el enlace para Sitios de Software Disponibles.
  3. Asegúrese de que haya un sitio de actualización llamado Helios. Si no está presente, haga clic en Agregar … e ingrese http://download.eclipse.org/releases/helios para la Ubicación.
  4. Ahora repase los pasos de instalación; Eclipse debería descargar e instalar las dependencias del complemento.

(Hay ejemplos en esa página para 3.5 (Galileo), 3.4 (Ganimedes) y 3.3 (Europa) para cualquiera con diferentes versiones)

Los mismos pasos exactos también funcionan para 3.7 (Indigo).

Simplemente use http://download.eclipse.org/releases/indigo para la ubicación.

Juno: http://download.eclipse.org/releases/juno

Kepler: http://download.eclipse.org/releases/kepler

Nota: El paso cuatro no es necesario. Solo son necesarios los pasos uno a tres.

Para Eclipse 3.7 o Indigo, la URL ganadora es

http://download.eclipse.org/releases/indigo

Y para 3.8 es

http://download.eclipse.org/releases/juno

Encontré el mismo problema en eclipse 3.7 añil

y he hecho lo siguiente:

  1. ayuda-> instalar nuevo software

  2. haga clic en “sitios de software disponibles”

  3. seleccione todas las entradas (CTRL-A) y elimínelas

  4. agregar una nueva entrada en la ubicación http://download.eclipse.org/releases/indigo/

  5. Ahora agregue nuevamente la ubicación de ADT http://dl-ssl.google.com/android/eclipse/

Si te descargas e instalas una versión clásica de eclipse, te faltan las herramientas esenciales de desarrollo de Java requeridas por el SDK de Android, etc.

Descubrí que instalar Eclipse Java Development Tools y Java EE Tools me resolvió este problema en Eclipse 3.7.

Parece obvio para muchos desarrolladores de Java, pero para los nuevos en IDE y JAVA, etc. es importante tener en cuenta que no están instalados con la versión “clásica” de Eclipse.

Agregar el enlace al repo de Helios http://download.eclipse.org/releases/helios no fue suficiente.

En Windows 7

Ejecute el eclipse como administrador

Ir a Windows-> Preferencias-> Instalar / actualizar-> marcar “todas las versiones de software disponibles” y aplicar -> ok

Ir a Ayuda-> Instalar nuevo software-> agregar -> poner el URL agregar o archivo zip ADT -> ok

eso es todo y está funcionando …

También estaba navegando por estas respuestas, pero no pude obtener ninguna respuesta a mi problema. Pero a través del éxito y la prueba encontré la siguiente solución. Primero actualice su eclipse yendo a Ayuda-> Buscar actualizaciones. Luego, vaya a Instalar nuevo software y proporcione la ubicación de adt (local o url), luego verifique Todas las actualizaciones ubicadas durante la instalación para encontrar el software requerido y lo haría el rest.

No estoy seguro de si esta solución funciona bien para otros, pero funcionó para mí y espero que funcione para algún desarrollador problemático por ahí

Y para la versión de Juno:

Solo tiene que agregarlo, no para instalar nada.

Descubrí que eliminar ~/.eclipse resolvió este problema en el eclipse Ubuntu de stock

Para mí, ejecutar win 7 64, eclipse 3.7.1 64, fue simplemente ejecutar eclipse como administrador, seguir los pasos enumerados.

Usando Ubuntu 11.10 pude solucionar ese problema volviendo a instalar Eclipse (en mi caso 3.7) de la siguiente manera:

  sudo apt-get purge eclipse sudo apt-get install eclipse.* 

A partir de allí, la instalación de Android SDK funcionó bien.

En mi caso, recibí el error anterior porque los ítems Indigo y “Actualizaciones de proyectos de Eclipse” en el panel “Sitios de software disponibles” estaban deshabilitados. Todo lo que tuve que hacer fue alternarlos al estado habilitado y mi instalación de ADT Plugin fue como una brisa (en lo que concierne a las instalaciones de eclipse, supongo)

Yo tuve este problema también.
Ejecutando Windows 7 (64 bit), Eclipse Indigo . Probé todas las diferentes sugerencias, pero finalmente, simplemente desmarcando Contact all update sites during install to find required software (ejecutando Eclipse como administrador , aunque no creo que esto fuera importante) conseguí que todo funcionara bien.
Espero que esto ayude a alguien.

Instale Google Plugin para Eclipse correspondiente a su versión. para el enlace de 3.6 helios es http://code.google.com/intl/es/eclipse/docs/install-eclipse-3.6.html

para la versión fuera de línea http://code.google.com/eclipse/docs/install-from-zip.html

Espero que resuelva el problema de la mina y el tuyo.

Obtuve un error similar en Windows Vista de 32 bits al usar el paquete Eclipse Classic 3.7.2 , pero funcionó bien después de descargar y usar Eclipse IDE para desarrolladores de Java EE .

pasos rectos para hacer funcionar su plugin ADT

  • Descargar eclipse helios EE IDE no la versión clásica
  • Después de descomprimir directamente vaya a Verificaciones de actualización desde el menú de ayuda
  • Después de que se actualice, descargue la versión fuera de línea del complemento ADT del sitio ADROID.
  • Ahora ve a Ayuda de nuevo -> Instalar nuevo software -> agregar -> haz clic en el archivo y luego apunta a tu descarga ADT ADT-17.0.0.zip. Dar cualquier nombre en el campo de nombre decir ADT. haga clic en Aceptar
  • ahora desde el trabajo con menú desplegable, seleccione el nombre del complemento de adt que le dio
  • ahora adelante con la instalación. disfrutar 🙂

Lo que hice (Helios):

1) Vaya a Ayuda -> Instalar nuevo software …

2) Seleccione o agregue una nueva ubicación http://download.eclipse.org/webtools/repository/helios/

3) Verifique la checkbox de WTP de última versión y presione next

4) Lo más probable es que te encuentres en la situación de “dependencias adicionales requeridas” , pero esa nueva pantalla te mostrará qué paquetes tienen wst en sus nombres, deberías proceder con la instalación de esos paquetes * wst *

5) U no obtuvo el 4to punto. En ese caso, ha requerido paquetes de wst instalados.

Disfrutar. O no… 🙂

Desarrollador de Android Para aquellos que usan eclipse 3.7

agregue lo siguiente después de http: // prompt download.eclipse.org/releases/indigo

A continuación, haga clic en el menú “ayuda” y haga clic en “buscar actualizaciones”

Para ayudar a eliminar algunas de las conjeturas y verificar qué dependencias se necesitan. Después de una nueva instalación de Ubuntu, necesitaba lo siguiente.

Error 1:

 ***Missing requirement: Android Development Tools 0.9.6.v201002051504-24846 (com.android.ide.eclipse.adt.feature.group 0.9.6.v201002051504-24846) requires ***'org.eclipse.gef 0.0.0' but it could not be found 

Sitio de actualización: GEF y Draw2d Plugin de http://download.eclipse.org/tools/gef/updates/releases/

Error 2:

 Missing requirement: Android Development Tools 0.9.9.v201009221407-60953 (com.android.ide.eclipse.adt.feature.group 0.9.9.v201009221407-60953) requires 'org.eclipse.wst.sse.core 0.0.0' but it could not be found 

Sitio de la actualización: Eclipse XML Editors and Tool de http://download.eclipse.org/releases/indigo

Actualización para Fedora 16

Tenga en cuenta que esto ahora lo proporciona un paquete, por lo que lo que se recomienda hacer es:

  pkcon install eclipse-wtp-sourceediting 

Esto parece ser una “bala mágica” de una sola vez para obtener todo lo que requiere el complemento ADK de Android en Fedora 16 (al menos).

Ninguna de las respuestas existentes funcionó para mí. Tener todos los sitios de actualización correctos en “sitios disponibles” no fue suficiente para decirle a Eclipse cómo encontrar sus dependencias.

Usando Fedora 14 y Eclipse Indigo 3.7.1, tuve que seguir estos pasos para que la instalación funcione:

  1. Compruebe e instale “Herramientas de Linux” desde http://download.eclipse.org/releases/indigo
  2. Compruebe e instale “Herramientas de Linux” desde http://download.eclipse.org/releases/indigo/201109230900

Después de reiniciar Eclipse, finalmente pude instalar el SDK de Android.

Durante la instalación, hay un error al solicitar org.eclipse.wst.sse.ui. ¿Cómo arreglo eso?

El complemento de Google para Eclipse depende de otros componentes específicos de Eclipse, como WST. Es posible que su instalación de Eclipse aún no los incluya a todos, pero se pueden instalar fácilmente siguiendo estas instrucciones. Eclipse 3.6 (Helios)

Seleccione Ayuda> Instalar nuevo software … Haga clic en el enlace para Sitios de software disponibles. Asegúrese de que haya un sitio de actualización llamado Helios. Si no está presente, haga clic en Agregar … e ingrese http://download.eclipse.org/releases/helios para la Ubicación. Ahora repase los pasos de instalación; Eclipse debería descargar e instalar las dependencias del complemento.

// Intenta instalar la extensión “eclipse plugin development environment”

Use http en lugar de https: // y resolverá este problema.

http://dl-ssl.google.com/android/eclipse/

ninguno de los anteriores funcionó para mí. Esto hizo:

  1. Retire Eclipse (creo que esto se trata más arriba).
  2. Obtener ESTE eclipse. (Los otros no tienen java). Este eclipse tiene java, el apt-get no
  3. Sigue estos pasos Este chico lo clavó. No debería ser tan difícil, pero no es tan malo …

Después de eso, pude volver a traer mis cosas de Android a través del “Instalar nuevo software” normal,

Me encontré con este problema para. Lo que hice fue simplemente extraer el paquete de eclipse usando 7-zip lugar del extractor de ventanas incorporado.

Agregue esto para eclipse juno Pude instalar el complemento ADT después de esto en ubuntu 12.04.

Eclispe 4.2 Juno Service Release 2

El bash de instalar Google Plugin para Eclipse falló incluso cuando se habilitó “Contactar con todos los sitios de actualización”. Después de instalar los paquetes Juno JST / WST Server funcionó.

Ayuda> Instalar nuevo software …

Trabajar con: Juno – http://download.eclipse.org/releases/juno

Categoría: Web, XML, …

  • Adaptadores de servidor JST
  • Extensiones de adaptadores de servidor JST
  • Interfaz de usuario del servidor JST
  • Adaptadores de servidor WST

Reiniciar Eclipse

Ayuda> Instalar nuevo software …

Trabajar con: Google Plugin for Eclipse – https://dl.google.com/eclipse/plugin/4.2

  • Google App Engine Tools para Android
  • Complemento de Google para Eclipse 4.2

Póngase en contacto con todos los sitios de actualización: ¡ habilitado !

Reiniciar Eclipse

Google es tu amigo Asegúrese de utilizar la versión correcta de Eclipse, y es posible que deba ejecutar Eclipse como root al instalar.

El problema es que las versiones de Eclipse que se envían con distribuciones de Linux suelen ser muy genéricas en su configuración. Es poco probable que encuentre el paquete correcto a través de su administrador de paquetes, quiere usar el mecanismo de Eclipse.

La descarga de herramientas SDK y la instalación del paquete ADT me plantearon un problema en Windows y Linux. Después de probarlo en todos los modos posibles en ambos sistemas operativos, incluso con mi profesor universitario conmigo para la instalación de Windows, no pudimos hacerlo funcionar.

En ambas ocasiones, la única forma en que lo conseguí fue instalando Android ADT Bundle que incluye herramientas Eclipse & SDK y ADT Plugin, todo en uno.

apt-get eliminar eclipse-jdt y simplemente descargar el paquete, simplemente funciona. 🙂

No es de un repository, pero funciona.

http://developer.android.com/sdk/index.html

    Intereting Posts