Mensaje de error: este SDK de Android requiere Android Developer Toolkit versión 22.6.1 o superior

Recientemente me encontré con el siguiente error:

captura de pantalla del diálogo

Lo más extraño es que acabo de actualizar un paquete de SDK a través de eclipse de trabajo. No hubo información o advertencia de que después de esta actualización, el valor actual de adt se bloquee. Revisé las actualizaciones más recientes y no puedo encontrar nuevos anuncios incluso en la página de Google. Incluso los nuevos adb contienen antiguos adt.

Desde http://developer.android.com/tools/sdk/tools-notes.html :

Dependencias: Android SDK Platform-tools revisión 18 o posterior. Si está desarrollando en Eclipse con ADT, tenga en cuenta que esta versión de SDK Tools está diseñada para ser utilizada con ADT 22.6.1 y posterior. Si aún no lo ha hecho, actualice su complemento ADT a 22.6.1.

¿La única solución es descargar un nuevo eclipse independiente y un complemento externo para ello? ¿El estudio de Android enfrenta los mismos problemas?

Medio ambiente: linux x64.

Hoy, yo y uno de mis amigos enfrentamos el mismo problema, así que he intentado muchas cosas, como reiniciar eclipse , revisar actualizaciones , etc., pero ninguna me funcionaba.

Luego encontré una solución de Aquí y funciona como un encanto para mí y también para mi amigo.

Sigue los pasos aquí:

  • Inicie Eclipse, luego seleccione Ayuda> Instalar nuevo software.
  • Haga clic en Agregar, en la esquina superior derecha.
  • En el cuadro de diálogo Agregar repository que aparece, ingrese “Complemento ADT” para el Nombre y la siguiente URL para la Ubicación:

    https://dl-ssl.google.com/android/eclipse/

  • Haga clic en Aceptar.

Si tiene problemas para adquirir el complemento, intente usar “http” en la URL de ubicación, en lugar de “https” (se prefiere https por razones de seguridad).

  • En el cuadro de diálogo Software disponible, seleccione la checkbox junto a Herramientas del desarrollador y haga clic en Siguiente.
  • En la siguiente ventana, verá una lista de las herramientas que se descargarán. Haga clic en Siguiente. Lea y acepte los acuerdos de licencia, luego haga clic en Finalizar.
  • Si recibe una advertencia de seguridad que indique que no se puede establecer la autenticidad o validez del software, haga clic en Aceptar.
  • Cuando la instalación finalice, reinicie Eclipse.

Reporté este error ayer. La solución es usar Ayuda -> Instalar nueva opción de software con httpS: // protocolo ( s es importante). No se necesitan descargas especiales o reinstalaciones, simplemente elija el sitio de actualización correcto.

El problema es que el sitio de actualización predeterminado en Android ADT es

http://dl-ssl.google.com/android/eclipse/

pero este sitio no se actualiza correctamente

Y la solución es agregar un nuevo sitio de instalación con protocolo https

https://dl-ssl.google.com/android/eclipse/

Haga clic en Ayuda-> Instalar nuevo software-> Agregar

Y usa este sitio para actualizar ADT

Problema: https://code.google.com/p/android/issues/detail?id=67325

Para resolver este problema, aquí he cubierto los pasos, seguramente te ayudará.

Por favor, sigue estos pasos:

  1. Ayuda | Instalar nuevo software

  2. Seleccione el sitio de actualización de ADT (hay dos, uno con http: // y uno con https: // Si uno no funciona, intente con el otro.

  3. Seleccione la sección de herramientas del desarrollador y presione siguiente.

  4. Debería ver un cuadro de diálogo que dice “este software ya está instalado; en su lugar, se realizará una actualización”. Al hacer clic en Aceptar, se instalará 22.6.1.

Actualización 27/03/2014

Lanzaron 22.6.2 y arreglaron este problema, así que actualice su ADT a la nueva versión.

Puede ver este hilo: No se puede actualizar desde ADT 22.3.0. a 22.6.1

Puede ir a Window-> Android SDK Manager y verificar qué versión tiene. En mi caso, muestra que ya tengo el kit de herramientas 22.6.1 instalado pero sigo recibiendo el error . Ya sea que ya lo tenga o no, puede hacer lo siguiente para solucionarlo.

  • Vaya a Ayuda-> Instalar nuevo software … En el cuadro de diálogo que se muestra a continuación, haga clic en el botón ‘Agregar’ en la parte superior derecha.
  • Pegue https://dl-ssl.google.com/android/eclipse/ en Ubicación. Puedes ponerle un nombre.
  • Haga clic en Aceptar y siga el cuadro de diálogo haciendo clic en Siguiente.
  • Si se le solicita con un mensaje que dice que ya lo tiene, simplemente acuerde para que se actualice (o instale si no estaba allí).

Esto debería resolver el problema. fuente: http://codewriterstips.blogspot.nl

si tu SDK de Android es viejo. debes descargar el nuevo SDK de Android en developer.android.com y copiar una carpeta nececary en él.