¿Cómo puedo actualizar mi ADT en Eclipse?

He intentado actualizar mi Eclipse. Actualmente tengo hasta 2.2 Android SDK en mi Eclipse. Ayer he actualizado mi Eclipse de esta manera:

Eclipse -> ventana -> Android SDK Manager -> He marcado dos casillas de verificación de la lista. Herramientas -> Herramientas de Android SDK y herramientas de Android SDK Platform.

He publicado aquí algunas últimas líneas del mensaje que recibo al descargar e instalar:

Preparación para instalar archivos
Descargando Android SDK Platform-tools, revisión 12
Instalación de Android SDK Platform-tools, revisión 12
Detener el servidor ADB fue exitoso.
Herramientas-plataforma Android SDK instaladas, revisión 12
Descarga de herramientas de Android SDK, revisión 20
Instalar Android SDK Tools, revisión 20
[post_tools_install.bat] Actualización de SDK Manager.exe
[post_tools_install.bat] 1 archivo (s) copiados.
[post_tools_install.bat] Actualizando AVD Manager.exe
[post_tools_install.bat] 1 archivo (s) copiados.
Herramientas instaladas de Android SDK, revisión 20
Detener el servidor ADB fue exitoso.
El inicio del servidor ADB fue exitoso.
Hecho. 2 paquetes instalados.
Obteniendo URL: https://dl-ssl.google.com/android/repository/addon.xml
Error al buscar la URL https://dl-ssl.google.com/android/repository/addon.xml , razón: dl-ssl.google.com
Obteniendo URL: http://software.intel.com/sites/landingpage/android/addon.xml
Error al buscar la URL http://software.intel.com/sites/landingpage/android/addon.xml , reason: software.intel.com
Carga de paquetes lista.

Pero después de todo esto después de que cerré Eclipse y quería volver a empezar, arrojó el error:

Este Android SDK requiere Android Developer Toolkit versión 20.0.0 o superior. La versión actual es 16.0.0.v201203301601-306762. Actualice ADT a la última versión.

En las preferencias recibí este error:

Este Android SDK requiere Android Develop … Actualice ADT a la última versión.

Has actualizado el sdk de Android pero no has actualizado el adt para que coincida con él.

Puedes actualizar el adt desde aquí

Es posible que deba actualizar la fuente del software para su actualización de adt

Ve a eclipse> ayuda> Buscar actualizaciones.

Debería enumerar la última actualización de adt. Si no funciona, intente lo mismo * Vaya a eclipse> ayuda> Instalar nuevo software * pero ahora haga lo siguiente:

Enumerará las actualizaciones disponibles, que idealmente debería ser adt 20.xx

Eclipse se reiniciará y espero que todo funcione bien para usted.

Tuve este problema Como ya tenía la dirección ADT , no pude seguir la solución sugerida. La razón por la que la actualización no funcionaba en mi caso es porque la dirección ADT no estaba marcada en la lista de “Actualizaciones disponibles”.

1) Ir a eclipse> ayuda> Instalar nuevo software

2) Haga clic en “Sitio de software disponible”

3) Verifique que tenga la dirección ADT

4) Si no lo agregas siguiendo los pasos de Murtuza Kabul

5) En caso afirmativo, verifique que la dirección esté marcada (casilla a la izquierda de la dirección)

Ejecuté la actualización después de haber lanzado Eclipse como administrador para asegurarme de que no iba a tener problemas para acceder a las carpetas del sistema

Vi la documentación de Eclipse ADT y descubrí la manera de evitar este problema. Pude actualizar mi herramienta de SDK a 22.0.4 (última versión).

La solución es : primero actualice ADT a 22.0.4 y luego actualice la herramienta SDK a 22.0.4

El enlace de arriba dice,

ADT 22.0.4 está diseñado para usarse con SDK Tools r22.0.4 . Si aún no ha instalado SDK Tools r22.0.4 en su SDK, use el Administrador de Android SDK para hacerlo

Lo que tuve que hacer fue actualizar mi ADT a 22.0.4 (última versión) y luego pude actualizar la herramienta SDK a 22.0.4 . Pensé que solo la herramienta SDK se había actualizado, no ADT, por lo que estaba actualizando la herramienta SDK con la versión anterior de ADT (22.0.1).

Cómo actualizar su ADT a la última versión

  1. En Eclipse ve a Help

  2. Install New Software —> Add

  3. dentro de Add Repository escribe el nombre: ADT (o lo que quieras)

  4. Ubicación: https://dl-ssl.google.com/android/eclipse/

  5. después de cargar, deberías obtener herramientas de desarrollo y complementos NDK

  6. compruebe ambos si desea usar el Native Developer Kit (NDK) en el futuro o verifique

  7. Solo herramienta de desarrollador

  8. haga clic en Siguiente

  9. Terminar

En mi caso, al abrir “Ayuda” >> “Instalar nuevo software” no tenía entradas para ninguna URL (las URL anteriores no estaban allí), así que las agregué manualmente. Y actualizado … y Voilaaaa !! Las publicaciones anteriores me han sido muy útiles para resolver este problema.

Ejecutarme como administrador luego de seguir otros comentarios me solucionó el problema 🙂

La razón de esto es que con la nueva actualización, cambiaron la URL del sitio de actualización de las herramientas para desarrolladores de Android para que requiera HTTPS. Si está actualizando ADT, asegúrese de usar HTTPS en la URL del sitio de actualización de Android Developer Tools.

Tuve el mismo problema cuando no hay archivos en los archivos Generated Java, BuildConfig y R.java faltan. La opción de comstackción automática no está generando.
En Eclipse en Proyecto, desmarca Crear automáticamente. Luego, en Proyecto, selecciona Desarrollar proyecto. Es posible que deba arreglar el proyecto