¿Android es compatible con JDK 6 o 7

Soy nuevo en el desarrollo de Android. ¿Puedo usar mi código Java existente desarrollado usando JDK 7 en Android?

Las funciones usan xerces dom y xslt y xpathapi. Actualmente, cuando instalé el entorno Android Eclipse ADT, estas funciones no se están comstackndo. También me gustaría saber si un dispositivo Android en sí mismo es compatible con JRE 6 o 7?

Originalmente, las herramientas de desarrollo de Android solo admitían las características jdk 6. Pero eso fue cambiado, primero por Android Studio 0.3.2 en octubre de 2013, ver: http://tools.android.com/recent/androidstudio032released

Compatibilidad con funciones de idioma como el operador de diamante, captura múltiple, try-with-resources, cadenas en switches, etc. Al crear un nuevo proyecto, puede especificar un nivel de idioma de origen: enter image description here Tenga en cuenta que puede utilizar todas estas funciones de idioma no solo con Android KitKat, sino también con versiones anteriores de Android. Hay una excepción a eso: try-with-resources, que requerirá minSdkVersion 19. Por lo tanto, Studio marcará cualquier uso en su código de try-with-resources si su minSdkVersion es menor que 19:

luego, mediante el plugin ADT 22.6 en marzo de 2014, ver: http://developer.android.com/tools/sdk/eclipse-adt.html

Se agregó soporte para las características del lenguaje Java 7, como multi-catch, try-with-resources y el operador de diamantes. Estas características requieren la versión 19 o superior de las herramientas de comstackción. Try-with-resources requiere minSdkVersion 19; el rest de las nuevas funciones de idioma requieren minSdkVersion 8 o superior. Para usar las nuevas funciones de idioma después de instalar ADT 22.6.0, asegúrese de ejecutar Eclipse en JDK 7 y cambie la configuración de su proyecto de aplicación para usar JDK 7.

Android no está destinado a ser 100% compatible con ninguna versión de la API de Java SE, ni 6, 8 ni ninguna. esta fue la razón del caso judicial de Oracle en contra de Google, acusando a Google de fragmentar Java. Algunas API son imposibles de implementar en Android como Swing; ¡Imagina una ventana con un botón de cierre en Android! Otros se retrasaron pero se implementaron: por ejemplo: la clase Charset está en Java SE 1.4 pero se implementó en Android API 9, AutoClosable en Java 7 implementado en Android API nivel 19 para permitir la implementación de la función de lenguaje try-with-resources. Algunas API existen pero para fines diferentes como la Consola.

En primer lugar, existe una diferencia entre Java JDK y JRE. JRE es Java Runtime Environment mientras que JDK es Java Development Kit. Es el JDK que necesita para el desarrollo de aplicaciones de Android junto con el SDK de Android existente.

El SDK de Android puede usar JDK 6 o 7, sin embargo, SÓLO puede usar la API de JDK 6.

Sí, jdk 7 ahora es compatible con Android. A partir de las herramientas de comstackción 19

JDK 5/6 SOLAMENTE. En realidad, andriod no es compatible con jdk 6 por completo porque Android jdk 6 no es Oracle JDK 6.

Android planea apoyar a Java 7

Apace Harmony