Error de Eclipse / Maven: “No se proporciona ningún comstackdor en este entorno”

Soy un recién llegado relativo al mundo del desarrollo empresarial de Java. El gurú de Java de mi organización está en permiso familiar indefinido, y se me ha asignado la tarea de mantener algunas de las aplicaciones Java que desarrolló. Instaló Eclipse [Kepler SR1] con Maven en mi computadora antes de que se fuera, y parecía funcionar bien.

Ahora estoy listo para implementar mi primera modificación y necesito ejecutar una install Maven, pero estoy teniendo problemas para hacer que funcione; obtengo el siguiente resultado en mi consola:

[ERROR] Error al ejecutar el objective org.apache.maven.plugins: maven-compiler-plugin: 3.1: comstackr (comstackción predeterminada) en el proyecto mrpapp: Comstackción fallida
[ERROR] No se proporciona ningún comstackdor en este entorno. ¿Quizás estás ejecutando un JRE en lugar de un JDK?

pero definitivamente estoy ejecutando un JDK y no un JRE. Comprobé dos veces mi $JAVA_HOME ( C:\Program Files (x86)\Java\jdk1.7.0_60 ) y tiene un javac.exe en su directorio bin .

Adjunto una copia de mi archivo pom.xml para su revisión. Estoy seguro de que hay algo ahí que está causando el problema, pero no estoy seguro de qué podría ser. Estoy usando una computadora portátil con Windows 7 64 bits, si necesita más información sobre la plataforma / entorno, también puedo suministrarla.

Cualquier ayuda será apreciada.

Vaya a Ventana → Preferencias → Java → JRE instalados.

Y vea si hay una entrada que apunta a su ruta JDK, y si no, haga clic en el botón Editar y ponga la ruta que configuró su entorno JAVA_HOME .

Vaya a Ventana> Preferencias> Java> JRE instalados> y verifique sus JRE instalados. Debería tener una entrada con un JDK allí.

https://cduu.wordpress.com/2013/03/08/maven-eclipse-compiler-error-no-compiler-is-provided-in-this-environment/

Screen_shot Agregue ‘tools.jar’ al JRE instalado.

  1. Eclipse -> window -> preference .
  2. Seleccione installed JREs -> Edit
  3. Agregar tarros externos
  4. seleccione tools.jar desde la tools.jar java/JDKx.x/lib .
  5. Haga clic en Finalizar

Intenté todas las cosas; el que funcionó para mí es:

  1. Haga clic derecho en el proyecto Eclipse y navegue a las propiedades.
  2. Haga clic en Java Build Path y vaya a la pestaña Bibliotecas.
  3. Compruebe qué versión de Java se agrega allí; ¿es JRE o JDK?
  4. Si está utilizando el proyecto Maven y quiere construir una solución.
  5. Seleccione el JRE agregó su y haga clic en quitar.
  6. Haga clic en Agregar carpeta de clase externa y agregue la instalación de JDK seleccionando desde el sistema.
  7. Haga clic en Aplicar y Aceptar.
  8. Reinicie Eclipse.
  9. Construir exitosamente

También me enfrenté a un error similar cuando estaba trabajando con Jdk1.8_92. Para mí, encontré tools.jar faltaba en mi carpeta jdk. Como estaba corriendo en consola, no pude probar las opciones de eclipse sugeridas por otros.

Instalé jdk-8u92-windows-x64. Después de probar todas las opciones, observé que tools.jar faltaba en la carpeta jdk1.8.0_92 / lib. Copié tools.jar de mi versión anterior de Java. Entonces fue capaz de comstackr.

Agregue estas configuraciones en pom.xml

  ...  ...   maven-compiler-plugin 3.1  1.7 1.7 true C:\Program Files\Java\jdk1.7.0_79\bin\javac     ...  

Por favor, compruebe si tiene las siguientes entradas en el elemento de su pom.xml especialmente el jdk.version porque cambiar a un jre instalado no me solucionó el error similar.

  1.7 4.1.1.RELEASE 1.2 4.11  

si alguien está ejecutando Eclipse en Ubuntu y tiene este problema, he encontrado la respuesta siguiendo estos pasos:

  1. Eclipse-> ventana-> preferencia.
  2. Seleccione JRE instalados-> Agregar
  3. Seleccione standardVM.
  4. JRE home: presione el botón [Directorio …].
  5. Elija su java (mi problema era que mi eclipse se estaba ejecutando con java8 y mi máquina virtual estaba con java7), en mi caso, java8 se instaló en usr / local / jvm / java-8-oracle.
  6. Presione finalizar
  7. Luego presione la flecha JRES instalada para que pueda ver las otras opciones.
  8. Ve al entorno de ejecución.
  9. Seleccione JavaSE-1.6 a la izquierda y a la derecha (el JRE compatible), tiene que elegir la Java que acaba de instalar (en mi caso java-8-oracle). tienes que hacer estos pasos con JavaSE1.8.
  10. Haga clic en Aceptar y reinicie Eclipse.

Obtuve el mismo error al intentar ejecutar una construcción maven dentro de Eclipse en una instalación de Eclipse Neon (para desarrolladores JEE) recién instalada, en Windows 10 con JDK 8 y JRE 8 instalados.

Había intentado especificar tools.jar como lib externo, así como también configurar jdk como -vm en eclipse. Ninguna de estas cosas funcionó.

Seleccionar el JDK como el env de ejecución predeterminado como se mencionó anteriormente hizo el truco ..

  1. Eclipse-> ventana-> preferencia-> java-> JRE instalados-> Ambientes de ejecución.
  2. Seleccione JavaSE-1.8
  3. Compruebe JDK1.8 en “JRE compatibles”.

El texto sobre el cuadro de lista de JRE compatible en el paso 3 dice “se puede especificar un JRE predeterminado al marcarlo”

Nota: También tengo el complemento comstackdor maven que explícitamente lista 1.8 en el pom

   org.apache.maven.plugins maven-compiler-plugin 3.1  1.8 1.8   

Cuando estaba ejecutando mvn compile , estaba obteniendo el error debajo de la consola:

 [INFO] Changes detected - recompiling the module! [WARNING] File encoding has not been set, using platform encoding Cp1252, ie build is platform dependent! [INFO] Compiling 1087 source files to C:\Code\DevVNextComplete\Development_vNext\Source\JARS\target\classes [INFO] ------------------------------------------------------------- [ERROR] COMPILATION ERROR : [INFO] ------------------------------------------------------------- [ERROR] No compiler is provided in this environment. Perhaps you are running on a JRE rather than a JDK? [INFO] 1 error 

[Resolución]

Había agregado la variable JAVA_HOME en las variables de mi entorno y luego funcionó.

enter image description here

En mi caso, había creado una configuración de ejecución y siempre que intentaba ejecutarla, se mostraba el error. Después de buscar en algunos sitios web, edité la configuración de ejecución y en la pestaña JRE, seleccioné el JRE en tiempo de ejecución como ‘JRE de espacio de trabajo predeterminado’ que ya había configurado para apuntar a mi instalación Java JDK local (por ejemplo C: \ Archivos de progtwig (x86) \ Java \ jdk1.8.0_51). Esto resolvió mi problema. Quizás ayude a alguien allá afuera.

JRE instalado En mi caso, resolví el problema eliminando duplicados de nombres, solo guardé uno con el nombre: jdk.1.8.0_101

estaba recibiendo el mismo problema, apuntó la carpeta java a bin en eclipse usando: windows> preferences> java> JREs instalados> eliminar cualquier JRE existente y apuntarlo a su carpeta java bin (principalmente en C: \ Program Files \ Java \ jdk1.8 .x_xx).

luego, ejecutar maven install debería funcionar.

  1. Desinstale Java (JDK / JRE) anterior del sistema (mantenga una (última) versión java), elimine también las entradas java jre / jdk anteriores en las variables de entorno PATH / CLASSPATH
  2. Eclipse-> Ventana-> Preferencias-> JRE instalados-> Agregar / editar JDK desde la última instalación
  3. Eclipse-> Ventana-> Preferencias-> JREs instalados-> Entorno de ejecución-> Seleccione la versión java deseada a la izquierda y haga clic en la checkbox a la derecha
  4. Si usa maven, incluya la siguiente etiqueta en pom.xml (actualice las versiones según sea necesario) dentro de la etiqueta de complementos.

      org.apache.maven.plugins maven-compiler-plugin 3.1  1.8 1.8   
  5. Haga clic derecho en el proyecto eclipse Maven -> Actualizar proyecto

Para mí (en Windows 10), recibí el error “No se proporciona ningún comstackdor en este entorno” en el símbolo del sistema de Windows cuando ejecuté mvn install . El arreglo estaba cambiando la variable de entorno JAVA_HOME para apuntar a mi jdk (C: \ Program Files \ Java \ jdk1.8.0_101); anteriormente había apuntado a la jre.

Y para que Eclipse utilizara el nuevo jdk, edité eclipse.ini en mi distribución de eclipse y cambié la línea para -vm a C:\Program Files\Java\jdk1.8.0_101\bin .

compruebe la versión de java en las versiones pom.xml y jre en Eclipse-> Ventana-> Preferencias-> JRE instalados. En mi caso pom.xml tiene una versión diferente (tenía 1.8 mientras que eclipse usaba 1.7). Se corrigió la versión en pom.xml a 1.7 trabajado.

si está trabajando fuera de eclipse en la ventana de comandos
asegúrese de tener el JAVA_HOME correcto y de que ese directorio contiene el comstackdor ingresando el siguiente comando en la ventana de comandos:

 dir %JAVA_HOME%\bin\javac.* 

1. Vaya a Windows -> Preferencias -> Java -> JRE instalados -> Entornos de ejecución

2. Seleccione la versión de Java que está utilizando actualmente en el cuadro “Entornos de ejecución”. Para que en el cuadro “JRE compatibles”, pueda ver como ” jre1.8.0_102 [coincidencia perfecta] ” (si su versión de Java es 1.8). Luego intenta construir usando maven.

Maven requiere JDK para comstackr. En Eclipse necesitas CAMBIAR / REEMPLAZAR tu JRE a la ruta JDK a la que apunta JAVA_HOME. Vaya a Ventana> Preferencias> Java> JRE instalados.

Asegúrate de que el plugin maven-compiler en tu pom.xml tenga la fuente y el destino de la versión java en tu JAVA_HOME

http://learn-automation.com/maven-no-compiler-is-provided-in-this-environment-selenium/

Para verificar qué usa tu Maven, abre una línea de comando y escribe:

 mvn –version 

Verifique que JAVA_HOME se refiera a un hogar JDK y no a un JRE

En Windows:

Vaya a Propiedades del sistema -> Configuración avanzada del sistema -> Avanzado -> variable de entorno y en la sección Variables del sistema seleccione la variable JAVA_HOME y haga clic en Editar Rellene el formulario con el siguiente nombre de variable: JAVA_HOME Valor de la variable:

En Unix:

 export JAVA_HOME= 

ver este enlace

Asegúrese de que tiene %JAVA_HOME% establecido escribiendo echo %JAVA_HOME% en Símbolo del sistema. Si no tiene ese conjunto, entonces necesita agregar su ruta de Java a las variables ambientales de Windows.

Siga: Windows -> Preferencias -> Java —> JRE instalados

Imagen de muestra

Haga clic en ” Buscar …”

Navega a la unidad C —> Archivos de progtwig

Imagen de muestra 2

Eclipse encontrará todos los jre’s y jdk’s -> seleccione uno de los jdk y seleccione Aplicar