Eclipse informa que la biblioteca de representación es más reciente que el complemento ADT

En una nueva instalación de Android SDK, el diseño gráfico de Eclipse está en blanco, en lugar de mostrar la representación del diseño. Eclipse muestra este mensaje:

Esta versión de la biblioteca de representación es más reciente que su versión del complemento ADT. Actualice el complemento ADT.

El informe de error Eclipse informa que la biblioteca de representación más reciente que el complemento ADT enumera los pasos para reproducir. ¿Cómo puedo solucionar esto?

  1. Haga clic en Ayuda> Instalar nuevo software .
  2. En el campo Trabajar con , ingrese: https://dl-ssl.google.com/android/eclipse/
  3. Seleccione Herramientas de desarrollo / Herramientas de desarrollo de Android .
  4. Haga clic en Siguiente y complete el asistente.

Cambia la versión de Android mientras renderizas el diseño.

enter image description here

El cambio en la versión de la API 18 a 17 me funciona.

Editar: la solución también funcionó para Android Studio.

La razón de la advertencia es que usa Old ADT (herramientas de desarrollo de Android), por lo que actualice su ADT siguiendo los procedimientos a continuación.

Procedimiento 1:

  1. Dentro de Eclipse Haga clic en el menú Ayuda
  2. Elija Buscar actualizaciones
  3. Mostrará las Actualizaciones necesarias en esa ventana, elija Todas las opciones con la checkbox o seleccione ADT actualizado.

enter image description here

Procedimiento 2:

Haga clic en Ayuda> Instalar nuevo software. En el campo Trabajar con, ingrese: https://dl-ssl.google.com/android/eclipse/ Seleccione Herramientas de desarrollo / Herramientas de desarrollo de Android. Haga clic en Siguiente y complete el asistente.

¿Cambio la API versión 17, 19, 21 y 23 en formato xml?

&&

Herramientas de desarrollo de Android actualizadas 23.0.7, pero todavía no puedo renderizar correctamente el diseño, así que estoy actualizando Android DDMS 23.0.7 , funciona perfecto … !!!

Intente desinstalar una vez desde Ayuda -> Detalles de instalación

e intente de nuevo con http://dl-ssl.google.com/android/eclipse/

Cambie la versión de destino a las nuevas actualizaciones que tenga. De lo contrario, cambie la versión de SDK que tiene en el archivo de manifiesto de Android.

 android:minSdkVersion="8" android:targetSdkVersion="18"