No se encontraron com.google.android.gms: play-services: 3.1.59 3.2.25 4.0.30 4.1.32 4.2.40 4.2.42 4.3.23 4.4.52 5.0.77 5.0.89 5.2.08 6.1. 11 6.1.71 6.5.87

hacer referencia a los servicios de reproducción a través de gradle dejó de funcionar para mí, lo redujo, incluso la muestra que usé como referencia en primer lugar dejó de funcionar: https://plus.google.com/+AndroidDevelopers/posts/4Yhpn6p9icf

FAILURE: Build failed with an exception. * What went wrong: A problem occurred configuring project ':auth'. > Failed to notify project evaluation listener. > Could not resolve all dependencies for configuration ':auth:compile'. > Could not find com.google.android.gms:play-services:3.1.36. Required by: gpsdemos:auth:unspecified * Try: Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. BUILD FAILED Total time: 3.577 secs 

Me temo que solo aumentó la versión, pero eso genera 2 preguntas: # 1) ¿cuál es la nueva? # 2) ¿por qué se ha ido la versión anterior?

Verifique si también instaló el “Repositorio de Google”. De lo contrario, también debe instalar el “Repositorio de Google” en su Administrador de SDK.

También tenga en cuenta que puede haber 2 instalaciones de SDK, una proveniente de AndroidStudio y una que pueda haber instalado. Mejor consolidar esto para una instalación, esto es una trampa común, que lo tenga instalado en una instalación, pero falla cuando construye con la otra instalación.

Ejemplo de cómo acceder a SDK Manager para Google Repository

Simplemente instala Google Repository desde tu administrador de SDK y luego reinicia Android Studio.

Además de instalar el repository y los paquetes SDK, se debe tener en cuenta que el número de versión cambia periódicamente. Una solución simple en este punto es reemplazar el número de versión específico con un símbolo más (+).

 compile 'com.google.android.gms:play-services:+' 

Las instrucciones de Google indican que uno debe asegurarse de actualizar los números de versión, sin embargo, agregar el plus se refiere a los cambios en el control de versiones. También tenga en cuenta que al construir en Android Studio, aparecerá un mensaje en la línea de estado cuando esté disponible una nueva versión.

Uno puede ver las versiones disponibles de los servicios de juego profundizando en la ruta correcta del repository:

ruta de repositorio de servicios de juego

Referencias

Este sitio también tiene instrucciones para Eclipse y otros IDE.

ADS-Setup

He estado luchando con este problema durante horas hasta que encontré esta publicación. Al igual que dijo @ligi, algunas personas tienen dos carpetas de SDK (Android Studio, que se incluye y Eclipse). El problema es que no importa si descargó la biblioteca de servicios de Google Play en ambas carpetas de SDK, su variable de entorno ANDROID_HOME debe apuntar a la carpeta SDK utilizada por Android Studio.

 SDK Folder A (Used on Eclipse) SDK Folder B (Used on AS) ANDROID_HOME= 

Después de cambiar la ruta de esta variable, el error desapareció.

Tuve el mismo problema porque tuve:

 compile 'com.google.android.gms:play-services:5.2.8' 

y resolví cambiar los números de versión por un ‘+’. entonces las líneas tienen que ser:

 compile 'com.google.android.gms:play-services:+' 

Agregar esto como segunda referencia porque tuve un problema similar …
Tuve que agregar explícitamente ‘.aar’ como un tipo de archivo registrado en la categoría ‘Archivos’ en la configuración de AS.

Si ya tiene el repository de Google instalado, asegúrese de que esté actualizado. Tuve que actualizar mi Repositorio y servicios de Google. Esto fue después de actualizar Android Studio.

Agregué una nueva variable de entorno ANDROID_HOME y la apunté al SDK (C: \ Archivos de progtwig (x86) \ Android \ android-studio \ sdk) que está dentro del directorio de instalación de Android Studio. (Las variables de entorno son parte de Windows, puede acceder a ellas a través de las propiedades avanzadas de la computadora … googleelas para obtener más información)

Yo también tengo el mismo problema y lo resolví ahora.

Según las soluciones mencionadas anteriormente por otros, probé todas las cosas y no resuelve mi problema.
Incluso si tiene dos ubicaciones de SDK, no se preocupe y compruebe si su dispositivo Android está configurado para Android Studio SDK (si tiene el repository de Android y todo en esa ubicación de SDK).

Solución:

  • Ve a la estructura de tu proyecto
  • Seleccione sus módulos
  • Haga clic en el toque de dependencia en el lado derecho
  • Añadir dependencia de la biblioteca
  • “com.google.android.gms: play-service: +”

Ahora funcionará.

Tengo la misma pregunta.

Debería agregar algunas dependencias en build.gradle, solo se ve así

 dependencies { compile fileTree(dir: 'libs', include: ['*.jar']) compile project(':libcocos2dx') compile 'com.google.firebase:firebase-ads:11.6.0' // the key point line compile 'com.google.android.gms:play-services-auth:11.6.0' } 

Por error agregué la comstackción com.google.android.gms:play-services:5.+ en dependencias en el bloque de script de comstackción. Debe agregarlo en el segundo bloque de dependencia. make changes-> synch project con gradle.