Actualización de Android Studio Gradle a la versión 0.5.0 – Gradle Migrating de 0.8 a 0.9 – También Android Studio mejora a 0.8.1

Después de los estados de mensaje de actualización:

Failed to refresh Gradle project 'XXX' The project is using an unsupported version of the Android Gradle plug-in (0.8.3). Version 0.9.0 introduced incompatible changes in the build language. Please read the migration guide to learn how to update your project. 

Mismo tipo de problema después de la actualización a Android Studio a la versión> = 0.8.0

Android Studio 0.5.0 requiere el complemento gradle 0.9.0

El gradle-plugin 0.9.0 funciona con Gradle 1.10 o Gradle 1.11

Modifique su script build.gradle según lo sugerido por Cedric.

Existe una relación entre gradle-plugin y la versión gradle. Por ejemplo

ACTUALIZADO AL 27/11/2015 :

 com.android.tools.build:gradle:0.6.+ -> gradle 1.8 com.android.tools.build:gradle:0.7.+ -> gradle 1.9 com.android.tools.build:gradle:0.8.+ -> gradle 1.9/1.10 com.android.tools.build:gradle:0.9.+ -> gradle 1.10/1.11 com.android.tools.build:gradle:0.10.+ -> gradle 1.10/1.11/1.12 com.android.tools.build:gradle:0.11.+ -> gradle 1.10/1.11/1.12 com.android.tools.build:gradle:0.12.+ -> gradle 1.10/1.11/1.12 com.android.tools.build:gradle:0.13.+ -> gradle 2.1 com.android.tools.build:gradle:0.14.+ -> gradle 2.1 com.android.tools.build:gradle:1.0.+ -> gradle 2.2.1-2.3 com.android.tools.build:gradle:1.1.+ -> gradle 2.2.1-2.3 com.android.tools.build:gradle:1.2.+ -> gradle 2.2.1+ com.android.tools.build:gradle:1.3.+ -> gradle 2.2.1+ com.android.tools.build:gradle:1.3.+ -> gradle 2.2.1+ com.android.tools.build:gradle:1.5.+ -> gradle 2.2.1+ com.android.tools.build:gradle:2.0.+ -> gradle 2.10.0+ 

Puede encontrar la versión gradle utilizada en su proyecto en el archivo gradle/wrapper/gradle-wrapper.properties

También hay una relación entre gradle-plugin y la versión IDE.

 Android Studio 0.3.x -> gradle-plugin 0.6 Android Studio 0.4.x -> gradle-plugin 0.7 Android Studio 0.4.3+ -> gradle-plugin 0.8 Android Studio 0.5.x -> gradle-plugin 0.9 Android Studio 0.5.8 -> gradle-plugin 0.9.+ or 0.10.+ Android Studio 0.5.9 -> gradle-plugin 0.9.+ or 0.10.4+ Android Studio 0.6.x -> gradle-plugin 0.11.+ Android Studio 0.8.x -> gradle-plugin 0.12.+ Android Studio 0.8.11+ -> gradle-plugin 0.13.+ / gradle-plugin 0.12.+ Android Studio 0.9.x -> gradle-plugin 0.14.+ Android Studio 1.0.0 -> gradle-plugin 1.0.0 Android Studio 1.1.x -> gradle-plugin 1.0.0/ 1.1.x / 1.2.x Android Studio 1.2.x -> gradle-plugin 1.0.0/ 1.1.x / 1.2.x Android Studio 1.3.x -> gradle-plugin 1.0.0/ 1.1.x / 1.2.x / 1.3.x Android Studio 1.4.x -> gradle-plugin 1.0.0/ 1.1.x / 1.2.x / 1.3.x Android Studio 1.5.x -> gradle-plugin 1.0.0/ 1.1.x / 1.2.x / 1.3.x / 1.5.x Android Studio 2.0.x -> gradle-plugin 2.0.0 Also gradle 1.12 requires Android Studio 0.5.8+ 

Para noticias actualizadas puede consultar este enlace: http://tools.android.com/recent
Para obtener documentación actualizada sobre el complemento de Gradle, consulte aquí .

Si cambia su versión de complemento, verifique la compatibilidad y luego haga clic en sync project con sus archivos gradle. Descargará una nueva versión de complemento si la necesita.

Para solucionarlo, abra el archivo llamado build.gradle en la raíz del proyecto y cambie la versión de gradle a 0.9. +.

 buildscript { repositories { mavenCentral() } dependencies { classpath 'com.android.tools.build:gradle:0.9.+' } } 

Se repetirá para cada proyecto; (

Si luego org.gradle.api.artifacts.result.ResolvedComponentResult un mensaje como ” No se puede cargar la clase” org.gradle.api.artifacts.result.ResolvedComponentResult “.

Vaya a su project_folder/gradle/wrapper y edite Unable to load class 'org.gradle.api.artifacts.result.ResolvedComponentResult'. archivo que cambia la distributionUrl a

 distributionUrl=http\://services.gradle.org/distributions/gradle-1.10-all.zip 

Después de la actualización a la versión 0.8.1 (descarga completa y copia de la carpeta SDK), tenía que tener una nueva versión de gradle instalada por IDE (usando el enlace “Solucionarlo” un par de veces: S) y modificando la sección “android” del archivo gradle en la carpeta del proyecto de 19.0 a 19.1, como se muestra a continuación: buildscript {repositories {mavenCentral ()} dependencias {classpath ‘com.android.tools.build:gradle:0.12.+’}} apply plugin: ‘android’

 repositories { mavenCentral() } android { compileSdkVersion 19 buildToolsVersion '19.1.0' defaultConfig { minSdkVersion 7 targetSdkVersion 19 } } dependencies { compile 'com.android.support:appcompat-v7:19.1.+' compile 'com.android.support:support-v4:19.1.0' } 

Tuve el mismo error, pero ya tenía

 classpath 'com.android.tools.build:gradle:0.9.+' 

establecer así, como Cedric Simon sugirió. Gracias al comentario de mattblang, traté de cambiarlo a 0.9.0 y actualizarlo

para aquellos que no saben dónde está el botón de actualización, busque a continuación:

enter image description here

Después probé lo que sucede cuando lo cambio de nuevo a 0.9. + Y lo renuevo nuevamente … y todavía funciona.

Así que supongo que solo presionar el botón de actualización hubiera sido suficiente.

Me enfrenté al mismo problema Migrando a la versión 1.0.0 de Gradle … Esta solución me ayuda y guarda la fecha …

Actualizar el plugin y los números de la versión de Gradle

La versión del complemento de Android Gradle suele aparecer en el archivo build.gradle de nivel superior del proyecto y se puede actualizar de la siguiente manera:

Déjame considerar que tengo la versión 0.8 .. mostrar mi build.gradle (carpeta raíz del proyecto / build.gradle) muestra

dependencias {classpath ‘com.android.tools.build:gradle:0.8.+’}

elimine la versión anterior (0.8) y agregue la nueva versión 1.0.0 como esta

dependencias {classpath ‘com.android.tools.build:gradle:1.0.0’}

Y también cambie el gradle / wrapper / gradle-wrapper.properties :

elimine el antiguo distributionUrl y agregue una nueva url

distributionUrl = http: //services.gradle.org/distributions/gradle-2.2.1-all.zip

y cambie el runProguard en el proyecto root / app / build.gradle

ANTES DE:

buildTypes {release {runProguard true proguardFiles getDefaultProguardFile (‘proguard-android.txt’), ‘proguard-rules.pro’}}

DESPUÉS:

buildTypes {release {minifyEnabled true proguardFiles getDefaultProguardFile (‘proguard-android.txt’), ‘proguard-rules.pro’}}

Para obtener más información: Migrar Proyecto Gradle (haga clic aquí)

El proyecto de Android más simple tiene el siguiente build.gradle:

 buildscript { repositories { mavenCentral() } dependencies { classpath 'com.android.tools.build:gradle:0.9.0' } } apply plugin: 'android' android { compileSdkVersion 19 buildToolsVersion "19.0.0" } 

Hay 3 áreas principales para este archivo de comstackción de Android:

new-build-system usuario-guía

Cuando actualicé a Android Studio 1.0 encontré que necesitaba actualizar para usar la versión 1.0.0 de gradle.

tuve

  dependencies { classpath 'com.android.tools.build:gradle:1.0.0-rc2' 

Lo cambié para eliminar el “-rc2”

  dependencies { classpath 'com.android.tools.build:gradle:1.0.0' 

Android Studio versión 1.0.2 La idea de un acoplamiento ajustado entre la versión IDE y la versión de comstackción es mala.

Android Studio 1.0.2. Gralde plugin 1.0. + Gradle.properties, distribución URL = http: //services.gradle.org/distributions/gradle-2.2.1-bin.zip

hmm recibo este error cuando trato de agregar esta dependencia.

Error: (22) Se produjo un problema al evaluar el proyecto ‘: aplicación’.

No se pudo encontrar el método classpath () para los argumentos [com.android.tools.build:gradle:0.9.+] en el proyecto ‘: app’.

Ok lo resolvió Esta línea debería ser parte de build.gradle “en la raíz del proyecto” como se indicó anteriormente, pero no lo reconocí. La actualización de las herramientas de comstackción a 19.03 realmente lo insertó automáticamente.