¿Por qué JavaFX no está incluido en OpenJDK 8 en Ubuntu Wily (15.10)?

He descargado OpenJDK 8 hoy vía sudo apt-get install openjdk-8-jdk y parece que JavaFX no está incluido en él.

 > java -version openjdk version "1.8.0_66-internal" OpenJDK Runtime Environment (build 1.8.0_66-internal-b17) OpenJDK Server VM (build 25.66-b17, mixed mode) 

He instalado E (fx) clipse en el último Eclipse (Eclipse Mars) también, pero todavía estoy recibiendo el mensaje javafx no se pudo resolver .

    De acuerdo con la lista de paquetes en Ubuntu Wily Xenial, hay un paquete llamado openjfx . Esto debería ser un candidato para lo que estás buscando:

    JavaFX / OpenJFX 8 – Plataforma de aplicaciones de cliente enriquecido para Java

    Puedes instalarlo a través de:

     sudo apt-get install openjfx 

    Proporciona los siguientes archivos JAR para la instalación de OpenJDK en sistemas Ubuntu:

     /usr/lib/jvm/java-8-openjdk-amd64/jre/lib/ext/jfxrt.jar /usr/lib/jvm/java-8-openjdk-amd64/jre/lib/jfxswt.jar /usr/lib/jvm/java-8-openjdk-amd64/lib/ant-javafx.jar /usr/lib/jvm/java-8-openjdk-amd64/lib/javafx-mx.jar 

    Si desea tener fonts disponibles, por ejemplo para la depuración, también puede instalar:

     sudo apt-get install openjfx-source 

    Utilizo Ubuntu 16.04 y porque ya tenía OpenJDK instalado, este comando ha resuelto el problema. No olvide que JavaFX es parte de OpenJDK.

     sudo apt-get install openjfx