Android L (API 21) – java.lang.IllegalArgumentException: la intención del servicio debe ser explícita

La nueva versión de Android – “Lollipop” (API 21) trae consigo algunos cambios, pero tiene algún precio si desea orientar su aplicación a esa API.

Cuando comenzamos a adaptar nuestras aplicaciones a la nueva API, uno de los primeros problemas que hemos encontrado es la IllegalArgumentException: Service Intent must be explicit

Si ha encontrado el problema y tiene la intención de usar su intención de manera explícita (lo que significa que al iniciar el servicio espera alcanzar exactamente 1 acción de servicio), aquí hay una solución rápida para convertir implícito -> explícito:

 public static Intent createExplicitFromImplicitIntent(Context context, Intent implicitIntent) { // Retrieve all services that can match the given intent PackageManager pm = context.getPackageManager(); List resolveInfo = pm.queryIntentServices(implicitIntent, 0); // Make sure only one match was found if (resolveInfo == null || resolveInfo.size() != 1) { return null; } // Get component info and create ComponentName ResolveInfo serviceInfo = resolveInfo.get(0); String packageName = serviceInfo.serviceInfo.packageName; String className = serviceInfo.serviceInfo.name; ComponentName component = new ComponentName(packageName, className); // Create a new intent. Use the old one for extras and such reuse Intent explicitIntent = new Intent(implicitIntent); // Set the component to be explicit explicitIntent.setComponent(component); return explicitIntent; } 

Deberias hacer eso. Por favor, siéntete libre de comentar para obtener información adicional sobre este nuevo problema.

Comience el servicio explícitamente

 intent = new Intent(context, Service.class); 

O proporcionar explícitamente el paquete en un bash implícito

 intent = new Intent("com.example.intent.ACTION"); intent.setPackage("com.example")