Cómo degradar o instalar una versión anterior de Cocoapods

¿Cómo puedo degradar Cocoapods a una versión anterior o cómo puedo instalar una versión anterior de Cocoapods?

para eliminar su versión actual, simplemente podría ejecutar:

sudo gem uninstall cocoapods 

puede instalar una versión específica de cocoatas de cocoa mediante el siguiente comando:

 sudo gem install cocoapods -v 0.25.0 

Puede usar versiones instaladas más antiguas con el siguiente comando:

 pod _0.25.0_ setup 

En realidad, no es necesario degradar: si necesita usar una versión anterior en algunos proyectos, simplemente especifique la versión que necesita usar después del comando pod .

 pod _0.37.2_ setup 

Si necesita instalar una versión anterior (por ejemplo, 0.25):

 pod _0.25.0_ install 
 PROMPT> gem uninstall cocoapods Select gem to uninstall: 1. cocoapods-0.32.1 2. cocoapods-0.33.1 3. cocoapods-0.36.0.beta.2 4. cocoapods-0.38.2 5. cocoapods-0.39.0 6. cocoapods-1.0.0 7. All versions > 6 Successfully uninstalled cocoapods-1.0.0 PROMPT> gem install cocoapods -v 0.39.0 Successfully installed cocoapods-0.39.0 Parsing documentation for cocoapods-0.39.0 Done installing documentation for cocoapods after 1 seconds 1 gem installed PROMPT> pod --version 0.39.0 PROMPT> 

Tenga en cuenta que las especificaciones de su pod se mantendrán, y están ubicadas en ~ / .cocoapods /. Este directorio también puede necesitar ser eliminado si desea una instalación completamente nueva.

Se pueden eliminar utilizando la pod spec remove SPEC_NAME luego pod setup

Puede ser útil hacer las pod spec remove master luego pod setup