El complemento es demasiado antiguo, actualice a una versión más reciente o establezca la variable de entorno ANDROID_DAILY_OVERRIDE en

hoy acabo de importar una aplicación de muestra de Android SDK como módulo en mi proyecto (análisis) y de repente recibí este error de gradle cuando bash sincronizarlo: el Plugin is too old, please update to a more recent version, or set ANDROID_DAILY_OVERRIDE envrinment variable to...

Este es mi archivo gradle aplicación:

 apply plugin: 'com.android.application' android { compileSdkVersion 22 buildToolsVersion "22.0.0" defaultConfig { applicationId "xxx.xxxxxx.xxxxx" versionCode 1 versionName '1' minSdkVersion 9 targetSdkVersion 22 versionCode 1 versionName '1' } buildTypes { release { minifyEnabled false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro' } } dependencies { compile fileTree(dir: 'libs', include: ['*.jar']) compile 'com.android.support:appcompat-v7:22.0.0' compile 'com.google.android.gms:play-services:6.5.87' compile 'com.android.support:recyclerview-v7:21.0.0' compile 'com.android.support:cardview-v7:21.0.0' compile 'com.facebook.android:facebook-android-sdk:3.21.1' testCompile 'junit:junit:4.12' compile project(':volley') } 

¿Tiene alguna idea de cuál puede ser la causa (estoy usando el complemento versión 1.1.0-rc1 y gradle versión 2.2 y Android Studio versión 1.1.0)?

EDITAR:

Este es mi mejor build.gradle :

 buildscript { repositories { jcenter() } dependencies { classpath 'com.android.tools.build:gradle:1.1.0-rc1' // NOTE: Do not place your application dependencies here; they belong // in the individual module build.gradle files } } allprojects { repositories { jcenter() } } 

Tal como lo sugirió CommonsWare, asegúrese de tener Gradle 2.2.1+ (el último es 2.3).

Asegúrese de actualizar su Android Studio, pero aquí están los “complementos” que deben actualizarse:

Top build.gradle :

Cambio:

 classpath 'com.android.tools.build:gradle:1.1.0-rc1' 

A:

 classpath 'com.android.tools.build:gradle:1.1.3' // latest 1.5.0 

Aplicación build.gradle :

Cambio:

 compile 'com.android.support:recyclerview-v7:21.0.0' compile 'com.android.support:cardview-v7:21.0.0' 

A:

 compile 'com.android.support:recyclerview-v7:22.0.0' // latest 23.1.1 compile 'com.android.support:cardview-v7:22.0.0' // latest 23.1.1 

Gradle: https://gradle.org/downloads

Siempre consulte el Administrador de Android SDK para las últimas revisiones:

Complemento de herramientas de comstackción de Android: http://tools.android.com/tech-docs/new-build-system

Bibliotecas de soporte de Android: http://developer.android.com/tools/support-library/features.html

Para ver las últimas versiones de complementos, consulte la página de Bintray Jcenter directamente: https://bintray.com/android/android-tools/com.android.tools.build.gradle/view .

Solución (Actualizado: 24-mayo-2016): Cambiar build.gradle (proyecto)

 buildscript { repositories { jcenter() } dependencies { classpath 'com.android.tools.build:gradle:XXX-lastVersionGradle' classpath 'com.google.gms:google-services:XXX-lastVersionGServices' // If use google-services // NOTE: Do not place your application dependencies here; they belong // in the individual module build.gradle files } 

XXX-lastVersionGradle : por ejemplo: 2.1.0

XXX-lastVersionGServices : por ejemplo: 3.0.0 (compatible con Firebase Analytics)

Nota: si está utilizando el complemento google-services tiene que ser la misma versión (si existe)

¡¡Advertencia!! -> 2.2.0-alpha arroja la versión major.minor no compatible 52.0 si no utiliza Java JDK 8u91 y NetBeans 8.1

Como nota al margen, he estado obteniendo el mismo error en una situación completamente no relacionada, después de que se modificó la configuración del año del reloj del sistema (es decir, 2015 -> 2016); cambiando el reloj al correcto resolvió el problema.

Nota 1: Estoy publicando esto principalmente porque tuve exactamente el mismo mensaje de error, pero la solución de trabajo demostró ser diferente a la actualización de la versión del complemento (publicada por Jared Burrows ).

Nota 2: usando

 classpath 'com.android.tools.build:gradle:+' 

puede hacer que la versión del complemento sea la más nueva. Tenga en cuenta que su comstackción puede incumplir los cambios de la API (y, por esa misma razón, no está recomendada por los documentos de la API de Android), utilice esto bajo su propio riesgo solo si actualiza constantemente la versión de todos modos.

En caso de que alguien tenga problemas con esto, en mi caso estoy usando Gradle 1.4 beta 1 y NECESITO conservarlo. Entonces, para hacer que Android Studio funcione vaya a la terminal y ejecute esto:

launchctl setenv ANDROID_DAILY_OVERRIDE

Reinicie Android Studio y el proyecto se comstackrá de nuevo.

Felicitaciones a ACTUALIZAR 2 aquí: https://emmanuelbernard.com/blog/2012/05/09/setting-global-variables-intellij/

Siempre puede consultar la última versión del complemento gradle aquí: https://bintray.com/android/android-tools/com.android.tools.build.gradle

Por lo tanto, a partir de hoy deberías usar:

classpath 'com.android.tools.build:gradle:2.2.2'

en consecuencia.

Reemplaza tu camino de clase con algo ambiguo como este. Es una solución y funciona, pero puede no ser una buena solución.

classpath ‘com.android.tools.build:gradle:+’

La mejor forma es reemplazar el + con la última versión de gradle

Consulte la última versión de Gradle Plugin aquí:

Descargar

Debe cambiar esto en dependencias de la configuración de la aplicación

 buildscript { repositories { jcenter() } dependencies { classpath 'com.android.tools.build:gradle:[PLACE VERSION CODE HERE]' } 

}

Este problema ocurre debido a los cambios en la versión de Gradle, ya que su aplicación usa la versión anterior de Gradle, necesita actualizar a una nueva versión.

Este cambio debe hacerse en el archivo build.gradle; consulte este enlace http://www.feelzdroid.com/2015/11/android-plugin-too-old-update-recent-version.html . para saber cómo actualizar el gradle y se proporcionan los pasos detallados. ahí.

Thans

Estoy usando Android Data Binding y tengo el mismo problema hoy.

Para resolverlo, cambia:

 classpath "com.android.databinding:dataBinder:1.0-rc0" 

A:

 classpath "com.android.databinding:dataBinder:1.0-rc1" 

1.0-rc0 todavía se podía encontrar en jcenter ahora, no sé por qué no podría ser usado.

Obtuve un camino que finalmente resuelve esto 1. compruebe su calsspath en el build.gradle superior, por ejemplo, el mío es classpath ‘com.android.tools.build:gradle:2.1.0-alpha3’ y luego vaya a https: // jcenter. bintray.com/com/android/tools/build/gradle/ encuentra una versión más nueva que la tuya, aquí elijo 2.1.0-beta3 cambiar classpath por debajo, luego lanzar la comstackción. classpath ‘com.android.tools.build:gradle:2.1.0-beta3’

Si desea continuar utilizando las versiones de desarrollo más nuevas, este problema puede volver a ocurrir cada vez que su versión esté lo suficientemente desactualizada.

He estado manteniendo una lista actualizada de las versiones de desarrollo más recientes, así como la versión estable de mi respuesta a esta pregunta similar, para que pueda solucionarlo cada vez que reciba una nueva advertencia:

Android Studio 2.0: el complemento es demasiado antiguo, actualice a una versión más reciente o configure ANDROID_DAILY_OVERRIDE

establecer la variable de entorno ANDROID_DAILY_OVERRIDE en el mismo valor Ejemplo – b9471da4f76e0d1a88d41a072922b1e0c257745c

esto funciona para mi

La solución de eliminar la parte ‘-rcX’ funciona. Quería proporcionar más detalles sobre por qué está ocurriendo el error. El problema es con https://android.googlesource.com/platform/tools/base/+/master/build-system/gradle/src/main/groovy/com/android/build/gradle/BasePlugin.java#230

Hay una edad de jubilación predeterminada de 40 días para los complementos que no tienen una versión o que contienen ‘rc’, ‘alpha’ o ‘beta’.

En los últimos meses, utilicé una versión de “vista previa” de Android Studio. Traté de volver a las versiones “estables” para las actualizaciones de software pero no fue suficiente y recibí este famoso error del que hablas.

La desinstalación de mi Android Studio 2.2.preview e instalando la última versión estable de Android Studio (2.1) me lo arreglaron 🙂

Ir a la versión estable o gradle en el archivo gradle de la aplicación en mi caso fue
classpath ‘com.android.tools.build:gradle:2.2.0-alpha3’

Lo cambié con

classpath ‘com.android.tools.build:gradle:2.1.2’

la salida es de NonFinalPluginExpiry.java

ejemplo 2.4.0-alpha7

https://github.com/c3ph3us/android-gradle-plugin-source-codes/blob/master/gradle-2.4.0-alpha7-sources/com/android/build/gradle/internal/NonFinalPluginExpiry.java

si alguien quiere usar el plugin y no quiere hacer un google shi diario …

o bien necesita:

  1. recomstackr plugin
  2. reemplace “Versión de complemento” en manifiesto
  3. hacer una secuencia de comandos de automatización para generar env var y configurarlo a diario

      MessageDigest crypt = MessageDigest.getInstance("SHA-1"); crypt.reset(); crypt.update(String.format( "%1$s:%2$s:%3$s", now.getYear(), now.getMonthValue() -1, now.getDayOfMonth()) .getBytes("utf8")); String overrideValue = new BigInteger(1, crypt.digest()).toString(16); 

APLICACIÓN DE EJEMPLO EN JAVA (fonts + JAR):

  1. PARA GENERAR ADO – PARA TODOS LOS SOES CON JVM
  2. SET ENV para LINUX

https://github.com/c3ph3us/ado

https://github.com/c3ph3us/ado/releases

ejemplo de función bash para exportar env e iniciar idea / or studio:

 // eval export & start idea :) function sti() { export `java -jar AndroidDailyOverride.jar p` idea.sh } 

Esta es la forma de Android de decirle que actualice gradle a la versión más reciente. Puedes hacer dos cosas-

  1. Actualiza a la versión más nueva de gradle. Puede enfrentar nuevos errores después de la actualización (por ejemplo, si está actualizando a 4.1, tendrá que adaptarse a la nueva syntax – “comstackr” ya no es válido, use “implementación”).
  2. Actualice su variable ANDROID_DAILY_OVERRIDE al valor proporcionado. Vaya a Computadora -> Propiedades -> Configuración avanzada del sistema -> Variables de entorno, y cree una nueva variable o valor de actualización de ANDROID_DAILY_OVERRIDE existente. Como su nombre indica, este valor solo es válido por un día y al día siguiente tendrá que anular la variable nuevamente.

Debe actualizar la versión de gradle. por ejemplo: com.android.build.gradle 1.3.0

este problema ocurre cuando se cambia la versión del gradle.