Xcode beta 6 iOS 8: simulador no funciona

No puedo lanzar el simulador con éxito. He buscado mucho en este sitio, Google, YouTube, etc., pero ninguna de las soluciones proporcionadas funciona para mí :(. Una vez que ejecuto IOS Simulator, aparece el error “No se puede iniciar el simulador IOS”. Siguiendo el error del simulador IOS, luego aparece un error de la lectura xcode “No se puede ejecutar la aplicación en el simulador Se ha encontrado un error al ejecutar (Dominio = DTiPhoneSimulatorErrorDomain, Código = 2)”. Literalmente he intentado todas las soluciones que puedo encontrar y todavía no tengo suerte.

Captura de pantalla para el error ACTUALIZAR:

Esto puede sonar tonto, pero fui a Xcode / preference / Downloads con la intención de ver un IOS 8.0 Simulator pero no había ninguno. ¿Podría ser este el problema? ¿Tengo que tener un simulador IOS 8.0? Si es así, ¿alguien me puede decir cómo obtenerlo? Además, en la pestaña “Descargas” en la preferencia de Xcode, veo los simuladores IOS 7.0 y 7.1 y ambos funcionan bien con Xocde 5.

el truco es seleccionar las herramientas de línea de comando adecuadas. solo selecciónalo aqui enter image description here

reiniciar (!) y todo está bien de nuevo 🙂

Ok, es un problema conocido. ¿Ves lista de simuladores? Si no

Vaya al menú de Xcode -> Abrir herramienta de desarrollador -> Se abrirá un simulador en su Dock -> haga clic en el simulador y luego vaya al Menú del simulador: Hardware -> Dispositivo -> Administrar dispositivos. Agrega los simuladores necesarios. Siempre intente ejecutar su aplicación con diferentes simuladores. Alguien funcionará.

Reinicia tu Mac. Acabo de tener ese error exacto después de instalar Xcode 6 beta 7, literalmente, lo único que hice en respuesta fue reiniciar mi Mac y ahora el simulador de iOS 8 está funcionando.

Este error es común si actualiza Xcode sin reiniciar después.

En mi caso, reinicié la configuración del simulador ios arreglarlo.

Simulador iOS -> Restablecer contenido y configuración …

  1. Abre Xcode 6 beta
  2. Ir a la ventana> Dispositivos
  3. Haga clic en el pequeño signo + en la parte inferior
  4. Agregue (si falta) todos los dispositivos que desea, o elimine y vuelva a crear si no funciona.
  5. Si alguno de los simuladores no funciona, puede eliminarlo y volver a crearlo en este menú.

enter image description here

Vi el mismo problema cuando instalé Xcode 6 beta 6, y eliminé beta 4 y beta 5. Aparentemente, al eliminar las versiones anteriores también borré las versiones de iOS Simulator 8. Devolverlo de mi Papelera resolvió el problema.

Solución: ¡No elimine el viejo software beta!

Editar: la solución de @Flori funcionó. Pudo borrar el viejo software beta, y después de un reinicio completo del sistema, funcionó de nuevo.

  • Desde los menús desplegables de xCode 6, Xcode> Abrir herramienta de desarrollo> Simulador de iOS (si aparece un error emergente simplemente deséchelo)
  • Una vez en el simulador, vaya a Hardware> Dispositivo> Administrar dispositivos.
  • Eliminar todo lo que figura en el simulador.
  • Reinicia tu máquina.

Después de eso, vuelva a Administrar dispositivos en el simulador y haga clic en el signo más para volver a agregar sus simuladores. Entonces aparecerán los simuladores de iOS 8.

Simplemente desactivó la variable de entorno DYLD_INSERT_LIBRARIES en el archivo /etc/launchd.conf o ~ / .launchd.conf. Que puedes editar con el comando sudo vi /etc/launchd.conf. eliminar el indicador de arriba guardarlo por “ZZ” (captura Z) y reiniciar el sistema. Funciona a las mil maravillas.

Asegúrese de que la ruta en el menú XCode> Preferencia> Ubicaciones apunte a XCode 6.0 (reinicie Xcode después de cambiarlos). Luego vaya al menú Ventana> Dispositivos y agregue los dispositivos simuladores que quiera usar.

Editar: Resulta que estaba obteniendo mi versión del error porque tenía un archivo (el tipo “Archivo vacío”) llamado “Frameworks” en varios de mis proyectos, y esto estaba causando grandes problemas con los simuladores iOS 8. Renombrar el archivo para que sea cualquier otra cosa, y luego hacer una Carpeta de comstackción limpia, lo solucionó de inmediato.

—— Mensaje Original obsoleto a continuación ——–

En caso de que esto ayude a alguien, estaba teniendo un error similar en Xcode 6 GM, y probé todo lo mencionado en estas Respuestas, pero los simuladores iOS 8 nunca ejecutarían ninguna de mis aplicaciones (sin embargo, no hay problemas con iOS 7 corriendo desde Xcode 6) .

Lo que hizo el tipo de trabajo fue crear un nuevo proyecto (las nuevas aplicaciones de proyecto se ejecutarían en los simuladores de iOS 8, pero nunca tuvieron suerte con las aplicaciones existentes). Copiar archivos y configuraciones de proyectos no es divertido, pero al menos me permitió hacer pruebas y ver si mis aplicaciones necesitaban ser reparadas para la versión pública de iOS 8.

Descripción ampliada del problema en https://devforums.apple.com/thread/246751

Intenté todo lo mencionado anteriormente y nada funcionó.

Finalmente, la única forma de hacerlo funcionar fue desarmar DYLD_INSERT_LIBRARIES = / usr / lib / libimckit.dylib

Cómo hice esto:

  1. Abra la terminal y escriba “sudo vi /etc/launchd.conf”
  2. Cambiando

“setenv DYLD_INSERT_LIBRARIES /usr/lib/libimckit.dylib”

a

“unsetenv DYLD_INSERT_LIBRARIES /usr/lib/libimckit.dylib”

  1. Guardar cambios
  2. Reinicie su sistema

En esta publicación [1] explica qué DYLD_INSERT_LIBRARIES es para

[1] https://stackoverflow.com/a/26053165/2091181

Tengo este problema cuando paso de Beta 6 a Beta 7. Muy frustrante. Podría restablecer el contenido y la configuración en cualquiera de los simuladores iOS 8. Ninguno de mis simuladores iOS 8 funcionaba en absoluto, solo una pantalla negra. Reinicié mi máquina durante el proceso, pero no estoy seguro si hizo algo. Inicialmente solo tenía simuladores iOS 8. Tuve que eliminar y reinstalar Xcode6Beta7. No obtuve Install More Components la primera vez que lo instalé, no estoy seguro de si esa fue la parte que faltaba. Instalé los simuladores de iOS 7 en Configuración-> Descargas porque mis iOS8 no funcionaban. Después de haber reinstalado y relanzado el simulador, tuve una lista de simuladores iOS 6,7 y 8. Ninguno de los simuladores de iOS 8 funcionaba. Pude lanzar el simulador iOS7 y luego usar el menú del dispositivo cambiar a un simulador iOS 8. Algunos todavía no funcionaban, tuve que eliminarlos y volver a agregarlos en la pantalla de dispositivos.

  1. Retire XCode6Beta de Aplicaciones.
  2. Reiniciar la máquina (por si acaso, esto parece resolver el problema de algunas personas por completo)
  3. Instala XCode6Beta .
  4. Verifique que se hayan ejecutado los Componentes de instalación adicionales.
  5. Inicie Xcode6Beta.
  6. Preferencias-> General-> Cambiar las herramientas de línea de comandos a Xcode 6.0.
  7. Reinicie Xcode .
  8. Preferencias-> Descargas-> Descargar iOS 7 Simulator (si aún no se ha descargado).
  9. Ejecute la aplicación en el simulador de iOS 7 (o ejecute el simulador de iOS y cambie al dispositivo con iOS 7)
  10. Si el Simulador de iOS 7 está funcionando, Hardware-> Dispositivos-> Seleccione un simulador de iOS 8.
  11. Elimine y vuelva a crear cualquier simulador de iOS 8 que no funcione en Ventana-> Dispositivos de Xcode .

Luché con esto por un tiempo, con la aplicación del simulador informando que no podía encontrar el simulador iOS8, y sugiriendo la actualización en Prefs / Downloads, que no funcionó. Traté de reinstalar Beta 6 dos veces (sin eliminar todos los archivos de soporte, que habría sido el siguiente). La instalación inicial se describió a sí misma como comstackción 6A280c; una nueva descarga produjo la comstackción 6A280e. Sin suerte.

Eventualmente, abrí Window -> Devices, y usé el botón “+” en la parte inferior izquierda para agregar un nuevo simulador para iPhone 5s, iOS 8, llamándolo “Fresh 5s”. La ventana emergente Schemes ahora muestra tres opciones de iPhone 5S / iOS 8 (ninguna con el nombre que designé, pero diferenciado por UUID); al menos uno de ellos funcionó.

Supongo que esta característica (colecciones de instancias arbitrarias de simuladores) será muy útil cuando esté horneada. Mientras tanto, creo que tendré que administrar la lista de simuladores manualmente.

Hacer los siguientes pasos funcionó para mí:

 1. Launch the iOS Simulator and go to iOS Simulator --> Reset Content and Settings... 2. Close all the applications and restart your mac 3. Open Xcode6.0.1 or 6.0 and test the iOS Simulator 

Tuve el mismo problema después de pasar de Xcode 6 beta 5 a beta 6, pero también para el simulador iOS 7.1. Reiniciar mi máquina parecía hacer el trabajo. No necesité actualizar de Xcode 5.1.1 CLT a Xcode 6.0 CLT.

Intenté todas las soluciones anteriores y aún no pude ejecutar el simulador iOS8. Los simuladores de iOS7 se lanzaron bien.

Al mirar la consola, descubrí que el lanzamiento estaba fallando, y el registro de fallos se quejó de la biblioteca dinámica, libimckit.dylib. Puede leer sobre esto aquí: https://discussions.apple.com/thread/5781366?start=0&tstart=0

La solución rápida, elimine eso y su biblioteca asociada, reinicie y cargue.

¿Hay algo interesante en ~ / Library / Logs / CoreSimulator / CoreSimulator.log?

“No se puede iniciar el simulador de iOS”. el mensaje de error es casi siempre porque launchd_crashed porque DYLD_INSERT_LIBRARIES se configuró en algo no compatible con el tiempo de ejecución del simulador de iOS. ¿Tiene algún registro de locking (por ejemplo: launchd_sim lockings) en ~ / Library / Logs / DiagnosticReports? De ser así, compruebe si muestran DYLD_INSERT_LIBRARIES configurados. Si ese es el caso, sus opciones son actualizar a un host de OS X Yosemite (que se ocupará de este problema) o desarmar DYLD_INSERT_LIBRARIES (probablemente configurado en /etc/launchd.conf o ~ / .launchd.conf)

  1. Forzar salir de todas las aplicaciones incluyendo xcode y simulador
  2. Reiniciar MAC

Al marcar en la preferencia Xcode “Ubicaciones”, tenía dos elementos de la misma versión , uno ubicado en el área de translocación de la aplicación (/ var /…/ AppTranslocation / …). También anteriormente había hecho una instalación manual de herramientas de línea de comandos. Para resolver esto, al final tuve que eliminar /Applications/Xcode.app y eliminar la instalación manual de las herramientas de línea de comandos:

 sudo rm -rf /Library/Developer/CommandLineTools 

Luego instalé Xcode de nuevo y reinicié. ¡Auge! Simulador trabajando de nuevo