‘node’ no se reconoce como un comando interno o externo, progtwig operable o archivo por lotes mientras se usa phonegap / cordova

Estoy usando phonegap / cordova. Everthing está instalado propelry, es decir, cordova, phonegap, ant, sdk, jdk. Pero ahora dice “el nodo no se reconoce como un comando interno o externo” ¡Por favor, ayuda!

En Windows, debe establecer la ruta de la carpeta node.js en las variables del sistema o las variables de usuario.

1) abrir Panel de control -> Sistema y seguridad -> Sistema -> Configuración avanzada del sistema -> Variables de entorno

2) en “Variables de usuario” o “Variables del sistema” encuentre la ruta variable y agregue la ruta de la carpeta node.js como valor. Por lo general, es C:\Program Files\nodejs; . Si la variable no existe, créela.

3) Reinicia tu IDE o computadora.

Es útil agregar también rutas “npm” y “Git” como variable, separadas por punto y coma.

Excelentes respuestas, pero solo podría abrir el símbolo del sistema y escribir

  SET PATH=C:\Program Files\Nodejs;%PATH% 

Agregue una variable de sistema llamada “nodo”, con el valor de su ruta de nodo. Resuelve mi problema, espero que ayude.

Funcionó para mí ejecutando el símbolo del sistema como administrador

Si instala Node usando el instalador de Windows , no hay nada que tenga que hacer. Agrega ruta a nodo y npm.

También puede usar el comando setx de Windows para cambiar las variables de entorno del sistema. No se requiere reiniciar. Solo cierre sesión / inicie sesión. O simplemente abra una nueva ventana de cmd, si desea ver el cambio allí.

 setx PATH "%PATH%;C:\Program Files\nodejs" 

Como está utilizando Windows, la instalación debería editar automáticamente la variable% PATH%. Por lo tanto, sospecho que simplemente necesita reiniciar su sistema después de la instalación.

La instalación agrega automáticamente rutas a la variable del sistema. Reinicia tu sistema y vuelve a intentarlo

Si ya tiene el nodo instalado, su variable de ruta está configurada y de repente comienza a recibir este error; intenta actualizar a la última versión.

Esto funcionó para mí yendo de 6.9.2 a 6.10.