No se pudo ejecutar el emulador en Android Studio

Intenté iniciar la aplicación en el emulador en Android Studio en ubuntu 14.04 y muestra los siguientes errores.

  1. Se muestra un error cuando la comstackción de gradle está en proceso:

/ inicio / siguiente / NTE / MachineSetup / android-sdk-linux / tools / emulator -netdelay none -netspeed full -vd Nexus_5X_API_24 No se pudo iniciar ‘/ home / next / NTE / MachineSetup / android-sdk-linux / tools / qemu / linux-x86 / qemu-system-x86_64 ‘: Ningún archivo o directorio

  1. El error aparece después de completar la comstackción gradle:

12/02 16:47:57: Lanzamiento de la aplicación Error mientras se esperaba el dispositivo: el proceso del emulador para AVD Nexus_5X_API_24 se eliminó.

He adjuntado capturas de pantalla para su referencia.

El error aparece durante la construcción de gradle

Error que aparece después de la construcción finalizada

El motivo del primer error está a continuación:

Hay dos emuladores: uno en $SDK/tools , otro en $SDK/emulator .
El que está en $SDK/tools no puede comenzar.

Coloque $SDK/emulator antes de $SDK/tools en su variable $ PATH, debería solucionar el problema.

Estoy usando Android Studio 2.3: archivo de edición: .profile

 export ANDROID_HOME=${HOME}/Library/Android/sdk export PATH=${PATH}:${ANDROID_HOME}/emulator 

antes de

 export PATH=${PATH}:${ANDROID_HOME}/tools 

Me gusta: enter image description here

Así que miré a mi alrededor para encontrar algunas publicaciones similair que encontraron lo que usted hizo, para el primer error encontré esto que podría solucionar el problema:

qemu-sistema

para el segundo:

Vi a varias personas que tenían este problema (fuente no muy relevante). Algunos recomendaron actualizar su estudio Android o el SDK. Viendo que esto podría intervenir con el primer error, recomiendo solo hacer el primer paso y luego verificar nuevamente.

No estoy seguro si esto lo ayudará pero estaba viendo este error al intentar ejecutar el emulador en la consola. Cambio el ANDROID_SDK para apuntar a la carpeta bin en mi .bash_profile y eso corrigió el problema

 export ANDROID_HOME=~/Library/Android/sdk export ANDROID_SDK=$ANDROID_HOME/lib 

Además, esto me sucedió cuando instalé la imagen del sistema, pero no el emulador en sí.

1: agrega $SDK/emulator en tu $PATH variable
2: elimine $SDK/tools en su $PATH variable
3: adb kill-server
4: adb start-server
5: inicia el emulador desde la línea de comando

Ejemplo:
emulador @ Pixel_XL_API_23

Intente copiar la carpeta ‘lib’ desde su ubicación de SDK de Android / Android / Sdk / tools / lib64 / qt / lib a ../Android/Sdk/tools/lib/qt/lib