Cómo habilitar el soporte de jQuery en Aptana Studio 3

¿Cómo puedo habilitar jQuery en Aptana Studio 3 (beta)?
No vi ningún documento para esta versión.
¿Aptana Studio 3 (beta) es compatible con jQuery?

En Studio 3, gran parte de este tipo de funcionalidad sigue apareciendo, ya que Aptana va más allá de una ruta de paquetes de TextMate para una gran cantidad de sus funciones, lo que creo que es realmente genial.

Dicho eso, ya hay un paquete jQuery. El paquete jQuery, si aún no lo tiene instalado, se puede instalar desde Aptana a través del menú Comandos (Comandos-> Desarrollo de paquete-> Instalar paquete y luego seleccione jQuery de la lista) .

Esta discusión de soporte contiene algunos detalles sobre la asistencia del código jQuery en Aptana: https://aptanastudio.tenderapp.com/discussions/problems/2006-studio-3-jquery-support-is-lacking

En particular, menciona agregar un archivo jquery vs doc ( http://code.jquery.com/jquery-1.4.1-vsdoc.js ) a su proyecto. Esta parece ser la clave.

Si instala el paquete jQuery y agrega el archivo JS antes mencionado, puede obtener sugerencias de código jQuery en su (s) editor (es) de Aptana. Acabo de revisar esto en uno de mis proyectos de Rails y funciona (estoy en la última versión beta de Studio 3 para Mac).

Esto es incorrecto. Si bien esto le dará fragmentos de jQuery y algunos comandos, para agregar JQuery Content Assist, todo lo que tiene que agregar es un único archivo. Por favor, siga las instrucciones aquí en su lugar:

http://wiki.appcelerator.org/display/tis/Using+JavaScript+Libraries

para tener código de asistencia con aptana 3, siga estas instrucciones https://wiki.appcelerator.org/display/tis/JavaScript+Library+Support (es decir, Commands-> Bundle dev-> Install-> select jquery) y ponga su jquery.js biblioteca en su proyecto como siempre (colóquelo en una carpeta de su elección)

Acabo de pasar la última hora tratando de hacer que esto funcione.

El soporte de Eclipse para javascript es terrible. He probado VJET y aptana. No se mostrará un código simple completo que incluya string.replace ().

Para cualquiera que golpee esta página, diría esto: ni siquiera te molestes. Eclipse simplemente no es un IDE de JavaScript.

    Intereting Posts