Antigüedad de Kotlin Runtime Warning en Android Studio

Después de descargar e instalar el último complemento de Kotlin, advertí que la advertencia de Kotlin Runtime obsoleta de Android Studio me decía:

Su versión del tiempo de ejecución de Kotlin en la biblioteca ‘kotlin-stdlib-1.1.2′ es 1.1.2, mientras que la versión del complemento es 1.1.2-release-Studio2.3-3. La biblioteca de tiempo de ejecución debe actualizarse para evitar problemas de compatibilidad.

Traté de hacer clic en el botón Actualizar tiempo de ejecución pero recibir otro mensaje:

La actualización automática de la versión de la biblioteca para proyectos de Gradle no está soportada actualmente. Actualice su build.gradle manualmente.

¿Cómo resolver este problema?

Puede actualizar su versión de Kotlin en su archivo build.gradle nivel de proyecto. Si lo tiene configurado de la manera habitual, debe tener la siguiente línea en la parte superior:

 ext.kotlin_version = '1.1.2' 

Para actualizar a la versión que coincida con su complemento, simplemente cambie esta línea a:

 ext.kotlin_version = '1.1.2-3' 

Editar (para responder a una pregunta a continuación):

El error le dice que necesita actualizar su versión, la pregunta es dónde descubrir que debe poner en 1.1.2-3 en lugar de decir, por ejemplo, 1.1.2-release-Studio2.3-3 .

Lo mejor que se puede hacer si el número de versión no es trivial como este es verificar los repositorys donde se alojan las versiones. En el caso de Android, probablemente lo obtendrá de jcenter, para lo cual puede encontrar la página del repository , que tiene todas las versiones disponibles enumeradas.

También puede navegar por el repository de maven sin formato de jcenter, donde los archivos se alojan realmente yendo aquí , o buscar Kotlin en mvnrepository o en mavencentral (versión cruda de este último aquí ).

En su archivo (Project: [projectName]) build.gradle , busque esto: ext.kotlin_version = 'xxx' y reemplace xxx con la versión actual de su plugin de Kotlin. enter image description here

Para verificar cuál es la versión actual de su complemento de Kotlin:

  1. Vaya a: Herramientas -> Kotlin -> Actualizaciones de Confugure Kotlin Plugin

  2. Haga clic en “Buscar actualizaciones ahora”. Después de un segundo, verá la versión de su complemento de Kotlin. (Si no está actualizado, su complemento de Kotlin se actualizará). enter image description here enter image description here

NB: también verifique su archivo (Module: app) build.gradle y build.gradle no utilizar:

 compile "org.jetbrains.kotlin:kotlin-stdlib-jre7:1.2.21" 

pero

 compile 'org.jetbrains.kotlin:kotlin-stdlib-jdk7:1.2.40' 

Tenga en cuenta la diferencia “… jre7 …” -> “… jdk7 …”. También reemplace “1.2.40” con su versión actual del complemento de Kotlin.

se quejó (en Android Studio 3.0.1) … muy probablemente debido a las dependencias de las bibliotecas a las que se hace referencia:

Su versión del tiempo de ejecución de Kotlin en la biblioteca ‘org.jetbrains.kotlin: kotlin-stdlib: 1.1.3@jar’ es 1.1.3, mientras que la versión del complemento es 1.1.51-release-Studio3.0-1.

luego hice cumplir la construcción contra la versión que exigía, en el nivel de módulo build.gradle :

 configurations.all() { resolutionStrategy.force 'org.jetbrains.kotlin:kotlin-stdlib:1.1.51' } 

y el resultado es:

 ./gradlew app:dependencies | grep kotlin Download https://jcenter.bintray.com/org/jetbrains/kotlin/kotlin-stdlib/1.1.51/kotlin-stdlib-1.1.51.pom | | +--- org.jetbrains.kotlin:kotlin-stdlib:1.1.3 -> 1.1.51 ... 

cambiar tu ext.kotlin_version de ‘1.1.2-4’to ext.kotlin_version =’ 1.1.2-5 ‘me solucionó el problema

Este problema surge cuando actualiza la versión del complemento de Kotlin que apareció en el estudio de Android, pero el problema es que la versión actual de Android Studio no puede cambiar dinámicamente el complemento kotlin gradle que se encuentra en el archivo Build.gradle de su nivel de proyecto .

 dependencies { classpath "org.jetbrains.kotlin:kotlin-gradle-plugin:1.2.10" } 

¿Cómo resolver este problema?

Entonces, necesita cambiar manualmente esta versión, puede encontrar eso aquí

la última versión de kotlin es 1.2.41 usa esto y sincroniza tu proyecto.

 buildscript { ext.kotlin_version = '1.2.41' repositories { google() jcenter() } dependencies { classpath 'com.android.tools.build:gradle:3.1.2' classpath "org.jetbrains.kotlin:kotlin-gradle-plugin:$kotlin_version" // NOTE: Do not place your application dependencies here; they belong // in the individual module build.gradle files } } 
 buildscript { ext.kotlin_version = '1.2.50' repositories { google() jcenter() } dependencies { classpath 'com.android.tools.build:gradle:3.1.2' classpath "org.jetbrains.kotlin:kotlin-gradle-plugin:$kotlin_version" // NOTE: Do not place your application dependencies here; they belong // in the individual module build.gradle files } } 

Hay dos piezas que quizás desee actualizar:

  1. kotlin runtime para el proyecto
  2. plugin kotlin

La respuesta de Ivo Stoyanov muestra cómo hacerlo utilizando los menús de estudio de Android. Cuando recibí el mensaje de error y lo intenté (actualizando el complemento de Kotlin) solo, todavía se quejaba del tiempo de ejecución de kotlin. Puede actualizarlo proyecto por proyecto, agregando la línea en ext.kotlin_version al proyecto build gradle, como lo indican algunas de las otras respuestas. Pero necesitarás saber la versión de tiempo de ejecución de kotlin para eso. Alternativamente, también puede hacerlo a través de los menús, como muestro aquí a continuación, con la ventaja de que el estudio de Android le muestra las versiones disponibles, y puede elegir la más reciente.

paso 1

paso 2

paso 3

etapa 4

Y luego, el estudio de Android agregará la línea adecuada en su comstackción de proyecto.

Me he encontrado con este problema varias veces en Android Studio e IDEA, encontré que si ingresas en el archivo Gradle de tu proyecto y en tus dependencias si configuras la versión de kotlin-gradle-plugin en $kotlin_version , $kotlin_version el mensaje de advertencia. le dirá a qué versión necesita establecer ext.kotlin_version .

 buildscript { ext.kotlin_version = '1.2.40' repositories { google() jcenter() } dependencies { classpath 'com.android.tools.build:gradle:3.1.2' classpath "org.jetbrains.kotlin:kotlin-gradle-plugin:$kotlin_version" // NOTE: Do not place your application dependencies here; they belong // in the individual module build.gradle files } } 

enter image description here

La última versión de Kotlin:

 buildscript { ext.kotlin_version = '1.2.41' repositories { google() jcenter() } dependencies { classpath 'com.android.tools.build:gradle:3.0.1' classpath "org.jetbrains.kotlin:kotlin-gradle-plugin:$kotlin_version" classpath 'com.github.dcendents:android-maven-gradle-plugin:1.5' classpath 'com.google.gms:google-services:1.5.0-beta2' // NOTE: Do not place your application dependencies here; they belong // in the individual module build.gradle files } } 

Un poco molesto, pero el estudio lo hace algunas veces. Los siguientes pasos pueden solucionar el problema.

Ir

Configuraciones -> Construir, Ejecución, Desarrollo -> Gradle -> Usar envoltorio de gradle predeterminado (recomendado)

cambie esto a Usar local y vuelva a Usar predeterminado. Studio preguntará sobre la actualización de Gradle luego de cerrar las ventanas de configuración.

Me enfrenté a este problema en el último Android Studio del canal Canary. Es posible que desee considerar la degradación de Android Studio a la versión estable también.

Me pasó en Android Studio 3.0 RC1.