Eclipse Kepler Java 8

Quiero comenzar a usar Java 8 con Eclipse, pero no sé cómo instalarlo. No puedo encontrar ningún tutorial sobre él. Estoy usando Eclipse Kepler y he agregado un JRE para JDK 8 al IDE, pero no me permitirá seguir creando el proyecto debido a un problema de cumplimiento con las versiones de JRE. ¿Cómo puedo usar Java 8 con Eclipse Kepler IDE?

Eche un vistazo a este informe de errores de vez en cuando para ver el progreso en Java 8 en el JDT de Eclipse.

EDITAR: para Kepler necesita SR2 (4.3.2) y el parche de características de Java 8. Comenzando con I20140318-0830 todas las versiones de Luna (4.4) contienen soporte para Java 8 “out-of-the-box”. La versión final de Eclipse Luna (4.4) se lanzará a fines de junio de 2014.

Ahora, después de lanzar Java 8, hay un parche de características, pero solo para Kepler SR2 (4.3.2) . Instalación a través de

Ayuda> Instalar nuevo software …> ‘Trabajar con’: http://download.eclipse.org/eclipse/updates/4.3-P-builds/

ver Tutorial Instalación de Java 8 en Eclipse Kepler

Las versiones de acceso temprano de Eclipse con soporte de Java 8 están disponibles. La instrucción de instalación se puede encontrar aquí .

Wayne Beaton (Director de proyectos de código abierto en la Fundación Eclipse ) acaba de publicar (febrero de 2014) un artículo sobre ” Crear y ejecutar el soporte de Java 8 ” (con Eclipse Luna 4.4Mx).

Incluye:

  • Obtener las fonts de JDK8
  • Descargar el último hito del Eclipse SDK (4.4Mx)
  • Configurando la opción ” vm ” en el archivo eclipse.ini para usar el JRE Java 8 incluido con el JDK descargado.
  • Añadiendo Egit
  • Clone la twig BETA_JAVA8 de los repositorys JDT Core , JDT UI y JDT Debug de Git BETA_JAVA8 .
  • Usando la práctica función “Importar todos los proyectos” para extraer automáticamente todo el código en mi espacio de trabajo.
  • Configurando varios JRE 1.4 , 5 y 6 .
  • Poniendo el mapeo correcto para esos JRE en el entorno de ejecución .

Para Eclipse Kepler 4.3+, Leeor menciona en los comentarios :

A partir del 21 de febrero, puede instalar el beta 8 JDT a través de ” install new software... ” en Eclipse (uso Kepler) aquí: Soporte JDT / Eclipse Java 8 (BETA)

 http://build.eclipse.org/eclipse/builds/4P/siteDir/updates/4.3-P-builds 

URL: http://download.eclipse.org/eclipse/updates/4.3-P-builds/

Agrégalo como la captura de pantalla enter image description here

Supongo que ha instalado Java 8, JRE 8 y los ha configurado (estableciendo rutas de clases, etc.). Sigue los pasos. Vaya a Ayuda-> Eclipse Market Place En el cuadro de búsqueda escriba “java 8 kepler”. El primer enlace que aparece es el soporte de Java 8 para Kepler SR2, selecciónelo e instálelo. Ésto tomará unos minutos. Es posible que deba reiniciar Eclipse después de la finalización.

El problema es que la versión de Kepler que usaste podría no tener soporte para Java8. Puede instalar el parche Java8 desde el mercado si usa la versión SR2

o

Puede descargar directamente Eclipse Kepler SR2 desde aquí , que viene con soporte predeterminado para Java8