Cómo instalar simuladores iOS anteriores en XCode 4.2.1 (SDK5.0)

Acabo de comprar un nuevo iMac. Luego descargué el último SDK 5.0 e instalé XCode 4.2.1. Todo está funcionando bien. Aunque me di cuenta de que solo hay iPhone y iPad Simuladores 5.0 disponibles para la depuración. Así que seguí haciendo clic en Más simuladores … Hice clic en Instalar para todos los elementos y pasé un tiempo, y cuando volví, indicó como “Instalado”. Pero cuando vuelvo a mi XCode, todavía hay simuladores 5.0 en la lista.

Entonces, ¿cómo hago para instalar los simuladores más antiguos en XCode 4.2.1? ¿Me perdí algún paso? ¿O necesito instalar SDK anteriores? Por favor ayuda. Gracias.

X-Code 4.2 solo tendrá el simulador y la biblioteca iOS 5. Si desea una versión más baja del simulador y la biblioteca con X-Code, simplemente vaya a X-Code-> Prefrences-> Download Tab. En la pestaña de descargas, tendrá dos tabs:

1) Componentes – Aquí tendrá la opción de descargar iOS 4.3 simulador (~ 600 Mb), iOS 4.0-4.1 (~ 670 MB) Soporte de depuración de dispositivos, iOS 3.0-3.2.2 (686.3 MB) Soporte de depuración de dispositivos.

2) Documentación : Yoy tendrá la opción de descargar iOS 5.0, XCode 4.2 Developer libaray, Mac OSX 10.7 Core Library.

enter image description here

Instale los componentes que necesite y vaya allí … ¿Ha instalado componentes de esta manera?

Si Xcode no muestra los simuladores deseados, podrá descargar códigos x anteriores desde aquí: https://developer.apple.com/downloads/index.action?name=Xcode

Por ejemplo:

  • Simulador iOS 5 -> Xcode 4.3
  • Simulador iOS 5.1 -> Xcode 4.3.3
  • Simulador iOS 6 -> Xcode 4.6
  • Simulador iOS 6.1 -> Xcode 4.6.3
  • Simulador iOS 7 -> Xcode 5
  • Simulador iOS 7.1 -> Xcode 5.1

Puede encontrar la aplicación Xcode dentro del .dmg descargado

  1. Abra este DMG
  2. Haga clic derecho en la aplicación Xcode y haga clic en ‘Mostrar contenido del paquete’
  3. Navegue a: Contenidos / Desarrolladores / Plataformas / iPhoneSimulator.platform / Desarrollador
  4. Copie la carpeta del simulador encontrado (por ejemplo, la carpeta iPhoneSimulator7.1.sdk)
  5. Repita los pasos 2 y 3 para su aplicación Xcode actual
  6. Pegar la carpeta del simulador

Reiniciar Xcode le mostrará los nuevos simuladores agregados

¡Feliz construcción y prueba!

Actualizar:
Probado en xCode 6, trabajando allí también