Agregar Play JSON Library a sbt

¿Cómo puedo agregar la biblioteca Play JSON ( play.api.libs.json ) a mi proyecto sbt?

Cuando agregué lo siguiente a mi archivo plugins.sbt :

 addSbtPlugin("play" % "sbt-plugin" % "2.1.0") 

Me enfrenté a este error:

 [warn] :::::::::::::::::::::::::::::::::::::::::::::: [warn] :: UNRESOLVED DEPENDENCIES :: [warn] :::::::::::::::::::::::::::::::::::::::::::::: [warn] :: play#sbt-plugin;2.1.0: not found [warn] :::::::::::::::::::::::::::::::::::::::::::::: 

No encontré un resolver para esta biblioteca, de lo contrario lo habría agregado y sbt update . Tenga en cuenta que mis resolvers incluyen http://repo.typesafe.com/typesafe/releases/ .

Juega 2.3 JSON con SBT> = 0.13.5

poner en build.sbt:

 libraryDependencies += "com.typesafe.play" %% "play-json" % "2.3.4" 

Jugar 2.1

build.sbt:

 resolvers += "Typesafe Repo" at "http://repo.typesafe.com/typesafe/releases/" scalaVersion := "2.10.2" libraryDependencies += "play" % "play_2.10" % "2.1.0" 

Play JSON está en Play 2.1, no es un artefacto independiente.

Play 2.2 está disponible y puede agregarse por separado del rest de Play Framework. en build.sbt:

 resolvers += "Typesafe Repo" at "http://repo.typesafe.com/typesafe/releases/" libraryDependencies += "com.typesafe.play" %% "play-json" % "2.2.1" 

Esto funcionó para mí (scala 2.11)

resolvers += "Typesafe Repo" at "http://repo.typesafe.com/typesafe/releases/"

libraryDependencies += "com.typesafe.play" %% "play-json" % "2.3.0"

Puede usar lo siguiente para obtener la biblioteca Play JSON:

addSbtPlugin("play" % "play-json" % "2.2-SNAPSHOT")

También puede tener que incluir la siguiente resolución:

"Mandubian repository snapshots" at "https://github.com/mandubian/mandubian-mvn/raw/master/snapshots/"

Aquí es donde originalmente obtuve la información: http://mandubian.com/2013/02/21/play-json-stand-alone/

Se puede consultar la sección Introducción del repository de GitHub y agregar lo siguiente al archivo build.sbt :

 libraryDependencies += "com.typesafe.play" %% "play-json" % "2.6.0-M1"