Error al resolver: com.google.firebase: firebase-core: 11.2.0

Obtuve varios problemas de “No se resolvió” al sincronizar mi proyecto. Todos están relacionados con Firebase y Play Services. Me aseguré de que todos sean iguales (11.2.0). También he verificado y la última versión para ambos es 11.2.0. Además, todas las demás respuestas a preguntas similares implican la actualización de los servicios y el repository de Google Play en SDK Manager, pero el mío ya está actualizado.

enter image description here

enter image description here

¿Alguna idea de por qué no puedo sincronizar mi proyecto?

EDITAR – Solución de trabajo actual

// Top-level build file where you can add configuration options common to all sub-projects/modules. buildscript { repositories { jcenter() } dependencies { classpath 'com.android.tools.build:gradle:2.3.3' classpath 'com.google.gms:google-services:3.0.0' classpath 'com.google.firebase:firebase-plugins:1.0.4' // NOTE: Do not place your application dependencies here; they belong // in the individual module build.gradle files } } allprojects { repositories { jcenter() maven { url "https://maven.google.com" } } } task clean(type: Delete) { delete rootProject.buildDir } 

Agregue maven { url "https://maven.google.com" } a su archivo build.gradle nivel raíz

 allprojects { repositories { jcenter() maven { url "https://maven.google.com" } } } 

Los servicios de juego y las dependencias de Firebase ahora están disponibles a través de maven.google.com con el lanzamiento de la versión 11.2.0 de los servicios de Google Play y Firebase.

Puede encontrar el documento oficial de Servicios de Google Play aquí y el documento de Firebase aquí. .

 allprojects { repositories { jcenter() maven { url 'https://maven.google.com' } } } 

Si está utilizando el complemento Android gradle 3.x, también puede usar:

 allprojects { repositories { jcenter() google() } } 

El mejor método para solucionar este problema es no utilizar el método manual de vincular Firebase a su aplicación.

He intentado agregar el último repository de firebase al referirme a este enlace .

Mostró el error “no se pudo resolver la dependencia firebase 11.2.0”

FireBase recomienda agregar Firebase a su aplicación con la ayuda de FireBase Assistant para Android Studio versión 2.2 y superior. Al agregar manualmente la última biblioteca a build-gradle (módulo) se produce un error como el anterior.

El asistente de Firebase agregó las versiones inferiores 10.0.1 automáticamente a las dependencias en el módulo gradle-build que es compatible y podría resolverse.

Usar el asistente de Firebase es muy fácil y el proceso es de 2 pasos. Como referencia, puede usar la sección “Usar el Asistente de Firebase” en el mismo enlace mencionado anteriormente.

Realmente funcionó con mi Android Studio 2.3.3. Y también asegúrese de que su repository de Google esté actualizado

Acabo de arreglar el mismo error agregando la dependencia de firebase-core .

 implementation 'com.google.firebase:firebase-core:16.0.1' 

Con la versión 16.0.0 de firebase tuve que

  • configuro la mayoría de mis bibliotecas de servicios de google play en 15.0.0 analytics y TagManager necesitaba ser 16.0.0
  • establecer mis versiones de la biblioteca de soporte a 27.1.1
  • firebase-core a 16.0.0

Construido contra sdk 27

Cambios adicionales:

También tuve que actualizar mis análisis a 16.0.0

  • implementación “com.google.android.gms: play-services-analytics: 16.0.0”

Parte de las versiones independientes que hizo Android recientemente, estoy adivinando. Puede ser necesario intentar subir o bajar una versión en los servicios de google play y las bibliotecas de Firebase