Error al instalar el paquete rgl

He visto esta pregunta aquí: Error al cargar el paquete rgl con Mac OS X pero no se menciona el error de instalación, que es mi caso. No puedo instalar el paquete rgl , usando este comando en R :

 source("http://bioconductor.org/biocLite.R") biocLite("rgl") 

Se muestra el siguiente error:

 configure: error: X11 not found but required, configure aborted. ERROR: configuration failed for package 'rgl' * removing '/Library/Frameworks/R.framework/Versions/3.2/Resources/library/rgl' 

rgl esta dirección /Library/Frameworks/R.framework/Versions/3.2/Resources/library y no hay ninguna carpeta rgl , por lo que no puedo eliminar aglrgl.so (o rgl.so ), que es la respuesta a lo mencionado anteriormente pregunta. ¿Puedes ayudarme con este problema de instalación? Gracias.

En Ubuntu, lo que funcionó para mí fue instalar el paquete directamente desde la línea de comandos:

sudo apt-get install r-cran-rgl

(Tenemos una configuración extraña aquí, entonces YMMV)

En una instalación limpia de Ubuntu 16.04, puede obtener este problema cuando intente instalar rgl desde CRAN:

 checking for X... no configure: error: X11 not found but required, configure aborted. ERROR: configuration failed for package 'rgl' 

El crédito se debe a este blog que resolvió mis problemas al instalar rgl rápidamente:

 http://solaimurugan.blogspot.ca/2015/09/3d-data-visualization-using-r-configure.html 

En caso de que desaparezca el enlace de arriba, la solución, tal como se describe en el blog es:

 sudo apt-get install xorg sudo apt-get install libx11-dev 

También puede ser necesario

 sudo apt-get install libglu1-mesa-dev 

Luego, instalar rgl desde CRAN debería funcionar.

Todas las respuestas mencionadas son correctas; sin embargo, ninguno es para Mac.

En mi caso (soy usuario de Mac), resolví el problema instalando XQuartz y reiniciando R.

En CentOS, lo que finalmente hizo el truco fue instalar libpng-dev:

 sudo yum install libpng-devel.x86_64 

Antes de esto, instalé xorg, libx11, la biblioteca mesa GLL y freeglut.

 sudo yum install xorg-x11-server-Xvfb.x86_64 xorg-x11-server-devel.x86_64 sudo yum install libX11.x86_64 libX11-devel.x86_64 sudo yum install mesa-libGL mesa-libGL-devel mesa-libGLU mesa-libGLU-devel sudo yum install freeglut.x86_64 freeglut-devel.x86_64 

La forma en que finalmente me di cuenta de lo que faltaba era intentar comstackr desde el origen (descargar el tar.gz en cran ) y examinar el config.log después de que el archivo ./configure fallara.

No estoy seguro del caso de Mac, pero en Windows tuve problemas para descargar el mismo paquete rgl. La instalación de RGL requiere el paquete devtools

 install.packages("devtools") library(devtools) install.packages("rgl") library(rgl) 

En OpenSuse

 sudo zypper install xorg-x11-devel sudo zypper install glu-devel