¿El instalador de .Net Framework 4.0 incluye .Net Framework 3.5?

¿Los componentes .Net comstackdos contra .Net Framework 3.5 se ejecutan en un sistema que solo tiene instalado .Net Framework 4.0?

O, en otras palabras, ¿el instalador de .Net Framework 4.0 incluye .Net Framework 3.5?

El instalador .NET 4.0 no incluye .NET framework 3.5. Hay información sobre este tema en MSDN:

.NET Framework 4 es altamente compatible con las aplicaciones desarrolladas con versiones anteriores de .NET Framework, excepto por algunos cambios que se realizaron para mejorar la seguridad, el cumplimiento de estándares, la corrección, la confiabilidad y el rendimiento.

.NET Framework 4 no utiliza automáticamente su versión del tiempo de ejecución de lenguaje común para ejecutar aplicaciones comstackdas con versiones anteriores de .NET Framework. Para ejecutar aplicaciones anteriores con .NET Framework 4, debe comstackr su aplicación con la versión de .NET Framework especificada en las propiedades para su proyecto en Visual Studio, o puede especificar el tiempo de ejecución soportado con el elemento en una configuración de aplicación archivo.

Puede instalar .NET 3.5 y .NET 4.0 uno al lado del otro. Visual Studio 2010 también incluye soporte de orientación mejorada para .NET 3.5. El blog de ScottGu habla de esto con más detalle.

Claro, esto es muy viejo y tarde. Sin embargo, a veces las imágenes son mejores que las palabras (siempre que los enlaces funcionen).

Para obtener más información, consulte la página oficial de Microsoft, Versiones de NET Framework y dependencias .

Diagrama de dependencias del .Net Framework

En XP SP2 con FW 4 instalado, la aplicación FW3.5 ejecuta un mensaje:

Unable to find a version of the runtime to run this application.

Por tanto, la respuesta es no.

Ver: Versiones y dependencias de .NET Framework

Esto da una imagen clara de lo que se incluye en cada versión de .Net. También,

No tiene que instalar versiones anteriores de .NET Framework o CLR antes de instalar la última versión; cada versión proporciona los componentes necesarios.