¿SimpleCursorAdapter desaprobado en API versión 15?

SimpleCursorAdapter desaprueba uno de sus constructores con el siguiente comentario:

Obsoleto. Se desaconseja esta opción, ya que da como resultado que las consultas del cursor se realicen en la secuencia de la interfaz de usuario de la aplicación y, por lo tanto, puede causar una respuesta deficiente o incluso errores de la aplicación no responde. Como alternativa, use android.app.LoaderManager con un android.content.CursorLoader.

¿Esto hace que toda la clase se desaproveche? El otro constructor (estándar) no está en desuso.

Solo el constructor está en desuso, no toda la clase.

SimpleCursorAdapter (Context context, int layout, Cursor c, String[] from, int[] to) llamadas SimpleCursorAdapter (Context context, int layout, Cursor c, String[] from, int[] to, int flags) con flags establecidos en FLAG_AUTO_REQUERY .

Pero FLAG_AUTO_REQUERY está en desuso porque

[…] da como resultado que las consultas del cursor se realicen en el hilo de interfaz de usuario de la aplicación […]

también el constructor está en desuso.

El constructor estándar no está en desuso, pero, obviamente, no tiene que llamarlo con flags = FLAG_AUTO_REQUERY !

Finalmente, si está utilizando SimpleCursorAdapter con un CursorLoader , como lo sugiere la documentación, este indicador no es necesario y puede pasar 0 .