npm WARN notsup SALTAR DEPENDENCIA OPCIONAL: plataforma no admitida para fsevents@1.0.14

Estoy tratando de ejecutar este proyecto https://github.com/Soundnode/soundnode-app después de actualizar mi versión minimatch a 3.10.9, obtengo este error

npm WARN opcional SALTAR DEPENDENCIA OPCIONAL: fsevents@^1.0.0 (node_modules \ webpack \ node_modules \ watchpack \ node_modules \ chokidar \ node_modules \ fsevents): npm WARN notsup SALTAR DEPENDENCIA OPCIONAL: Plataforma no compatible para fsevents@1.0.14: wanted {” os “:” darwin “,” arch “:” any “} (actual: {” os “:” win32 “,” arch “:” ia32 “})

mi configuración es Node v – 4.4.2 npm v- 3.10.9 estoy trabajando en Windows OS de 32 bits

Es una advertencia, no un error. Ocurre porque fsevents es una dependencia opcional, utilizada solo cuando el proyecto se ejecuta en un entorno macOS (el paquete proporciona ‘Acceso nativo a Mac OS-X FSEvents’).

Y como está ejecutando su proyecto en Windows, fsevents se omite como irrelevante.

Esto todavía parece ser un problema, provocando que se cancelen las instalaciones de paquetes con advertencias sobre paquetes opcionales que no se instalan debido a la “Plataforma no admitida”.

El problema se relaciona con el “shrinkwrap” o package-lock.json que se conserva después de cada ejecución del administrador de paquetes. Los bashs subsiguientes siguen fallando ya que se hace referencia a este archivo en lugar de a package.json .

Agregar estas opciones al comando npm install debería volver a establecer las cosas.

  --no-optional argument will prevent optional dependencies from being installed. --no-shrinkwrap argument, which will ignore an available package lock or shrinkwrap file and use the package.json instead. --no-package-lock argument will prevent npm from creating a package-lock.json file. 

El comando completo se ve así:

  npm install --no-optional --no-shrinkwrap --no-package-lock 

Esto se ha registrado como un problema de NPM: https://github.com/npm/npm/issues/14042