cambiando el comstackdor de java de eclipse a jdk7

Estoy intentando actualizar de jre6 y jdk6 a jre7 y jdk7. Progtwigndo usando eclipse, descargué e instalé el jre7 y jdk7 en: C: \ archivos de progtwig \ java \ ahora cuando entro eclipse quiero cambiar el comstackdor usado así que voy a: ventana> preferencias> comstackdor java> pero aparece solo 1.3.1.4,1.5 y 1.6 También he ingresado: ventana> preferencias> java> JRE instalados y agregué la versión jre7. Pero el comstackdor no puedo cambiar. ¿Cómo cambio mi comstackdor de eclipse?

Necesita actualizar al menos a Eclipse Indigo SR1 , que ha estado fuera por más de un mes. Ver también Eclipse anuncia compatibilidad completa con Java 7 .

Como evidencia, aquí hay una pantalla de mis preferencias de Indigo SR1:

enter image description here

Y aquí hay un ejemplo de fragmento de código executabele usando el operador de diamante y ARM:

enter image description here

Necesitas una versión más nueva de Eclipse. Por lo menos 3.7SR1.

3.6 La versión de Eclipse es suficiente. Estoy usando lo mismo con JDK1.7

Vaya a Window > Preferences >Java > Installed JREs .

A continuación, haga clic en Add... y seleccione Standard VM .

Necesita especificar el directorio de su JRE y darle un nombre.

Cuando haya terminado, simplemente marque el JRE correcto en la misma ventana.

Por defecto, el JRE marcado se agrega a la ruta de comstackción de los proyectos Java recién creados.

(mi versión Eclipse SDK es 3.7.0)