Las imágenes no aparecen cuando la architecture está configurada en 64 bits

Para hacer la transición de mi aplicación a 64 bits, cambié la configuración de construcción de Architectures a:

ARCHS = “$ (ARCHS_STANDARD_INCLUDING_64_BIT)”;

La aplicación está funcionando bien, excepto que algunas de las imágenes no se muestran (en blanco). ¿Por qué sucedería? ¿alguna pista?

La respuesta está aquí:

https://devforums.apple.com/message/922989#922989

Encontré la razón. En un viewController, que aún no estaba asignado, pero que se incluía en la aplicación, se implementaron los siguientes (en el archivo .m arriba de la implementación viewController):

@implementation UIImageView (UIScrollView) - (void)setAlpha:(float)alpha { ..........(no difference if here is some code or not) ............... [super setAlpha:alpha]; } @end 

Poner arriba en el comentario resolvió el problema, aunque el botón que no mostraba la imagen no estaba en una vista de desplazamiento.

Actualice la estructura de datos utilizada en el código de acuerdo con 64 bits, por ejemplo, reemplace Float con CGFloat (si no funciona, también cambie el tipo int con NSInteger )
mira aquí para más información
En mi caso, reemplace Float con CGFloat y resuelva mi problema (la forma más sencilla de reemplazar float a CGFloat )

 #define float CGFloat 

Escriba en el archivo .pch y verifique si funciona o no.
Gracias

Solucionó mi problema para cambiar

 - (void)setAlpha:(float)alpha { 

a:

 - (void) setAlpha:(CGFloat)alpha {