Error al resolver: com.android.support:cardview-v7:26.0.0 android

Intento agregar recyclerview a mi proyecto y aparece este error y lo agregué de las dependencias de estudio de Android esto es un error aparece cuando intentas agregar recyclerview en android studio

esta es la versión compilada ...

A partir de la versión 26 de las bibliotecas de soporte, asegúrese de que la sección de repositories incluya una sección maven con el punto final ” https://maven.google.com “.

Algo como;

 allprojects { repositories { jcenter() maven { url "https://maven.google.com" } } } 

Así es como lo tengo funcionando.

  1. Agrega maven { url "https://maven.google.com" } como @Gabriele_Mariotti sugiere más arriba.

     allprojects { repositories { jcenter() maven { url "https://maven.google.com" } } } 
  2. Luego, en el archivo build.gradle dentro de la carpeta de la aplicación, agregue

     compileSdkVersion 26 buildToolsVersion "25.0.3" defaultConfig { applicationId "com.xxx.yyy" minSdkVersion 16 targetSdkVersion 26 } 
  3. Luego, en el uso de las dependencias

     dependencies { compile 'com.android.support:appcompat-v7:26.0.1' compile 'com.android.support:design:26.0.1' compile 'com.google.android.gms:play-services-maps:11.0.4' compile 'com.google.android.gms:play-services-location:11.0.4' compile 'com.mcxiaoke.volley:library-aar:1.0.0' compile 'com.android.support:cardview-v7:26.0.1' } 

Simplemente agregue esto a su archivo build.gradle principal a nivel de proyecto en todos los proyectos ()

  maven { url "https://maven.google.com" } 

Enfrentaré el mismo problema mientras actualizo mi SDK y la versión de estudio de Android (3.0 beta). He resuelto este problema al seguir este tutorial. En esto nos dijeron que actualizaramos el archivo de configuración de comstackción como

 android { compileSdkVersion 26 buildToolsVersion '26.0.0' defaultConfig { targetSdkVersion 26 } ... } dependencies { compile 'com.android.support:appcompat-v7:26.0.0' } // REQUIRED: Google's new Maven repo is required for the latest // support library that is compatible with Android 8.0 repositories { maven { url 'https://maven.google.com' // Alternative URL is 'https://dl.google.com/dl/android/maven2/' } } 

Espero que te ayude.

Si está utilizando Android Studio 3.0 o superior, asegúrese de que su proyecto build.gradle debe tener un contenido similar a-

 buildscript { repositories { google() // add google() before jcenter() jcenter() } dependencies { classpath 'com.android.tools.build:gradle:3.0.1' } } allprojects { repositories { google() // add google() before jcenter() jcenter() } } 

Y para debajo de Android Studio 3.0 y comenzando desde las bibliotecas de soporte 26. + su proyecto build.gradle debe verse así:

 allprojects { repositories { jcenter() maven { url "https://maven.google.com" } } } 

Nota: la posición realmente importa agrega google () antes de jcenter ()

verifique estos enlaces a continuación para más detalles-

1- Creación de aplicaciones de Android

2- Agregar dependencias de comstackción

3- Configura tu construcción

en el caso de que haya encontrado que OneSignal cambió sus dependencias

así que lo cambié de

compile 'com.onesignal:OneSignal:[3.5.8, 3.99.99]'

a

compile 'com.onesignal:OneSignal:[3.5.8, 3.5.8]'

entonces funciona, verifique cualquier dependencia inespecífica.

Agregue esto al archivo build.gradle del nivel de proyecto y debería funcionar bien.

 allprojects { repositories { google() // this is to be added if there's something already. jcenter() } } 

Se requiere el nuevo repository Maven de Google para la última biblioteca de soporte que es compatible con Android 8.0. Simplemente actualice su repository Maven de Google como se muestra a continuación:

Para agregarlos a su comstackción, agregue maven.google.com a los repositorys de Maven en su archivo build.gradle nivel de build.gradle :

 repositories { maven { url 'https://maven.google.com' // Alternative URL is 'https://dl.google.com/dl/android/maven2/' } } 

Alternativa puedes actualizar el archivo build.gradle esta manera:

  repositories { jcenter() google() } 

A continuación, agregue la biblioteca deseada a su bloque de dependencias. Por ejemplo, la biblioteca de cardview se ve así:

 dependencies { compile 'com.android.support:cardview-v7:26.1.0' } 

Actualice su repository de soporte de Android desde el administrador de SDK.

Hay otra forma de agregar el repository de google

  1. Agregue gradle-4.1-rc-1-all en gradle-wrapper.properties.

     distributionUrl=https\://services.gradle.org/distributions/gradle-4.1-rc-1-all.zip 
  2. A continuación, agregue google() en el build.gradle de nivel superior

     allprojects { repositories { google() jcenter() } } 

intenta comstackr

  compile 'com.android.support:cardview-v7:25.3.1' 

Limpia tu gradle de la terminal

 ./gradlew clean 

luego usa este código en tu sección build.gradle

 allprojects { repositories { jcenter() maven { url "https://maven.google.com" } } } 

Asegúrese de que la versión de su biblioteca incluida esté disponible. Para su verificación, puede usar este enlace

Simplemente cambie la versión de comstackción de compile ‘com.android.support:appcompat-v7:26.0.0’

a

comstackr ‘com.android.support:appcompat-v7:26.0.0-alpha1’

Esto resolverá su problema.

Si las otras soluciones aquí no funcionan, asegúrese de que no está en el modo ‘fuera de línea’ . Si está habilitado, Android no descargará los archivos necesarios y obtendrá este error.

enter image description here

Use compile 'com.android.support:cardview-v7:25.4.0'
Si quieres la versión 26, deberías usar compile 'com.android.support:cardview-v7:26.0.0-beta2' , porque es beta por ahora

 android { compileSdkVersion 26 buildToolsVersion '26.0.2' useLibrary 'org.apache.http.legacy' defaultConfig { applicationId "com.test" minSdkVersion 15 targetSdkVersion 26 versionCode 1 versionName "1.0" testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner" multiDexEnabled true } 

Esto es trabajo para mí

 compile 'com.android.support:cardview-v7:+' 

Esto debería extraer la versión más reciente y permitir que se compile.

prueba esto,

Vaya a Android-> SDK y asegúrese de tener todas las dependencias necesarias. si no, descárguelos. luego goto Archivo -> Settigs -> Construir, Ejecución, Depoyment -> Gradle

elija usar el wapper de gradle predeterminado (recomendado)

y desmarcar el trabajo sin conexión

gradle build termina con éxito por una vez que puede cambiar la configuración

Puede ser que este problema se deba a la biblioteca de Facebook. Reemplazar

 compile 'com.facebook.android:facebook-android-sdk:[4,5)' 

por

 compile 'com.facebook.android:facebook-android-sdk:4.26.0' 

@Aryan tiene razón al no poder resolver: com.android.support:appcompat-v7:27.+ (Dependency Error)

Una imagen vale más que mil palabras

enter image description here

Para mí solo tuve que limpiar mi proyecto.

Build -> Clean Project