Articles of adt

No se encontró ningún repository error en la instalación de ADT en Eclipse Indigo

Este error aparece cuando bash instalar ADT: An error occurred while collecting items to be installed session context was:(profile=epp.package.jee, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=). No repository found containing: osgi.bundle,com.android.ide.eclipse.adt,16.0.1.v201112150204-238534 No repository found containing: org.eclipse.update.feature,com.android.ide.eclipse.adt,16.0.1.v201112150204-238534 No repository found containing: osgi.bundle,com.android.ide.eclipse.ddms,16.0.1.v201112150204-238534 No repository found containing: org.eclipse.update.feature,com.android.ide.eclipse.ddms,16.0.1.v201112150204-238534 No repository found containing: osgi.bundle,com.android.ide.eclipse.hierarchyviewer,16.0.1.v201112150204-238534 No repository found containing: org.eclipse.update.feature,com.android.ide.eclipse.hierarchyviewer,16.0.1.v201112150204-238534 No repository found […]

Eclipse: no me deja usar Android SDK, afirma erróneamente que mi ADT está desactualizado

Estoy desarrollando para Android con Eclipse, y todo estaba funcionando bien hasta ayer. Usé Ninite para actualizar todas mis cosas, incluidos los JRE y todo (pro tip: no lo hago), y reinició mi computadora sin preguntar en medio de la edición de mi espacio de trabajo. Esto causó todo tipo de problemas sucios, pero ahora […]

¿Cuándo establece ADT BuildConfig.DEBUG en falso?

En la versión más reciente de ADT (r17) se agregó una constante generada BuildConfig.DEBUG que se establece de acuerdo con el tipo de comstackción. El problema que tengo es que nunca se establece como falso, esperaba que cambiara al hacer “Herramientas de Android -> Exportar paquete de aplicaciones firmado”, pero no lo hizo para mí. […]

Error: este SDK de Android requiere Android Developer Toolkit versión 22.6.1 o superior

He instalado la versión 22.6.1 de adt hace 2 días. Funcionaba bien De repente, cuando abro eclipse hoy, me sigue apareciendo el siguiente error: Este Android SDK requiere Android Developer Toolkit versión 22.6.1 o superior. La versión actual es 22.2.1.v201309180102-833290. Actualice ADT a la última versión. Aquí está la captura de pantalla del Administrador de […]

Cómo obtener el nombre de Android AVD del nombre del dispositivo adb

Usando el SDK de Android desde la línea de comandos, puedo obtener una lista de los dispositivos en ejecución disponibles usando: ./adb device Esto me da el número de serie de los dispositivos disponibles. ¿Cómo puedo obtener el nombre AVD del dispositivo emulador de ese número de serie (como lo hace el complemento Eclipse ADT)?

Theme.AppCompat.Light.DarkActionBar – No se encontraron recursos

Cómo utilizar correctamente la Biblioteca de soporte de Android porque tengo este error en mi archivo de manifiesto: android:theme=”@style/Theme.AppCompat.Light.DarkActionBar” error: Error: No resource found that matches the given name (at ‘theme’ with value ‘@style/Theme.AppCompat.Light.DarkActionBar’). AndroidManifest.xml /ttab line 39 Android AAPT Problem Mi amigo hizo esto implementando para mí previamente en otra computadora, ahora tengo que […]

Usar la nueva propiedad “manifestmerger” en Android

En la versión más reciente de ADT (vista previa de la versión 20 3), dicen que es posible hacer que el archivo de manifiesto de las bibliotecas se combine con los proyectos que los usan: Combinación automática de archivos de manifiesto del proyecto de la biblioteca en el manifiesto incluido del proyecto. Habilítelo con la […]

Cómo crear un GIF animado a partir de archivos JPEG en Android (desarrollo)

Estoy buscando una manera simple de crear un GIF animado en una aplicación nativa de Android. Los archivos de origen deben ser JPEG (desde la cámara o lo que sea) y la salida debe guardarse como GIF en el dispositivo. No quiero saber cómo reproducir animaciones o archivos GIF animados. Para ser claro: quiero saber […]

BufferOverflowException al crear aplicaciones

Cada vez que quiero ejecutar mi aplicación Android recibo un error: [2013-11-02 13:05:36 – Dex Loader] Unable to execute dex: java.nio.BufferOverflowException. Check the Eclipse log for stack trace. [2013-11-02 13:05:36 – **********] Conversion to Dalvik format failed: Unable to execute dex: java.nio.BufferOverflowException. Check the Eclipse log for stack trace. Lo busqué en google, pero no […]

Eclipse Indigo: no se puede instalar el complemento Android ADT

Cuando bash instalar Android Developer Tool, aparece el siguiente error. Software que se está instalando: Herramientas de desarrollo de Android 11.0.0.v201105251008-128486 (com.android.ide.eclipse.adt.feature.group 11.0.0.v201105251008-128486) Requisito faltante: Herramientas de desarrollo de Android 11.0.0.v201105251008-128486 ( com.android.ide.eclipse.adt.feature.group 11.0.0.v201105251008-128486) requiere ‘org.eclipse.wst.sse.core 0.0.0’ pero no se pudo encontrar También encontré que agregar el paquete WST no ayuda. Obtengo lo siguiente, No […]