Articles of android sdk tools

¿Cómo realizar la minimización y la ofuscación con el comstackdor JACK?

Google lanzó una versión de prueba de su nuevo comstackdor JACK para desarrolladores de Android con Android Studio 2.1. Mi pregunta es, ¿cómo habilitamos la ofuscación para el APK con JACK? El artículo siguiente dice que JACK realiza ofuscación de forma nativa y elimina la necesidad de Proguard: Comstackndo con Jack Mientras que el siguiente […]

Error de Travis CI porque no puede aceptar la licencia Restringir diseño

Antes de escribir esta pregunta, ya busqué la misma pregunta sobre esto, exportaron licencia porque todavía usan la versión alfa del diseño de restricción. Pero ahora Android ya lanzó una versión estable del diseño de restricciones. Intenté una gran cantidad de configuración, pero aún así fallé. mi último .travis.yml language: android jdk: oraclejdk8 android: components: […]

libz.so.1: no se puede abrir el archivo de objeto compartido

Estoy enfrentando un problema en ubuntu 12.04 como: /usr/lib/ndk/android-ndk-r8c/toolchains/arm-linux-androidabi-4.6/prebuilt/linux-x86/bin/../lib/gcc/arm-linux-androidabi/4.6/../. ./../../arm-linux-androidabi/bin/as: error al cargar las bibliotecas compartidas: libz.so.1: no se puede abrir el archivo de objeto compartido: No existe ningún archivo o directorio Lo intenté sudo apt-get install lib32z1 Pero dice Leyendo listas de paquetes … Hecho Construyendo árbol de dependencias Leyendo información de estado … […]

Android comando desconocido ‘crunch’

Acabo de instalar Eclipse y Android SDK en Mac OS X. Importé el proyecto a Eclipse y recibí el error “Crunch” del comando Desconocido mientras ejecutaba el proyecto. ¿Cómo debería resolver este problema? por favor, ayúdame

incapaz de ejecutar adb en Ubuntu. El archivo descargado está destinado a x86-64 mientras tengo i686

Intento usar AndroidStudio, pero cuando presiono el botón Ejecutar, recibo un mensaje de error que dice que no puede obtener un puente de depuración. Comprobé el archivo adb en plataformas-herramientas usando el comando de file y encontré que está destinado a x86-64, mientras estoy ejecutando i686. ¿Sabes dónde puedo obtener el archivo adb destinado a […]

Iniciando el emulador de Android en las herramientas de SDK, revisión 12

Actualicé las herramientas de Android SDK de la revisión 11 a la revisión 12, y ahora el emulador no se puede iniciar. Cuando bash ejecutar emulator.exe, obtengo: Parámetro de línea de comandos no válido: Archivos \ Android \ android-sdk \ tools / emulator-arm.exe. Sugerencia: use ‘@foo’ para iniciar un dispositivo virtual llamado ‘foo’. por favor […]

No ha aceptado los acuerdos de licencia de los siguientes componentes de SDK

Descargué las últimas herramientas de Android SDK versión 24.4.1. Usé la línea de comando para instalar SDK. Escribí y cuando me preguntaron ¿Acepta la licencia ‘android-sdk-license-c81a61d9′ [y / n]: y después de que la instalación se haya realizado correctamente? Pero al usar Gradle 3.1 para comstackr, aparece lo siguiente No ha aceptado los acuerdos de […]

Aceptar automáticamente todas las licencias de SDK

Desde los plugins Android 2.2 de Gradle : Gradle intentará descargar los paquetes faltantes de SDK de los que depende un proyecto Lo cual es increíblemente genial y se sabía que era un proyecto de JakeWharton . Pero, para descargar la biblioteca de SDK, debe: aceptar los acuerdos de licencia o gradle le dice: No […]

No se puede ejecutar dex: Múltiples archivos dex definen Lcom / myapp / R $ array;

Desde que actualicé a ADT 14 ya no puedo construir mi proyecto. Estaba construyendo bien antes de la actualización. El error: [2011-10-23 16:23:29 – Dex Loader] Unable to execute dex: Multiple dex files define Lcom/myapp/R$array; [2011-10-23 16:23:29 – myProj] Conversion to Dalvik format failed: Unable to execute dex: Multiple dex files define Lcom/myapp/R$array; Se informaron […]