Articles of build.gradle

Estructura de Gradle y Multi-Proyecto

Estoy tratando de entender cómo debería abordar la siguiente configuración del proyecto: ┌Top Android Project │ ├── Project 1 – (Pure Java Modules) │ │ │ ├── Module A1 │ ├── Module B1 │ : │ └── Module Z1 │ ├── Project 2 – (Android Libraries Modules) │ │ │ ├── Module A2 │ ├── […]

Error: ejecución fallida para la tarea ‘: app: packageRelease’. > No se puede calcular el hash de /../AndroidStudioProjects/../classes.jar

Estoy intentando hacer una comstackción de ‘lanzamiento’ en una aplicación de Android y sigo recibiendo este error de: No se puede calcular el hash de /../AndroidStudioProjects/../classes.jar Y cuando miro en ese directorio para ‘classes.jar’, el archivo no está allí. ¿Tengo que crear este archivo yo mismo con una tarea gradle? Está sucediendo algo con Proguard […]

Conflicto con la dependencia ‘com.android.support:support-annotations’. Las versiones resueltas para la aplicación (23.1.0) y la aplicación de prueba (23.0.1) difieren

Al construir me sale el siguiente error: Conflict with dependency ‘com.android.support:support-annotations’. Resolved versions for app (23.1.0) and test app (23.0.1) differ. Estas son mis dependencias gradle dependencies { compile fileTree(include: [‘*.jar’], dir: ‘libs’) compile ‘com.android.support:support-v4:23.1.0’ compile ‘com.android.support:appcompat-v7:23.1.0’ compile ‘com.android.support:design:23.1.0’ compile ‘com.android.support:cardview-v7:23.1.0’ compile ‘com.android.support:recyclerview-v7:23.1.0’ compile ‘com.squareup.retrofit:retrofit:1.9.0’ compile ‘com.squareup.okhttp:okhttp:2.4.0’ compile ‘com.squareup.picasso:picasso:2.5.2’ compile ‘com.jakewharton:butterknife:7.0.1’ compile ‘com.squareup:otto:1.3.8’ compile ‘com.snappydb:snappydb-lib:0.5.2’ […]

Android Studio: no se encuentra el complemento con id ‘android-library’

He estado intentando que ActionBarSherlock funcione y tenga algún problema. Un problema con el que me he encontrado es el siguiente mensaje al intentar comstackrlo: Plugin with id ‘android-library’ not found Específicamente: D:\Projects\Android\actionbarsherlock>D:\Projects\Android\gradlew –info build Starting Build Settings evaluated using empty settings script. Projects loaded. Root project using build file ‘D:\Projects\Android\actionbarsherlock\build.gradle’. Included projects: [root project […]

No se pudo encontrar el método android () para argumentos

He estado tratando de importar un proyecto a Android Studio y aquí es donde estoy atascado, hay una pregunta similar sobre Stack Overflow pero no proporcionó una solución a mi error en particular. Este es mi registro de error: C:\\build.gradle Error:(24, 1) A problem occurred evaluating root project ”. > Could not find method android() […]

Actualización de Android Studio Gradle a la versión 0.5.0 – Gradle Migrating de 0.8 a 0.9 – También Android Studio mejora a 0.8.1

Después de los estados de mensaje de actualización: Failed to refresh Gradle project ‘XXX’ The project is using an unsupported version of the Android Gradle plug-in (0.8.3). Version 0.9.0 introduced incompatible changes in the build language. Please read the migration guide to learn how to update your project. Mismo tipo de problema después de la […]

Error: ejecución fallida para la tarea ‘: app: transformResourcesWithMergeJavaResForDebug’

Por lo tanto, recibo continuamente un error de comstackción de gradle al intentar ejecutar mi proyecto. He buscado otras soluciones y algunos dicen que agregar: packagingOptions { exclude ‘META-INF/NOTICE’ } para mi gradle.build de mi aplicación solucionaría el problema, sin embargo, no es así. Así es como se ve actualmente mi aplicación gradle.build. apply plugin: […]

Error de Dex en Android Studio 3.0 Beta4

Error:java.lang.RuntimeException: java.lang.RuntimeException: com.android.builder.dexing.DexArchiveMergerException: Unable to merge dex Error:java.lang.RuntimeException: com.android.builder.dexing.DexArchiveMergerException: Unable to merge dex Error:com.android.builder.dexing.DexArchiveMergerException: Unable to merge dex Error:com.android.dex.DexException: Multiple dex files define Lcom/google/zxing/integration/android/IntentResult;

Error: corrija el conflicto de versión actualizando la versión del complemento google-services

Tengo un problema con el complemento de Google Services. Actualicé los servicios de google a la última versión. Obtuve una dependencia de este sitio: https://bintray.com/android/android-tools/com.google.gms.google-services/ Error:Execution failed for task ‘:app:processDebugGoogleServices’. > Please fix the version conflict either by updating the version of the google-services plugin (information about the latest version is available at https://bintray.com/android/android-tools/com.google.gms.google-services/) or […]

Error: Conflicto con la dependencia ‘com.google.code.findbugs: jsr305’

Creé un nuevo proyecto en Android Studio 2.2 Preview 1 con la aplicación Android y el módulo Backend con Google Messaging. Este es el archivo de la aplicación: apply plugin: ‘com.android.application’ android { compileSdkVersion 23 buildToolsVersion “23.0.3” defaultConfig { applicationId “com.xxx.xxx” minSdkVersion 15 targetSdkVersion 23 versionCode 1 versionName “1.0” testInstrumentationRunner “android.support.test.runner.AndroidJUnitRunner” } buildTypes { release […]