Articles of compatibilidad

Correo máximo efectivo: longitudes del cuerpo

Hay una longitud máxima para el texto en la sección & body de un mailto: enlace. Según uno de mis compañeros de trabajo, el W3C publica el límite como 256 (aunque no tengo un enlace para respaldar esto). Estamos incorporando mailto: enlaces tanto en un correo electrónico como en una página web y hemos utilizado […]

Creación de biblioteca con ABI compatible con versiones anteriores que usa Boost

Estoy trabajando en una cierta biblioteca C ++ (o más framework). Quiero que sea compatible con versiones anteriores conservando no solo la compatibilidad API sino también ABI (como el gran trabajo que hace Qt). Utilizo muchas funcionalidades de Boost y me parece que esto hace que la compatibilidad con versiones anteriores sea simplemente imposible, a […]

Android: Tinte con DrawableCompat

Intento teñir una imagen antes del nivel 21 de la API de Android. He teñido correctamente elementos usando: Sin embargo, parece que no puedo entender cómo hacerlo a través del código en un ImageView: Drawable iconDrawable = this.mContext.getResources().getDrawable(R.drawable.somedrawable); DrawableCompat.setTint(iconDrawable, this.mContext.getResources().getColor(R.color.red)); imageView.setImageDrawable(iconDrawable); Intenté configurar el TintMode, pero parece que no es diferente. ¿Estoy utilizando la clase […]

Integridad del marco de registro

Estoy construyendo una pequeña aplicación Java y espero usar logback para iniciar sesión. Mi aplicación tiene una dependencia en un proyecto anterior que hace su registro a través de org.apache.commons | com.springsource.org.apache.commons.logging | 1.1.1 … entonces mi plan era usar org.slf4j | jcl-over-slf4j | 1.5.6 … para redirigir el registro de JCL a org.slf4j | […]

¿Dónde puedo encontrar una matriz de compatibilidad de Selenium WebDriver con Firefox definitiva?

He trabajado en varios proyectos usando Selenium Java y Firefox Web Driver, en una variedad de plataformas. Una y otra vez, me encuentro con incompatibilidades entre la versión de Selenium WebDriver que utilizamos y la versión de Firefox instalada. La primera línea de defensa es, por supuesto, asegurarnos de que usamos la última versión de […]

Cómo lidiar con las clases en desuso en Android para mantener la compatibilidad

Estoy volviendo a trabajar en una aplicación en la que trabajé hace un tiempo, cuando todo estaba basado en Android 2.2 Froyo. He actualizado mi SDK para las API más recientes y noté que las funciones de ClipboardManager que estaba usando están en desuso. Actualicé el código para usar el nuevo modelo ClipData y lo […]

Constante no inicializada ActiveSupport :: Dependencies :: Mutex (NameError)

Cuando quiero crear un proyecto Ruby on Rails, obtengo el mensaje a continuación. /usr/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:55: uninitialized constant ActiveSupport::Dependencies::Mutex (NameError) from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:36:in `gem_original_require’ from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:36:in `require’ from /usr/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support.rb:57 from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:36:in `gem_original_require’ from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:36:in `require’ from /usr/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/rails_generator.rb:31 from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:36:in `gem_original_require’ from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:36:in `require’ from /usr/lib/ruby/gems/1.8/gems/rails-2.3.8/bin/rails:15 from /usr/bin/rails:19:in `load’ from /usr/bin/rails:19 ¿Qué ha ido mal? ¿Cómo puedo arreglarlo?

¿Cómo hacer que Internet Explorer 8 sea compatible con el elemento nth child () CSS?

Quiero dar un efecto de franja de cebra a mis filas de la mesa. En todos los otros navegadores se puede hacer usando CSS nth elemento hijo. Pero quiero hacerlo IE 8 también. Entonces, ¿cómo puedo hacerlo?

IE11 El modo de documento está predeterminado en IE7. ¿Cómo reiniciar?

Mi Internet Explorer 11 en mi tableta con Windows 8.1 Surface está predeterminado en el modo de documento 7, lo que hace que muchos sitios web se procesen incorrectamente. Cuando abro las herramientas de desarrollo, declara que está predeterminado en el modo de documento 7 debido a la configuración de compatibilidad de intranet. Sin embargo, […]

¿Por qué IE9 cambia al modo de compatibilidad en mi sitio web?

Acabo de instalar IE9 beta y en un sitio específico que he creado (HTML5) IE9 salta al modo de compatibilidad a menos que le indique manualmente que no lo haga. He intentado eliminar varias partes del sitio web pero no hay cambios. Incluye eliminar todos los CSS. En otro sitio web mío, todo va bien. […]