Articles of eclipse

No se puede crear el Proyecto Maven en eclipse

Tengo Eclipse Luna y Maven 3.2.3 instalados en una máquina con Windows 7 detrás de un firewall corporativo. Intentar crear un proyecto a partir de un arquetipo da como resultado el siguiente error: No se pudo resolver archetype org.apache.maven.archetypes: maven-archetype-quickstart: RELEASE desde cualquiera de los repositorys configurados. No se pudo resolver el artefacto org.apache.maven.archetypes: maven-archetype-quickstart: […]

importar desde otro proyecto de Java en eclipse

Estoy trabajando en dos proyectos en eclipse y me gustaría importar algunas clases del proyecto a al proyecto b. ¿Que debería hacer? ¿Hay alguna manera de hacerlo sin agregar el proyecto a la ruta de comstackción?

Combinaciones de teclas de Visual Studio para Eclipse

¿Alguien tiene un esquema de enlace similar a VS 2005 disponible para Eclipse? Cómo importarlo en las preferencias de Eclipse (solo veo el botón de exportación).

No se encontró ningún repository error en la instalación de ADT en Eclipse Indigo

Este error aparece cuando bash instalar ADT: An error occurred while collecting items to be installed session context was:(profile=epp.package.jee, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=). No repository found containing: osgi.bundle,com.android.ide.eclipse.adt,16.0.1.v201112150204-238534 No repository found containing: org.eclipse.update.feature,com.android.ide.eclipse.adt,16.0.1.v201112150204-238534 No repository found containing: osgi.bundle,com.android.ide.eclipse.ddms,16.0.1.v201112150204-238534 No repository found containing: org.eclipse.update.feature,com.android.ide.eclipse.ddms,16.0.1.v201112150204-238534 No repository found containing: osgi.bundle,com.android.ide.eclipse.hierarchyviewer,16.0.1.v201112150204-238534 No repository found containing: org.eclipse.update.feature,com.android.ide.eclipse.hierarchyviewer,16.0.1.v201112150204-238534 No repository found […]

¿Cómo establecer un punto de interrupción en Eclipse en una biblioteca de terceros?

Obtengo una NullPointerException en una clase de una biblioteca de terceros. Ahora me gustaría depurar todo y necesitaría saber de qué objeto se sostiene la clase. Pero me parece que no puedo establecer un punto de inflexión en una clase de un tercero. ¿Alguien sabe una manera de salir de mi problema? Por supuesto que […]

Agregar jar a un Eclipse PlugIn

Intento crear un plugin de Eclipse que tenga que usar un flask escrito por mí mismo que dependa de otros flasks, pero no entiendo por dónde empezar manipulando flasks como plugins separados. En cualquier lugar tengo que usar solo los archivos .jar o ¿estoy equivocado?

¿Alguna forma de generar el archivo ant build.xml automáticamente desde Eclipse?

Desde Eclipse, descubrí que puedo exportar fácilmente un archivo de comstackción Ant para mi proyecto . Proporciona referencias a bibliotecas de terceros y algunos objectives básicos. Lo estoy usando desde mi archivo de comstackción global. Lo único que me molesta de esto, es que si algo se modifica en la estructura del proyecto (como agregar […]

Error “inclusión no resuelta” con Eclipse CDT para cabeceras de biblioteca estándar C

Configuré CDT para eclipse y escribí un sencillo progtwig hello world C: #include int main(void){ puts(“Hello, world.”); return 0; } El progtwig crea y ejecuta correctamente, pero eclipse sigue mostrando este signo de interrogación amarillo junto a la statement de inclusión que dice “Unresolved inclusion: ” cuando pongo el mouse sobre ella. No afecta la […]

diagtwig de secuencia UML gratuito plugin de eclipse de ingeniería inversa que funciona de la caja: ¿existe tal cosa?

Probé (aunque no muy exhaustivamente) numerosas soluciones, incluyendo ModelGoon (solo diagtwigs de clases e interacciones disponibles), ObjectAid (solo diagtwig de clases), eUML free edition (se cierra con un siniestro error de “licencia no encontrada” en el primer uso), MoDisco (con la única opción en el menú es “explorar el elemento del modelo correspondiente”). Y también […]

Eclipse: no me deja usar Android SDK, afirma erróneamente que mi ADT está desactualizado

Estoy desarrollando para Android con Eclipse, y todo estaba funcionando bien hasta ayer. Usé Ninite para actualizar todas mis cosas, incluidos los JRE y todo (pro tip: no lo hago), y reinició mi computadora sin preguntar en medio de la edición de mi espacio de trabajo. Esto causó todo tipo de problemas sucios, pero ahora […]