Articles of homebrew

Obteniendo un error de “intérprete erróneo” cuando usa brew

Me aparece este error cuando bash ejecutar cualquier comando de preparación. Holger-Sindbaeks-MacBook-Air:~ holgersindbaek$ brew help -bash: /usr/local/bin/brew: /usr/bin/ruby: bad interpreter: No such file or directory No tengo absolutamente ninguna idea sobre cómo solucionar esto y he estado buscando durante mucho tiempo sin respuesta.

Error PID en mysql.server start?

Acabo de intentar instalar MySQL usando homebrew (en Mac OS X 10.6), pero me encontré con un problema en el primer obstáculo. Al intentar iniciar el servidor manualmente (inicio mysql.server), aparece el siguiente error: . ERROR! Manager of pid-file quit without updating file. Lamentablemente, no estoy seguro de qué registro de errores o archivos de […]

OSX – reemplace gcc versión 4.2.1 con 4.9 instalado a través de Homebrew

Esto me ha estado atormentando por un tiempo ahora. Estoy intentando comstackr un enorme archivo C ++ (sé que funciona, ya que funciona bien en mi computadora Arch Linux en el trabajo). Cuando revisé mi versión de GCC en mi mac, devuelve lo siguiente Configured with: –prefix=/Applications/Xcode.app/Contents/Developer/usr –with-gxx-include-dir=/usr/include/c++/4.2.1 Apple LLVM version 6.0 (clang-600.0.57) (based on […]

¿Cómo hacer que Ruby / Homebrew / RVM trabaje en Yosemite?

Después de instalar Yosemite, no pude preparar brebaje o Ruby. Estaba recibiendo este error en la actualización de cerveza: /usr/local/bin/brew: /usr/local/Library/brew.rb: /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby: bad interpreter: No such file or directory /usr/local/bin/brew: line 23: /usr/local/Library/brew.rb: Undefined error: 0 obteniendo este error en irb: /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/fileutils.rb:245:in mkdir’: Permission denied – /Library/Ruby/Gems/2.0.0/extensions/universal-darwin-14 (Errno::EACCES) from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/fileutils.rb:245:infu_mkdir’ from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/fileutils.rb:219:in block (2 levels) […]

¿Cuál es la forma sugerida de instalar brew, node.js, io.js, nvm, npm en OS X?

Estoy tratando de usar homebrew tanto como sea posible. ¿Cuál es la forma sugerida de instalar lo siguiente en OS X? node.js io.js nvm npm y con suerte apoya el desarrollo para: iónico ngCordova

Octave-Gnuplot-AquaTerm error: configure terminal aqua título mejorado “Figura 1” … tipo de terminal desconocido “

Instalé Octave y gnuplot a través de Homebrew y descargué AquaTerm.dmg. Cuando trato de trazar, recibo el siguiente mensaje: octave:4> plot(x,y) gnuplot> set terminal aqua enhanced title “Figure 1” font “*,6” ^ `line 0: unknown or ambiguous terminal type; type just ‘set terminal’ for a list` En un terminal set terminal bash, set Terminal , […]

Homebrew: instala nueva fórmula php72-imagick

Necesito instalar el módulo de imagick en mi php 7.2 Ya veo brew search php72 ==> Searching local taps… ==> Searching taps on GitHub… ==> Searching blacklisted, migrated and deleted formulae… No formula found for “php72”. Closed pull requests: … php72-imagick 3.4.3 (new formula) (https://github.com/Homebrew/homebrew-php/pull/4267) ¿Cómo puedo hacerlo? También necesito soporte para argón

Instalación de Nokogiri en OSX 10.10 Yosemite

Recientemente actualicé a la versión 10.10 de Yosemite beta, pero estoy teniendo problemas para instalar Nokogiri. Estoy usando RVM y Ruby 1.9.3. También seguí los pasos aquí e intenté seguir las instrucciones en la página principal de Nokogiri. He instalado libxml2 (2.9.1) y libxslt (1.1.28) a través de homebrew, y he intentado utilizar las herramientas […]

¿Cómo puedo cambiar a ruby ​​1.9.3 instalado usando Homebrew?

He instalado ruby ​​1.9.3 usando hombrew brew instalar ruby Pero el predeterminado 1.8.7 todavía se usa. ¿Cómo puedo cambiar OSX para usar 1.9.3 como ruby ​​predeterminado?

homebrew no funciona en OSX

Obteniendo este error cuando ejecuto el comando brew en la terminal. Necesito ayuda resolviendo /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:55:in `require’: cannot load such file — utils/popen (LoadError) from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:55:in `require’ from /usr/local/Library/Homebrew/utils.rb:6:in `’ from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:55:in `require’ from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:55:in `require’ from /usr/local/Library/Homebrew/global.rb:9:in `’ from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:55:in `require’ from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:55:in `require’ from /usr/local/Library/brew.rb:16:in `’ aquí están mis configuraciones de env gem: VERSIÓN […]