Articles of roid support library

Error de biblioteca de soporte de Android después de actualizar a 23.3.0

He estado usando el soporte de Android v4 23.1.1 y recientemente intenté actualizarlo a 23.3.0 (el último cuando esto fue preguntado) pero recibí el siguiente error: Error: Conflicto con la dependencia ‘com.android.support:support-annotations’. Las versiones resueltas para la aplicación (23.3.0) y la aplicación de prueba (23.1.1) son diferentes. Visita http://g.co/androidstudio/app-test-app-conflict para más detalles. Hasta ahora he […]

Agregar biblioteca de soporte al proyecto de Android Studio

Acabo de instalar el nuevo Android Studio y estoy buscando una forma de importar la biblioteca de soporte para Android. ¿Dónde está la opción para eso? En Eclipse solo quedan dos clics. Busqué en Google, pero no encontré nada. Sin duda es demasiado nuevo.

¿Cómo funciona la Biblioteca de soporte de Android?

Por lo que yo sé, la biblioteca de soporte está usando porque los dispositivos viejos no tienen nuevas API. Por ejemplo, no saben qué es Fragment y cómo implementarlo. Por lo tanto, estos comportamientos se definen en la biblioteca de soporte. Por lo tanto, mi principal pregunta es, ¿cuál es / son la diferencia (s) […]

TextInputLayout Sugerencia no flota después de actualizar Google Support Library

Recientemente, actualicé mi biblioteca de soporte a com.android.support:appcompat-v7:25.1.0 después de lo cual, si agrego un texto a EditText través de un archivo xml, la sugerencia TextInputLayout no flota. También eché un vistazo a esta pregunta pero no funcionó para mí. Aquí está mi código xml: Aquí están mis dependencias de gradle: dependencies { compile fileTree(include: […]

Error de Android – Causado por: java.lang.NoClassDefFoundError: android.support.v4.util.SparseArrayCompat

Tengo estos errores de registro al iniciar mi aplicación: > 05-20 01:48:35.312: E/AndroidRuntime(23032): FATAL EXCEPTION: main 05-20 01:48:35.312: E/AndroidRuntime(23032): java.lang.RuntimeException: Unable to start activity ComponentInfo{com.tomsyweb.suna/com.tomsyweb.suna.MainActivity}: android.view.InflateException: Binary XML file line #9: Error inflating class com.origamilabs.library.views.StaggeredGridView 05-20 01:48:35.312: E/AndroidRuntime(23032): at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:1651) 05-20 01:48:35.312: E/AndroidRuntime(23032): at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:1667) 05-20 01:48:35.312: E/AndroidRuntime(23032): at android.app.ActivityThread.access$1500(ActivityThread.java:117) 05-20 01:48:35.312: E/AndroidRuntime(23032): at android.app.ActivityThread$H.handleMessage(ActivityThread.java:935) […]

El fragmento incorrecto en ViewPager recibe la llamada onContextItemSelected

Tengo una aplicación que muestra algunos fragmentos (del mismo tipo) en un ViewPager y estoy teniendo problemas con los elementos del menú contextual. (Estoy usando la biblioteca de soporte). Cuando se selecciona un elemento del menú contextual en el menú contextual en uno de los fragmentos, el fragmento incorrecto recibe la onContextItemSelected evento onContextItemSelected . […]

Actualización de la biblioteca de soporte 23.2.0 error de comstackción

He actualizado la biblioteca de soporte a 23.2.0. Desde la actualización recibo este error en tiempo de comstackción: \ app \ build \ intermedios \ data-binding-layout-out \ debug \ values-v11 \ values-v11.xml Error: (67, 54) No se encontraron recursos que coincidan con el nombre de stack (en ‘android: actionModeCloseDrawable’ con valor ‘@ drawable / abc_ic_ab_back_mtrl_am_alpha’). […]

Error al usar elementos de biblioteca de soporte de diseño de Android

Error al inflar algo de la biblioteca de soporte de diseño xml build.gradle dependencies { compile ‘com.android.support:support-v4:22.2.0’ compile ‘com.android.support:design:22.2.0’ compile ‘com.android.support:multidex:1.0.1’ compile ‘com.android.support:support-v13:22.2.0’ compile ‘com.android.support:appcompat-v7:22.2.0’ proyecto build.gradle buildscript { repositories { mavenCentral() } dependencies { classpath ‘com.android.tools.build:gradle:1.2.3’ } } allprojects { repositories { mavenCentral() } } Error: Binary XML file line #115: Error inflating class […]

Aplicación dibujable de Android: srcCompat no muestra imágenes

Estoy usando la biblioteca de soporte para mostrar imágenes vectoriales en Android Kitkat. Cuando pruebo mi aplicación en Emulater, no veo ninguna de estas imágenes. Hice un diseño separado para Android lollipop y superior y funcionó a la perfección (creo que porque estoy usando el atributo src lugar de srcCompat Aquí está el código donde […]

Problemas de representación en Android Studio v 1.1 / 1.2

Cuando agrego android.support.v7.widget.Toolbar u otro android.support.v7.widget.* Hay problemas de renderizado. Pero la biblioteca de soporte está actualizada. Y cumplí en las dependencias adecuadamente. Puedo importarlos en MainActivity.java ¿Cuál es el problema?