Articles of rubygems

no se puede cargar dicho archivo – bundler / setup (LoadError)

Estoy configurando la aplicación Rails 4 con Ruby 2.0, pero estoy obteniendo “No se pudo iniciar la aplicación web” y obtengo esta traza: cannot load such file — bundler/setup (LoadError) /usr/local/lib/ruby/site_ruby/2.0.0/rubygems/core_ext/kernel_require.rb:53:in `require’ /usr/local/lib/ruby/site_ruby/2.0.0/rubygems/core_ext/kernel_require.rb:53:in `require’ /usr/lib/ruby/gems/1.8/gems/passenger-4.0.19/lib/phusion_passenger/loader_shared_helpers.rb:212:in `run_load_path_setup_code’ /usr/lib/ruby/gems/1.8/gems/passenger-4.0.19/helper-scripts/rack-preloader.rb:96:in `preload_app’ /usr/lib/ruby/gems/1.8/gems/passenger-4.0.19/helper-scripts/rack-preloader.rb:150:in `’ /usr/lib/ruby/gems/1.8/gems/passenger-4.0.19/helper-scripts/rack-preloader.rb:29:in `’ /usr/lib/ruby/gems/1.8/gems/passenger-4.0.19/helper-scripts/rack-preloader.rb:28:in `’ Mi apache2.conf es: LoadModule passenger_module /usr/lib/ruby/gems/1.8/gems/passenger-4.0.19/buildout/apache2/mod_passenger.so PassengerRoot /usr/lib/ruby/gems/1.8/gems/passenger-4.0.19 PassengerDefaultRuby /usr/local/bin/ruby bundle […]

Agregar un directorio a $ LOAD_PATH (Ruby)

He visto dos técnicas de uso común para agregar el directorio del archivo que se está ejecutando actualmente al $ LOAD_PATH (o $ :). Veo las ventajas de hacer esto en caso de que no estés trabajando con una gem. Uno parece más detallado que el otro, obviamente, pero ¿hay alguna razón para ir uno […]

Gemspec no válido debido al formato de fecha en la especificación

Cuando incluyo una gem que hice, gracias a Bundler (versión 1.0.12), en un Gemfile y luego bash agrupar o rastrillar así: $ rake Tengo este mensaje de error: Invalid gemspec in [/Users/zagzag/.rvm/gems/ruby-1.9.2-p180@foobar/specifications/myplugin-1.0.0.gemspec]: invalid date format in specification: “2011-04-21 00:00:00.000000000Z” Estoy en el último Mac OS X (10.6.4), con: $ ruby -v ruby 1.9.2p180 (2011-02-18 revision […]

joya install pg –with-pg-config funciona, el paquete falla

Cuando ejecuto (como root) gem install pg -v ‘0.12.0’ — –with-pg-config=/usr/pgsql-9.1/bin/pg_config Obtengo el siguiente resultado: #-> gem instal pg -v ‘0.12.0’ — –with-pg-config=/usr/pgsql-9.1/bin/pg_config Building native extensions. This could take a while… Successfully installed pg-0.12.0 1 gem installed Installing ri documentation for pg-0.12.0… Installing RDoc documentation for pg-0.12.0… #-> Cuando ejecuto bundle install: Installing pg (0.12.0) […]

La instalación de Nokogiri falla, falta el archivo libxml2

Siempre trabajé para solucionar los problemas de instalación de Nokogiri siguiendo la documentación del tutorial ” Instalar Nokogiri “. Pero esta vez, incluso después de instalar todas las dependencias, Nokogiri no se ha instalado. Obtuve el siguiente error: libxml2 is missing. please visit Intenté instalarlo especificando los directorios libxml2 y libxslt: sudo gem install nokogiri […]

Ya has activado X, pero tu Gemfile requiere Y

Cuando ejecuto rake obtengo este error: Ya has activado el rastrillo 0.9.2, pero tu Gemfile requiere rastrillo 0.8.7. Considere el uso de bundle exec. Usar bundle exec rake lugar de simplemente rake parece funcionar, pero ¿es la mejor manera de arreglar esto?

¿Por qué se instalan las gems en un directorio con una versión de Ruby diferente a la que estoy ejecutando?

Cuando instalo una gem, se instala en un directorio llamado 1.9.1, a pesar de que no es la versión de Ruby que he instalado: $ ruby -v ruby 1.9.3p327 (2012-11-10 revision 37606) [x86_64-darwin12.2.0] $ gem which rails …/ruby/gems/1.9.1/gems/railties-3.2.9/lib/rails.rb ¿Por qué pasó esto? No tengo otras versiones de Ruby instaladas (y ciertamente no v1.9.1).

¿Por qué estamos instalando Ruby 1.9.2 / 1.9.3 gems en una carpeta 1.9.1?

Esto se debe a que el directorio de instalación de Gem utilizado por el comando gem , que se ve al usar gem env , se configura de la siguiente manera: /lib/ruby/gems/1.9.1 Mi pregunta es por qué? ¿No debería llamarse la carpeta? /lib/ruby/gems/1.9.x o /lib/ruby/gems/1.9 o de lo contrario no podría haber uno por versión […]

Cómo manejar el error Ruby on Rails: “Instale el adaptador postgresql:` gem install activerecord-postgresql-adapter ‘”

Al ejecutar una aplicación Ruby on Rails (RoR) o un código Ruby que usa el marco ActiveRecord, aparece el mensaje de error: Instale el adaptador postgresql: gem install activerecord-postgresql-adapter Intentando correr: gem install activerecord-postgresql-adapter también falla, dejándote perdido.

La gem nativa ‘json’ requiere herramientas de comstackción instaladas

Tengo ruby 1.9.2p180 (2011-02-18) [i386-mingw32] instalado en mi máquina con Windows 7. Ahora traté de instalar la gem JSON usando el comando “gem install json” y obtuve el siguiente error. ERROR: Error installing JSON: The ‘json’ native gem requires installed build tools. Please update your PATH to include build tools or download the DevKit from […]