Articles of ubuntu

Cómo comstackr OpenCL en Ubuntu?

Pregunta: ¿Qué encabezados y controladores necesarios se necesitan y dónde los obtendría para comstackr CL abierto en ubuntu usando gcc / g ++? Información: durante un tiempo he estado tropezando tratando de descubrir cómo instalar CL abierta en mi escritorio y si es posible mi netbook. Hay un par de tutoriales que he intentado pero […]

VLC grabar la cámara web y transmitir a Chrome Linux

Actualmente estoy buscando cómo lograr lo que me han dicho que es posible. Me dijeron que podríamos usar vlc para transmitir una cámara web en Linux que permitiera lo siguiente: Grabar la transmisión a la máquina local para una carga posterior. Reproduzca la transmisión mientras está grabando con las capacidades de video HTML5 de Chrome. […]

El paquete Building R obtiene el error “ld: no se puede encontrar -lgfortran”

Estoy tratando de instalar el paquete lars. Ubuntu 11.04 Natty de 64 bits. Desde la construcción, obtengo: * installing *source* package âlarsâ … ** libs gfortran -fpic -O3 -pipe -g -c delcol.f -o delcol.o gcc -shared -o lars.so delcol.o -lgfortran -lm -L/usr/lib64/R/lib -lR /usr/bin/ld: cannot find -lgfortran collect2: ld returned 1 exit status make: *** […]

¿Cuál es el modo C predeterminado para el gcc actual (especialmente en Ubuntu)?

Cuando solicito ver la versión actual de cc, obtengo esto. $ cc –version cc (Ubuntu/Linaro 4.7.2-2ubuntu1) 4.7.2 Copyright (C) 2012 Free Software Foundation, Inc. This is free software; see the source for copying conditions. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. $ Lo que me gustaría saber es […]

Bash: error de syntax: redirección inesperada

Lo hago en un script: read direc <<< $(basename `pwd`) y obtengo: Syntax error: redirection unexpected en una máquina ubuntu /bin/bash –version GNU bash, version 4.0.33(1)-release (x86_64-pc-linux-gnu) mientras que no obtengo este error en otra máquina suse: /bin/bash –version GNU bash, version 3.2.39(1)-release (x86_64-suse-linux-gnu) Copyright (C) 2007 Free Software Foundation, Inc. ¿Por qué el error?

¿Cómo boost el límite máximo de archivos abiertos (ulimit) de Neo4j en Ubuntu?

Actualmente ulimit -n muestra 10000 . Quiero boostlo a 40000 . He editado “/etc/sysctl.conf” y puse fs.file-max=40000 . También /etc/security/limits.conf y actualicé los valores duros y blandos. Pero aún ulimit muestra 10000 . Después de hacer todos estos cambios, reinicié mi computadora portátil. Tengo acceso a la contraseña de root. usr_name@usr_name-lap:/etc$ /sbin/sysctl fs.file-max fs.file-max = […]

actualizando nodejs en ubuntu 16.04

Hace poco estuve revisando la versión del nodo en mi ubuntu 16.04 cuando se utilizó el comando node -v me muestra la versión 6.9.1 pero cuando nodejs -v muestra 6.9.2 anteriormente antes de usar este comando se utilizó el comando npm update . Ahora, ¿cuál es la diferencia en el node -v y nodejs -v […]

MongoDB no se iniciará después de la caída del servidor

Mi computadora Ubuntu se había bloqueado, y cuando reinicié MongoDB no funcionaba. Probé los siguientes comandos y obtuve el siguiente resultado: $ mongo Error: couldn’t connect to server 127.0.0.1:27017 src/mongo/shell/mongo.js:91 exception: connect failed $ service mongodb status mongodb stop/waiting $ service mongodb restart stop: Unknown instance: start: Rejected send message, 1 matched rules; type=”method_call”, sender=”:1.57″ […]

Falta incluir “bits / c ++ config.h” al comstackr de forma cruzada progtwig de 64 bits en 32 bits en Ubuntu

Estoy ejecutando la versión de 32 bits de Ubuntu 10.10 y tratando de realizar una comstackción cruzada con un objective de 64 bits. Basado en mi investigación, he instalado el paquete g ++ – multilib. El progtwig es un mundo de hola muy simple: #include int main( int argc, char** argv ) { std::cout << […]

¿Cómo cambiar el comstackdor predeterminado de GCC en Ubuntu?

He instalado gcc-3.3 / g ++ – 3.3 en ubuntu 11.04 que ya tiene gcc / g ++ – 4.4. Entonces, en mi sistema, tanto gcc-3.3 como 4.4 están disponibles. Puedo llamar a ambos comstackdores como quiera. Si solo llamo al comando gcc llamará a gcc-4.4. Para llamar a gcc-3.3, tengo que usar el comando […]